[1.29.28.0] Clean instal on a new PC : You are missing packages that are essential to run Microsoft Flight Simulator. Please update the application and try again

Hello.

I have a new PC and tried to install twice MFS but it failed each time.

Bought it from the Microsoft Store when it came out.

111 Gb of data to download then I arrive in the main menu.

I get a notification in the top right saying that « essential pack update available for download for a better experience ».

Click on it and it brought me back to the MFS update screen then I got the pop up saying « mandatory packages needed to launch MFS are missing. Please update the application and relaunch »

Of course I went to the Microsoft Store to see if there is an update but nothing.

I am desperate. I have downloaded twice 111 Gb for the same result.

I install the game from scratch. Really don’t understand how mandatory packages could be missing.

I am on 1.29.28.0 version.

Bought a PC back in 2020 for MFS but sold it and decided to stick on the Xbox Series X but after some thinking I found that I was really too limited in the choice of add on/ planes that’s why I decided to build a new PC.

1 Like

I’m having the exact same issue too. It only ocurred after a reinstall

1 Like

I have exactly the same problem, I’m currently reinstalling the game the second time today and I’m planning to try the following fix/workaround mentioned by user andyjb1037219 on 2nd August 2021 in this forum. As I’m not allowed to include links within my post, please feel free to use the forum’s search function with the above mentioned user id, good luck.
I assume this error is caused by corrupt config data files in the cloud.

I’m unclear as to what Code of Conduct requirement states that you can’t link to another post inside the MSFS Forum. That’s allowable in most cases.

This is possibly the post you’re referring to.

https://forums.flightsimulator.com/t/fixed-on-live-1-19-8-0-you-are-missing-packages-that-are-essential-to-run-microsoft-flight-simulator-please-update-the-application-and-try-again/427269/20?u=casualclick

I had to clean install the sim due to CTD issues however after the install I get the ‘‘You are missing essential packages’’ msg with my only option being Quit.
There are no updates on either the xbox app or microsoft store.
Any ideas how to fix this?

i already tried it and no results

I suspect this is something server related as yesterday afternoon i did not have this problem. It started occuring around 8:00pm CET after I started the first clean install.

Same problem after reinstalling to a portable SSD. It worked fine after the reinstal, fast and beautiful, but then when computer was swticted off and then on again later the dreaded blue message appeared: ‘You are missing packages… etc’. So why did it work in the first place??? This problem needs to be sorted out.

1 Like

Today, all the players who reinstalled MSFS have this problem. This is definitely a server problem. I hope Asobo will solve it as soon as possible!

Same issue, i’ve installed the game twice.

I got a message on the last install asking me to install additional packages needed for the game to work but I could click ‘do this late’.

After a restart I now cannot launch the game

Same problem here!

I removed:
“C:\Users\USER_NAME\AppData\Roaming\Microsoft Flight Simulator\Packages\Official\Steam\Asobo-aircraft-103solo-smallwheels-livery-xbox-aviators” and when I start the game it asks me for a small update of the plane in question, and I can play, but if I go out and come back I find the same problem, which I solve by deleting the folder again

2 Likes

Same problem. Even on 1.29.30.0

Same issue here. been working on it for 2 days now. trying many suggested solutions but no go. sent a message to ms. no idea what their response time is. wish i had an answer. If anyone comes up with a solution please post the details.

Yep, same issue. Reinstalled and getting the Missing Essential Package error and need to quit the sim.

I’m assuming there has been no word from Asobo on this, yet anyway?

1 Like

Same here, waiting for a solution for this error :worried: :roll_eyes:

Thanks for posting this I was almost ready to reinstall the reinstall.

I’ve tried to reinstall 4 times, now I’ll just wait for fix

Same here…I took drastic step and reinstalled my Win 11 OS and installed the sim…and I am starring “missing essential packages” “quit” with no option to update etc.

I notice one thing though. When i installed first time 5 days ago, the installation manager was showing 502 number of things to be installed.
Today it is 463…a total of 105GB,
Re-installing 3rd time now…fingers crossed.

Mine was showing 588 when I installed this morning.