100% reproducible CTD at specific coordinates for months [grammar.pggmod]

No mods here, so it’s not that for me. Lowering building quality to Low allowed me to fly through that area.

The two abrupt stops above the magenta line are with Ultra presets, online features on, and off.

The dashed line that flies mostly on the magenta line slightly further South is with UItra presets with buildings set to Low. It’s definitely a default scenery issue related to autogen buildings, not a scenery mod in the Community folder.

image

2 Likes

Without airport and scenery addons too?

Yes, as my screenshot shows.

I completed that flight with Buildings set to low.

No takeoff logged as is often the case with unt-towered airports as it asks for ATC clearance for takeoff that you cannot get. Near the end of the flight it still shows this, which is a different issue for a different thread:

image

I’ll now fly the reverse course, with Buildings set back to Ultra, and see where it crashes on the way back.

2 Likes

That’s somewhat common, actually. Apart from report it to zendesk and avoid the area there’s not much you can do. Will probably get fixed in a next world update.

1 Like

The reverse course crashed much further back than I expected:

It’s the line heading SW just above the yellow line:

So somewhere in this area:

I hope this helps. I’m now off to get some burgers, and watch episode 4 of The Mandalorian! :slight_smile:

2 Likes

I narrowed it down to a small area and the OSM buildings, when I exclude those I do not get a crash. Could you try with my fix add-on?

Rename to .zip and extract into Community folder:
package-laurinius-scenery-edlt.zip.pln (14.3 KB)
Project sources (rename to .zip):
sources-laurinius-scenery-edlt.zip.pln (16.5 KB)

The area where the problematic autogen is located is really small, you can barely see the EDLT airstrip in the lower left corner:


I wonder what the OSM buildings are, as the few houses in that spot are still build when I only exclude OSM (when I would choose exclude all there would be no buildings at all in the exclusion polygon.

Would be nice to know what its trying to do in the excluded area that causes the crash. And I wonder how much more of those tiny crash spots exist around the world.

6 Likes

Yes, I just flew over that area with Ultra presets, including Buildings set to Ultra, and I had no crash.

Well done! :clap:

Definitely log this with Zendesk, and include that mod folder as a workaround. That should assist with them fixing it.

I did empty my community folder before 3rd test, still CTD. I did notice the Paderborn Aerosoft airport is just south and still loaded through content manager. Also, I see some SPP security activity in 2 of the 3 CTD I experienced. Not sure at all if either is related, but could be possibly triggering something in Antivirus, although I do have Flightsimulator set as an exception and unblocked.(not disabled though)

Blockquote
Could you try with my fix add-on?
Blockquote

Yes, this fixed it for me.

You really gotta love the sim community
You guys should get content discounts for every ctd and mod that fixes stuff for consumers like me who have no idea.

The community mods have saved the game form

Well done fellas

2 Likes

Yep, major CTD just around the six wind generators. No add-ons, and never prone to CTDs in the past. Something evil this way comes…

1 Like

Well, there’s hope. My latest ticket regarding this issue (where I also included my findings and the workaround mod) was not closed with a default answer but re-qualified as a bug and assigned to QA.

Let’s see if it can help the developers to identify a root cause and maybe fix CTDs elsewhere as well.

1 Like

Just FYI, it still crashes after the latest update.

I haven’t revisited this myself. Does the latest patch still cause the CTD in that area?

Still having CTDs in the same area. However, the “faulting module” is grammar.pggmod in the Packages\Official\OneStore\bf-pgg\PGG\grammar.pggmod. The file date is 12/22/2020. According to the pggmod_version_info.txt it was created by Blackshark.ai GmbH. This might have been an attempted fix.

Yes, error is still there, but the patch I posted in this thread is still working fine.

They should already have all necessary information from my numerous tickets (including the grammar.pggmod reference in the error log) to reproduce this bug and hopefully fix the root cause, but I also got no further information since November when they sad they would assign the issue to QA…

1 Like

Thank you for the update! I don’t know why this problem would be assigned to QA unless QA interfaces with Blackshark. I am concerned that the updated file from Blackshark delivered in December is “the fix”. I don’t know if for each bug fix in an update or patch release ZenDesk contacts the person who opened the problem with ZenDesk and have them verify “problem solved”.

Googling my crashes with the module grammar.pggmod made me stumble across this and the first time i had this pggmod-CTD, i was at the exact same postition. So i also can reproduce this. I also issued a Zendesk ticket and they always closed it after telling me i should upgrade my drivers and remove all mods. -.-

FYI: I had this crash again today and thought there would be another area which causes the crash but it seems that I passed this location in the map again when I see my latest position on the map:

short link to your post for better follwing:

and… what ?

Of course if you have installed mod, then it is kind of default answer.

Confirm that you can reproduce the issue without mod and reopen the Ticket and also mention within the description these forum-thread here ( and possible OP can post its ticket id )

2 Likes

Hi all!
This topic has been re-opened to help provide feedback to the exception error: grammar.pggmod that causes a CTD in certain AI areas of the globe.

When reporting here, please report first to Zendesk then here. Include the ICAO airport code or coordinates.

Thank you!

3 Likes