100% reproducible CTD at specific coordinates for months [grammar.pggmod]

I did empty my community folder before 3rd test, still CTD. I did notice the Paderborn Aerosoft airport is just south and still loaded through content manager. Also, I see some SPP security activity in 2 of the 3 CTD I experienced. Not sure at all if either is related, but could be possibly triggering something in Antivirus, although I do have Flightsimulator set as an exception and unblocked.(not disabled though)

Blockquote
Could you try with my fix add-on?
Blockquote

Yes, this fixed it for me.

You really gotta love the sim community
You guys should get content discounts for every ctd and mod that fixes stuff for consumers like me who have no idea.

The community mods have saved the game form

Well done fellas

2 Likes

Yep, major CTD just around the six wind generators. No add-ons, and never prone to CTDs in the past. Something evil this way comes…

1 Like

Well, there’s hope. My latest ticket regarding this issue (where I also included my findings and the workaround mod) was not closed with a default answer but re-qualified as a bug and assigned to QA.

Let’s see if it can help the developers to identify a root cause and maybe fix CTDs elsewhere as well.

1 Like

Just FYI, it still crashes after the latest update.

I haven’t revisited this myself. Does the latest patch still cause the CTD in that area?

Still having CTDs in the same area. However, the “faulting module” is grammar.pggmod in the Packages\Official\OneStore\bf-pgg\PGG\grammar.pggmod. The file date is 12/22/2020. According to the pggmod_version_info.txt it was created by Blackshark.ai GmbH. This might have been an attempted fix.

Yes, error is still there, but the patch I posted in this thread is still working fine.

They should already have all necessary information from my numerous tickets (including the grammar.pggmod reference in the error log) to reproduce this bug and hopefully fix the root cause, but I also got no further information since November when they sad they would assign the issue to QA…

1 Like

Thank you for the update! I don’t know why this problem would be assigned to QA unless QA interfaces with Blackshark. I am concerned that the updated file from Blackshark delivered in December is “the fix”. I don’t know if for each bug fix in an update or patch release ZenDesk contacts the person who opened the problem with ZenDesk and have them verify “problem solved”.

Googling my crashes with the module grammar.pggmod made me stumble across this and the first time i had this pggmod-CTD, i was at the exact same postition. So i also can reproduce this. I also issued a Zendesk ticket and they always closed it after telling me i should upgrade my drivers and remove all mods. -.-

FYI: I had this crash again today and thought there would be another area which causes the crash but it seems that I passed this location in the map again when I see my latest position on the map:

short link to your post for better follwing:

and… what ?

Of course if you have installed mod, then it is kind of default answer.

Confirm that you can reproduce the issue without mod and reopen the Ticket and also mention within the description these forum-thread here ( and possible OP can post its ticket id )

2 Likes

Hi all!
This topic has been re-opened to help provide feedback to the exception error: grammar.pggmod that causes a CTD in certain AI areas of the globe.

When reporting here, please report first to Zendesk then here. Include the ICAO airport code or coordinates.

Thank you!

3 Likes

Zendesk ticket was raised and accepted as a bug as follows:

Request #105223 CTD at specific location coordinates - NINUK - 30°52’37.0"N 072°49’34.0"E

Support Tuesday at 20:05

Hi Khurram,

Thanks for bringing this matter to our attention.

This issue has been tracked in our internal bug tracker. Our QA team will review the information and try to reproduce the issue. Bugs and issues that have been successfully reproduced will be categorized and prioritized—game-breaking bugs will receive the highest priority, while middle-of-the-road and cosmetic bugs are prioritized based on reproduction and the number of times reported.

We’ll come back to you if we need more information or if we have troubleshooting steps to recommend.

Kind regards,
Microsoft Flight Simulator Support Team

Can refer to this thread for other related discussion. Try for yourselves - try to launch a flight from OPRQ and should CTD.

2 Likes

Just to confirm that Sim Update 4 does NOT fix this CTD I’m afraid. Still able to reliably reproduce the grammar.pggmod crash at the mentioned locations.

That rings a bell. Reducing building quality in graphics settings to Medium was a workaround for one particular area months back.

I think my original CTD location near EDLT has been fixed (since SU4?), just flew circles in that area without my patch and got no CTD, before it was a guaranteed CTD when entering that area.

1 Like

e.g. this one still exist

thus seems the main issue , somewhere within the impl, exist furthermore.

I’m having the same issue northwest of RPMR airport.

If anyone has some spare time, can you help check if you can replicate this CTD? Here are the replication steps:

  1. Load into RPMR airport
  2. Slew/Fly on a 321 degree heading until you reach the hills on the left side
  3. CTD occurs at the end of the breadcrumb trail

Managed to take a screenshot a few seconds before the sim crashed. This gray untextured area seems like the culprit:

A single Minecraft tile. How strange! I don’t have my gear set up right now, but I’ll try taking the drone over that way.

I can see that tile from the airport.

I crashed just as the drone camera was probably a mile away from it.

Took the plane up just so I could get a trail also.

6° 9’ 34.97" N 125° 0’ 50.87" E

image

Much like Z’ha’dum, those who visit “malo basag tboli” never return.

Incidentally “malo basag” means “bad crack” in Filipino if Google Translate is to be trusted. Seems appropriate here.

And Tboli is presumably referring to the Tboli people of Southern Mindanao.

The crash is indeed one of the grammar.pggmod ones:

Fault bucket 1435457293547054447, type 5
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.FlightSimulator_1.17.3.0_x64__8wekyb3d8bbwe
P2: praid:App
P3: 0.0.0.0
P4: 60c0b1e3
P5: grammar.pggmod
P6: 76.0.0.3
P7: 608bf361
P8: c0000005
P9: 00000000046e3f59
P10:
3 Likes