21/25 planes have become " non -flyable "after world update III

I just wonder whether anyone here has had similar experience as I have :

After I installed the new world update III recently , 21/25 of the planes become non-flyable , namely, these 21 planes all stuck in loading screen with a blue full loading bar forever . I have re-downloaded and re-installed the program many times with no luck , which needs 5-6 hours to complete a process every time. I also have looked at contentment management section , which reveals all the contents have been installed.

anyone has got a better idea?

1 Like

Maybe uninstall one in content manager and track down and delete the files for it and then reinstall it as a test? Worth a try.

if you’re getting stuck on the blue loading bar, your first step should be to disable/remove all mods and liveries from your community folder (easiest done by simply renaming the community folder).

If this solves the issue, add the mods and liveries back one by one to see which one is causing the issue.

Hi thanks for helping .
I actually don’t have any modes or community file installed , all “official “ they all worked perfectly before the update.

I understand these files are located in user-/ …and I have seen all plane‘s fils there . Deleting and reinstalling them don’t solved the problem. The msmf ‘s exe file is actually under program direct . Not sure if there is any other location apart from these 2。

I am also having the same stuck on blue bar problem. I have tried several locations but only with two aircraft, namely 172 and A320. Remove content in the community folder didn’t work for me. And it’s just too time-consuming for me to re-install the game(took me 30 hours to install it due to bandwidth limit).

I am now just hoping that Asobo can release an update sooner for me to see if it can fix the problem. Currently sticking to XPlane and can’t enjoy the new UK update. :frowning: