5hrs into a TBM930 flight, cockpit unresponsive to mouse clicks

Brief description of the issue:

Flight was perfect for 5 hours. Then the cockpit stoped visually responding to mouse clicks. Some clicks are read and acted on, but no visual change happens. Some clicks are ignored entirely. Mouse wheel continues to work fine.

I’ve only had this twice a few months ago.

If you wait between a few seconds to 15 minutes (in my case) or so all the clicks you did in that time start to catch up and everything works again. I expect there is a particular thread that stalls for some time. It would be interesting to know what is actually happening.

Thanks for that. It’s been over half an hour now so I’m not sure it’s going to recover.

Now to see if I can complete the flight without needing any cockpit clicks - I have most things mapped to other controllers…

I’ll let you know it it recovers.

Cheers

Man, and I thought 15 minutes was excessive!

It would be good if we could work out why it happens. I think this one would take a ton of effort for the devs to fix if it is so hard to reproduce.

I’ve seen this as well today with the steam C172 with frequent HDG changes and also with ignored clicks on the upper GPS when attempting to enter a direct course. It eventually frees up to operate normally, but it can take several minutes to do so.

What’s interesting about it in this case is that it’s isolated to a fraction of the displayed area, whereas other screen freezes - that can happen when changing to/from real world weather where the sound continues but the entire sim is frozen and unresponsive up to several minutes before it too recovers.

It seems my situation was different.

No cockpit clicks showed any visual feedback (numbers not changing, switches not moving), although some fo the clicks did complete their action and have an effect on the sim, but I was flying blind to a certain extent.

I left if for 1.5 hours and it continued to fly OK, but with mouse clicks ignored. Mouse wheel was fine on numerical knobs, but would not move switches.

I tried going into control settings and setting up a new control just to make it possibly save and re-read the control assignments. No better.

I tried unplugging the mouse completely and re-connecting it. No better.

After about an hour and a half, all input response stopped, including keyboard and other controllers. Then I noticed that the sim had now frozen.

I checked in the TaskMan and sure enough, “Not responding”. So I killed it.

First time I’ve had a total loss of input followed by sim freeze, but without a CTD.

I’ll ZenDesk it.

The unresponsive cockpit issue, not the freeze, can be resolved by opening one of the docked windows from the top menu, such as the VFR map, or ATC. Click on that windows title, then close it again, and the cockpit will become responsive again.

Since the OPs system froze later, it may not be this, but it sure sounds like it.

Thanks for that. I will try it if it happens again. It was a first for me. As was the freeze without CTD.

Has your info been Zendesk’d?

Many times, I expect.

Good stuff.

More info.

I repeated this flight.

The crash happens as I cross the international date line. So it is a bug.

Some users are flying transatlantic flights I believe, so presumably they aren’t crashing. They wouldn’t be doing it in a TBM, though.

There is a bug in the ASOBO G3000 which doesn’t draw routes which cross the international date line. The pic below shows this bug. The curved purple line is the correct route. The straight purple line is the error, and ‘reflects’ from the IDL.

No route is shown beyond the IDL.

As you cross the IDL the curve then redraws from the plane forwards, and there is another straight line in error shown bouncing off the IDL and proceeding ahead of you, so the opposite of what you see in this picture.

You don’t need to be doing a trans-oceanic flight to experience this. You could be flying around southern Alaska, far out into the Pacific etc. It is a bug in the sim with no mods loaded.

There is a separate and perhaps linked bug if I load the 0.34 G3000 mod into the sim. With that in place the sim crashes with a solid lock moments after crossing the IDL. I’ve reported that to the author of the mod.

Lastly, I had an apparently unrelated CTD today flying the TBM930 on a very long flight. I was doing the flight as a robustness test before bothering to set out on a round the world flight soon. After about 7 hours in the TBM at cruise altitude the sim CTD’d. I’ve done many other long flights previously without CTDs. Also this CTD was over China, so the IDL was not involved.

It may just have been a freak bug, but something is obviously not quite right somewhere.

Hello SIedDriver,

Did you get a chance to solve the issue using hobanagerik’s workaround?