60+ fps but massive stuttering (10900k)

So I upgraded from a super old 3930k to a 10900k and now I am getting terrible stutters.

Even if I set the game to low, when in bush areas, I get over 80fps but with terrible stutters as if it was running below 30.

I’m not sure if it’s the new patch or the new cpu but it really sucks. With my old cpu, doing around 60fps, the game was smooth, now I get similar fps but it’s so stuttery.

I am running a 2070 btw. On a fresh windows 10 install version 2004 with latest nvidia drivers. 10900k is overclocked to 5.1ghz.

1 Like

I have a 9900k + 2070 super and same issue
Getting great frame rates but stutters that kill the experience. I don’t know if there is anyway to document stuttering besides just playing and going by your own experience.

I keep trying different things, seems the best result for my setup so far was to:

Turn off Overclock - This seemed to make the biggest difference, running stock speeds lessened the stuttering

Process Lasso - Use the app to disable “Windows dynamic thread priority boosts enabled (*)” and then set FS2020 priority to Below Normal (which seems counter intuitive but some reason it seems to improve)

On my system, it appears that FS loads up one core until it stutters (in dev mode whenever i get a stutter i see the main thread warning). I think they need to optimize the game a bit more to distribute the load better.

2 Likes

Thanks I’ll try those and report back. I saw some guy lower his rolling cache size and apparently it fixed his stuttering. I will also try that.

It’s weird as my old cpu didn’t have this issue, was like a 10 year old 6 core. The thing is that by the time I tried the game on the new hardware, the update was already out. So i’m not sure if it’s the update or the new cpu that’s causing it.

I turned mine off completely which (hard to say at this point lol) seemed to help as well.

Some say turning off live traffic helps alot

If you’re getting 60+ frames you should

  1. in your video card Cp set your refresh rate to (custom if need be) say 50fps
  2. in FS11 VS=ON Even though FS11 will show 60, you will be running at 50fps.

No offence but using more software to increase performance is redundant imho. (process lasso)
a 10900 + 1070 at least on a single monitor should run quite well
@ OP, how much and what ram do you have, what is your hard drive?

On my old cpu I didn’t make any changes to refresh rate or anything, it just worked out the box. 60+ FPS on high/medium and really smooth (it felt like 120fps+ really, that kind of smooth).

Now even with higher FPS like 70-80 it’s just not smooth, it’s very choppy like micro stutter.

My ram is 16gb 3733mhz. My old ram was 16gb 2133. Hard drive is evo plus nvme.

Oh and I tried all the above fixes and nothing worked. Still good FPS but choppy.

Guys,

it’s a widespread misconception that a high frame rate equals smooth gameplay - at least for flightsim purposes. What gives me the best results is to aim for settings inside the simulator that provide a stable framerate of well more than 30 fps under all circumstances (I’m running mostly “High” settings on an i9-9900k with 5.1Ghz on all cores and a RTX 2080). That’s crucial, 30 fps and more under ALL circumstances.
Than I have two options:

  1. I can set a custom resolution inside the Nvidia Control panel with a 30Hz refresh rate. My monitor supports that. Than I select “vsync on” in MSFS, in my case I choose a maximum refresh rate of 60, you may try 30 if that gives you a smoother result. The downside of this is a laggy mouse cursor.
  2. My preferred method: I use Riva Tuner Statistics Server (RTSS) ver. 1.2.2 (it may work with later versions but I haven’t tried). I set up a profile for MSFS ( hit CTRL and “ADD” while MSFS is running and it will show you flightsimulator.exe). In that profile klick on scanline sync until it shows “scanline sync x/2”. In the box behind it set -10. In MSFS deselect (YES!) vsync.

What both methods do: they synchronise the framerate of the Sim with the refresh rate of your monitor. And that gives you a smooth expierience despite it being “only” 30 fps. If the Sim can’t keep up at least 30 fps - well than you are back to stutters unfortunately until you lower your settings ingame.

1 Like

Unless there’s some weird micro stutter case, like the one I’m having now, higher frames is smoother. Just because it’s a sim doesn’t mean anything. At the end of the day it’s game, and panning around with low fps is going to look choppy on any game. Especially being used to using a gsync monitor.

Like on my old cpu (3930k) The 60-74fps I was getting was very smooth. Now new cpu with the same gpu, I get higher fps but its noticeably choppy.

I’m going to try and put my gpu in my old system to finally see if it’s the new cpu or the new update that’s causing this issue, as I’m out of ideas at this point.

TLDR. Try lock your frames to 50 in Nvidia control panel

On medium/low I can get 120fps. Why would I lock it to 50. What the hell are you people on.

I had same issue on a similar processor 10700k and 1080ti.

This is how I solved it:

  • go to bios and disable hyperthreading

  • disable speedstep technology and any other option that can throttle down CPU

  • on Nvidia control panel do no activate Vert Sync (set it off)

  • on game settings, set resolution to 1080p and enable vertical synch locked at 60

  • use reasonable settings, mixture of ultras medium and high’s

  • do NOT use jets they clearly have a performance issue which hopefully will be fixed in this month’s patch. Test with Cessna 172 and see if you have stutters.

Thanks these sound promising I will try them. I’ve only been flying with the Cessna 152 for the same reason you stated.

I’ll try these and report back, cheers.

Maybe because the “60-74 fps” was more in sync with your 60Hz monitor? When you set RTSS to “scanline sync” it will fix the output of the sim to 60fps instead of 30. As long as you can maintain 60fps+ you will be fine.

Nope!

My monitor is 160hz.

@Bevilax @FlipperJeans470

Well I fixed it. It was gsync. Since the game is not exclusive full screen, gsync wasn’t kicking in.

To enable it use Nvidia Profile Inspector to select the MSFS profile and set the two gsync settings to “full screen and windowed” like this: https://i.imgur.com/GdLhtIC.jpg

You’ll know gsync is now working because in the loading screens the FPS won’t be something ridiculous like 800fps, they’ll be capped at your monitors refresh rate. Use Msi Afterburner or something to display fps. You can also use the Gsync indicator in the nvidia control panel to confirm its working.

You must use nvidia profile inspector, the nvidia control panel “windowed and full screen” gsync setting won’t do it.

This fixed it for me. Silky smooth and no more weird micro like stutters.

For the record: hyperthreading is enabled plus cpu overclock, and windows power profile set to “high performance”. These are all the settings I set on my pc. And this is with vsync set to off in game btw.

Good luck all!

2 Likes

All my settings were already as in the image, so I couldn’t change them. Did you maybe have old version of drivers or geforce experience? I never had a problem with > 120 fps with my global monitor settings on Fullscreen and Windowed. Maybe it has to do with multi monitors and which one is primary…?

Check the settings for the msfs profile not global - this is on nvidia profile inspector btw.

This was a fresh windows install for me, so no previous drivers and I only have one monitor.

Ok so you didnt have latest geforce drivers installed? I suspect the latest drivers maybe set these options by default. I also used the inspector and as i said everything was already preselected for microsoft flight simulator.

Me too, 9900k with 2080S. Only in big airport with lots of traffic. I think it’s the problem is the traffic but I enjoy live traffic and multiplayer and I don’t want to turn it off