747 Autopilot LNAV RNAV Rudder Problem

Hi,

iv’e got a rudder issue.
If i fly with autpilot enabled (lnav/rnav on) the rudder is not centered.
I tried to reinstall the simulator, but it still is not working.
If i disable the autopilot, the rudder is centered.
Is this a known problem?

Screenshot: ibb. co/1L30Gkn

Does this affect the plane, or is it just cosmetic?

Unfortunately it does affect the plane. You also can see the effect on the screenshot.
The plane does not fly straight. With autopilot enabled, it’s always crooked to the right.
Am I the only one, who got this problem?

Well… I realized sometimes that my plane heading and route are slightly different. I’ve never checked if the rudder is turned like yours… I will check and report on bridge :cowboy_hat_face:

No, there are several posts on it.
If you are using a controller, do you have a big enough dead-zone?

Thanks @everybody for your help. I also disconnected the controller and flew by keyboard only. It was still the same.

1 Like

That’s probably a wind correction.

1 Like

I think this is Deadzone problem. Please Check rudder and etc Deadzone of your controller. Too tight deadzone setting can make Autopilot issue.

The rudder is not used to correct for wind.

I get the feeling this is more related to ailerons than rudder.
If your controller is applying a gentle bank to the aircraft, you would be constantly making an adjustment for it when not using autopilot. When you engage auto pilot the input would still be there and not enough to cause the autopilot to disengage so the only way the AP can hold the heading is compensate with rudder trim to offset the roll tendency.
A throttle imbalance could cause the same yawing effect but I expect the autothrottle would compensate.
It would be useful to know what controller you are using, when not using the keyboard.

1 Like

I just tried the 787 Dreamliner with enabled rnav lnav. I do not have the problem with that plane.
By the way, I’m using a pxn-2119ii controller.

1 Like

I fly in the 747 now and again, not once I had a problem with the aircraft movement, on the post above you said dreamliner is fine, maybe redownload 747?

file size should be around 1GB, To redownload, on the main menu… on the top ‘profile’, then ‘content manager’ somewhere on the list should say Asobo 747… tick the box on the left… uninstall, then press install button for 747, download, also just to be sure after downloaded… reboot the sim

Im having the same issues with all my aircraft. It only happens after i engage the autopilot on all aircraft. I just tried it on the cub with same issues. First noticed it on the 747 and then tried the a320 with the same effects. I can fly manually without issues and maybe a minute or two while engaged in autopilot it does it. Is there an actual fix for this? or is this just a bug after the last update?

This is what happens to me every time after 5 mins or so, flying 747 on autopilot. (see the rudders?)

Not pressing any buttons, and taxiing was fine.

After activating AP, watch your trim settings. Aileron and rudder trims stay static or are they creeping?

Aileron trim shows on the screenshot to be 0 / neutral, not sure about the rudder trim though…

Noticed: the rudder reset doesn’t work, it does nothing. I’ll try to fly a bit…

After about 8 mins of flying with autopilot…

Oh, and just to clarify, this does NOT happen, for example with 787 (which has other issues, like taxiing, which is impossible all together).

Not fun! Who ever resolves what’s going on, gets a cookie.



Doing a search for similar problems may help you out.