9 hours and still trying to download updates

Its been nine hours running and still downloading. I tried running as admin, turning off firewalls etc… this is crazy

When I bought the deluxe version for $100+ month ago, i figured that was the download. No idea i would be downloading for 24+ hours for the a 40gig file


I’m up to 18. And not through lack of speed (my end or theirs). It is just broken.

The problem is, I can’t even find anywhere near me that has the physical version to buy and install.

same here

7 Hours yesterday, today 20

Flight simulator still can not be downloaded …

Honestly i am very dissapointed of your service, when i wrote i got no answer and not even the purchased money back

tried it on 3 Computers now always the same

This has been nothing but a nightmare… I have 100gb down, no other problems. Installed onto SSD with tons of space, and I even checked the internet tuning on windows 10 as they recommend. But the download went from 5% to 23% after 14 hours… this is insane and excruciating. Please advise a fix to get on a better CDN node…

Hi @SargeLive, the only real option you have to get to a better server is a VPN – there are a few out there that offer a free trial if you don’t have one already.

Report back too if you end up trying it and let us know if it made a difference (or not).

yes, its a catastrophic - WHY is no one solving the Installation Issue?

1 Like

There is no physical version. You can only download it.

Don´t worry, mates… 11 hours yesterday… Started half an hour ago and still 52 gb to go …

But anyway … it is summer … so let the pc do the work and do something nice outside in the green … or at least to get some tan …

Woke up this morning around 7:00 a.m. and it was finally loaded and done. Took my first flight 30 minutes later and it sure is nice.

it still is not working

intsllation bug

really, it worked? HOW did you do that? ?

People, if you have a fast fiber internet connection and it still downloads very slowly, you can try turning on autotuning to normal

please open CMD as admin and type in:

netsh interface tcp show global

Make sure Auto-Tuning is stated as : normal and not disabled

if it is disabled use the command:

netsh int tcp set global autotuninglevel=normal

Restart your PC, open CMD again and use the show global command again to make sure it’s still correctly set on normal and then try downloading MSFS2020 again, for me that helped A LOT, I was able to download almost at my full speed and had the game ready after less than 2 hours.

Yes, how many here have tried the steps suggested by support? Have they even looked? If so, you should say something like “I tried the tips from support but they don’t work, I’ve logged an issue with the help desk and suggest everyone that still has a problem do the same”.

We also saw one person that had horrible speeds because his ISP has a small pipe from where the server(s) are located in the US. He contacted his ISP and they fixed it. Anyone still having the problem tried that as well?

It is pretty obvious that if thousands of us could download it quickly, and still do so right now, then it isn’t simply “their CDNs are slow”.

ehx do developers do such a immense software, when on 30% it doesnt work