A lot of CTD's after update

Updated this morning, and now the sim seems to be running very flaky. Graphics performance is good (I don’t monitor FPS but it feels nice and smooth), unfortunately two of the three flights I’ve tried so far have ended after only a few minutes with a CTD and the G2 going back to its home screen.

I’m running an i7 10700k, an RTX 3080, 32GB RAM, Win 10 and Nvidia drivers up to date. Neither CPU or GPU seemed particularly stressed, max CPU temps in the 80’s, average temps in the 50’s. Max GPU temp 73.9 but I think it’s being worked a bit harder as the fans are running higher than before.

Anyone else getting CTD’s in VR? :frowning: Very rarely had them prior to now.

Same boat for me :frowning:
Running an i9900k at 4.9 Ghz and 3081 Ti, 32 gb of ram.
Max CPU temp 70, GPU 76. Nothing more than before.
G2 also, drivers up to date, as Open XR dev tool.

1 Like

Remove all community add-on also disable AI traffic know as CTD issue

1 Like

Quick update, not sure whether it’s relevant. The CTD’s were using the new 172 float plane. Just tried again with the stock 172 and was able to complete a short flight (in the same location) without a CTD.

As mentioned in the OP, my CPU temps are a little higher in the mid to high 80’s max (average below 60) and GPU max temp is 73.9, but I know it is working harder as the fans are going higher than before and this is pushing the CPU temps up a little I think. It’s also warm here, but of course no different to before the update.

I have just two mods in my community folder, the Working Title CJ4 and G3000 ones. As for AI traffic, I do have it enabled (not real world) but at very low levels in the VR settings.

Update content manager as well.

Hi all,

In the same boat as the rest of you. Constant CTDs. Up to 10 so far. All within 3 minutes of the start of the flight.

I’m running a W-3175x, RTX 3090, 96GB RAM, Reverb G2, everything up to date. CPU is at 7% utilization, RAM at 17%, GPU 90%+, then crashes.

I haven’t had a CTD in months. I’ve followed the suggestions posted by @ExpressTomato52, no luck. Let me know if any of you find a solution.


1 Like

No issues for me. Seems to be running smooth and stable.

Intel 9900K
Reverb G2
32GB Ram
Everything up to date driver wise.
Everything OC’d

Same problem here. Constant CTD’s, which I hardly ever encountered before. Reverb G2, i7 9700, TTX 2070S, 32 MB. All up to date.

Constant CTDs here too - in fact I can’t even get the in-game update. I only did the store update and can’t go beyond launching in the in-game installation manager…

I had a lot of CTDs only in VR, and it seems to stem from not just AI traffic, but using this setting:

I was using not generic AI models and had TON of CTDs, but only in VR. Now I haven’t had any yet. . .knock on wood! The non-generic models for Multiplayer doesn’t seem to have as bad an effect.

I’ve tried to start the sim twice. Both times, it crashed. The first time it took 17 minutes of load time to get to the crash…never opened the airport. The second time took 14…again…never opened the airport. No notification. No idea what caused it. WT CJ4 and a default airport. Not sure this sim is even flyable any more.

Same here, can’t fly for more than a few minutes and CTD. I do have a bunch of updates in the content manager, will go through all those and see what happens.
When it is working though IT IS AMAZING, getting close to 60 FPS with full ULTRA.

So, have not managed a single flight in the 172 float plane without a CTD. Had one in the standard 172 which was Ok. Just tried jumping into the TBM 930 to see whether that one would work Ok, but the throttle doesn’t work with that (I have the newest WT Mod released today), so for now I think I’ll give it a rest and see whether things sort themselves out in the next few days.

The sim does seem a little smoother, but does seem to be causing my CPU to spike a bit hot at times.

As soon as I power up my Reverb G2, the sim freezes. Was working just fine before the update. The music still plays and the mouse cursor moves but I can’t select anything.

I have had several CTDs after updating. First CTD occurred after trying to load a discovery flight. CTD look place moments after clicking the fly button. I had not yet entered VR mode. I restarted the computer and MSFS and created a flight in the keys - Marathon to Key West in an A5. Flight loaded normally and I entered VR. Sim ran spectacularly for 10 minutes and then CTD.

Running a i7 10700k, an RTX 3090, 32GB RAM, G2 Win 10 and Nvidia drivers up to date. I emptied my community folder before installing update 5, and I reset the cache after installation and before trying any flights. Live traffic was on.

I have the same problem. The sounds still play and the mouse is movable but you can’t click anything.
What I have found is that the sim has not actually crashed but is just in a very long pause. If you wait 2-3 minutes it seems to come back and all is well until it does it again. Very frustrating.


Complete opposite for me, AMD rig with G2 headset. I gave it away in VR as I could never get a flight that didn’t CTD with that set up. Today I’ve had no CTDs at all, just one instance where the program froze when attempting to change some settings.

Had some great flights in VR today, especially as I don’t need glasses anymore after cataract surgery.

Yep yep yep, lots of CTDs for me, even in the menus at various stages. This really needs a hotfix. So many peoplr seem to be affected

CDT within 6 to 8 minutes of flight every, 20 plus, times. Numerous aircraft and locations. With and without any USB peripherals (have 22 Saitek devices). With or without cache, AI aircraft etc. Community folder has been deleted. No help with event viewer. ASUS Maximus/9900k@5.1, ASUS Tuf Gamer OC 3090, 64Gig of ram, 2x2TB Samsung EVO Plus 970 m.2 NVMe SSD’s, Samsung C49RG9X@ 5120x1440 and there is a 2nd smaller monitor for mapping etc. Have a G2 but not using it with this update, yet! Rarely had any CTD’s prior.

PLUS side, gained 15 to 25 FPS on all Ultra settings including from EGCL over London. 45+, clarity is amazing while it lasts.

The first launch and immediately CTD … I’ll try to configure now. Vive, 7700K, 1080