A320: Autopilot has gone Rogue. Should be rather called AutoDisaster

I had put up this issue yesterday, now bringing up this again that the autopilot of the A320 is behaving randomly like a drunk bird in the sky. Its not following the flight plan. Making random turns, left or right, mid flight. Also, While Doing an ILS landing on Prague airport with LOC mode on and stablized, at 300 ft the plane started turning to the right and Started flying in the other direction away from the airport.
The plane can no more be trusted with full flights From one airport to another because all your flight Plans, all your navigation, all the approach planning could possibly go in vain, if this broken plane starts
doing random things on its own.
If the level of flaws would continue like this, this much celebrated flight simulator would become a 100GB garbage.

14 Likes

Just set your self to start from a ramp or gate and do no further flight planning until you are at said ramp or gate, then use the MCDU only to plan your flight including waypoints along the way.

I have had zero problems with the AP in the A320, but I do all my flight planing in the MCDU.

Okay. Will try this fix By not entering the destination airport in the pre-flight selections and hope it works. Thanks for the idea.

If all else fails sit there with a claw hammer and personally threaten it to behave or suffer the consequences.

That’ll teach it to behave, believe me. Worked on my wife anyway!

1 Like

The A320neo not following the FP on AP has been mentioned frequently on here since the patch. I also encountered this problem the other day flying KLAX-KLAS as my default A320 kept banking left and eventually just making a circle. I ended the flight and came on here to find a solution. The fix seems to be making sure your joystick/control deadzones are not set to 0%, but rather to say 5-10%. I changed mine to 5% and I’ve never had the problem since. I suggest trying that first if you haven’t already!

3 Likes

It might sound stupid but have you tried to set “ground vehicle density” to 0? Try this from main menu rather than pause menu.

Wives may listen. But this plane won’t. :smile:

2 Likes

Thanks, looking forward this fix to work for me as well.

Well Anything that works :blush: until the developers gives us a permanent solution. Thanks

If it works it would be nice to provide feedback. Thanks and best of luck.

@judgedrebb Certainly. Thanks

1 Like

I’ve got the same issue but the dead spots don’t see to work for me. I’ve unplugged my joystick and ta’dah! it works fine… its an unrecognised joystick to the game… so this could be the issue

This could actually be true for me as well. I am using a CH Products Flight Sim Yoke, which is not recognized by FS2020 but works fine manually assigned - I thought. Guess I will have to buy a new joystick/yoke. Ahh, this makes me so sad I wish I had a bottle of wine instead, but all liqueur stores are closed in Sweden for the weekend. So no FS2020 and no booze, guess I must be social with my family instead :rofl:

1 Like

the problem is still there i was using a320nx mod and manually input the waypoints in MCDU and ones i turned the AP on the plane started turning right it just does what it wants.

1 Like

Is your joystick not recognised by flight sim by default? As meaning you had to manually configure the joystick at first setup? If so it seems like this is the issue

I performed three back to back landings at Prague airport using the fix suggested by @B101UKNo1 and @FearlessTiara18 , and it seems that now the A320 autopilot is not missing the flight path and also maintaining the alignment with the runway. I did the following-

  1. I am not selecting the destination airport in pre flight menu. Rather I just select the Departure airport because it’s a minimum requirement to enter the simulation. Now in the MCDU, I am entering the ICAO of the departure and destination airport manually.

  2. I adjusted the dead zones of my joystick/side stick to 5 %. Earlier the dead zones were at 2%.

With the above settings I performed 3 test flights at Prague airport- departure from runway, circling the airport and then landing. And in none of the tests, the plane missed the flight path.

I think these fixes are working. Thank you for the suggestion.

I just had this issue. i have set the flightplane from MCDU but the plane , once in airborne, started going right without following the flightplan…

2 Likes

Yes this has worked for me as well

No no the joystick was recognised by default, I did no setting. Now I have adjusted the dead zone to 5 %. Also, making flight plans through the MCDU only. it’s working.

Have a great weekend :blush: