A320 Neo will rotate at specific waypoint althought before it following path

Now days i found issue with a320 neo default and flybywire also .After takeoff i engage autopilot then it works well. After 1 or 2 Waypoint it start turnout from path and rotate somewhere else. Please help me.

Start with these four steps.
If you have done these, and the problem persists, let us know.

  • Set Flight Model to modern, not legacy.
  • Assists settings should be set to Hard/True to Life.
  • AI Copilot control should be off.
  • Add deadzones to all your axis controls. Approximately 5%, (sometimes a bit more or less) may be enough.

Sometimes I got this issue too and my solution is disengage autopilot and engage autopilot again, aircraft would continue follow autopilot.

I have the same issue. I have modified the settings as you suggested and also switched the autopilot on and off but still have the same issue. When I engage the autopilot the A320 (with FlyByWire mod) it sets a heading of 180 deg. The only way I can continue on my flightplan is to keep using the Direct To option in the MCDU to follow the plan. Its strange that some people don’t have this issue and others do! Anyone have any other suggestions?

At what point in the flight does this occur?
Is it just after take off when you engage the AP?

When I engage the autopilot. Every time.

Should have stated that the aircraft responds correctly when the autopilot is not engaged.

Do you use a joystick, if so, what kind?

No I use a Honeycomb Alpha Flight Yoke with a Saitek Quadrant for throttle, etc. when the autopilot is disengaged it controls the aircraft really well.

Thrustmaster’s do seem to have some issues with this sim, which was why I asked.
Honeycomb’s, I haven’t heard of too many issues with them.
Which particular type of the mod are you using?
How big a deadzone did you put in?
When this occurs, is the plane following the flight director bars on the PFD, or are they going opposite to the turn?

Firstly to answer you questions. Using FlyByWire 0.5.2 (latest I think), deadzone is 11 deg on both axes. Need to check on your last point.

However I have made progress. I generated a flightplan using Simbrief. Loaded it into the sim and still had the same problem. I then cleared the MCDU and setup the MCDU from scratch, manually entering the waypoints and airways from the Simbrief plan. Guess what it works on my first flight using that method. I will try a different route and feedback the results.

1 Like

The flight bars will indicate whether this is deadzone related.
If they go against the turn, not with it, a larger deadzone may be needed.
This would be indicating that the A/P is trying to turn back, but erroneous signals from the controller are overriding it.

I experienced the same issue, which I resolved by increasing my YOKO dead zone to 9%. I dislike having to do this as I don’t believe real aircraft have dead zones in their control systems and it interferes with smooth manual flying. In reality having slight pressure on the controls interfering with the autopilot, without an autopilot disconnect warning, has caused aircraft to crash.
I believe that in the real aircraft the break out force from autopilot operation, when pressure is applied to the rudder pedals or the joystick, is programmed to be quite high, and also will lead to an autopilot disconnect warning. Surely this should be programmed into the Simulator.

I’ve noticed at times the simulator will treat fixes as “fly over” fixes, instead of “fly by”. It’s quite comical especially when the route takes a pretty decent turn of 60-90 degrees. The AP will miss the turn, fly over the course, and correct back. I’ve never seen a modern AP do this IRL.

1 Like

Yes, very unrealistic.
The breakout force is already programmed in the sim, your issue probably isn’t from that.
This comes from erroneous signals from your controller, which over-rides the A/P.
These signals come from the area near your controller’s dead center position, so when your controller is at rest these signals occur.
They can occur in ones that are almost new.

If I move my yoke very slightly in any direction when the autopilot is engaged then the aircraft immediately starts to react, the breakout force does not seem high at all. The autopilot light remains on and there is no warning that the autopilot has disengaged.

That part certainly needs a tweak, for sure.
That is how the erroneous signal issue from controllers does it’s thing.
Just a slight signal sends the A/P into a frenzy!
It will (or at least used to, I haven’t tried lately) disconnect and sound the alarm with a larger stick input.

I don’t know if this is related or not. But does Honeycomb yoke have a automatic snap back to neutral center if you take the pressure or your hands off the yoke? I find that flying the Airbus with its fly-by-wire system uses sidesticks, or in the sim a joystick would suffice. A side/joystick would snap back to neutral position when you remove your hands or pressure which will tell the aircraft that the controls are neutral and no input, thus flying normally.

But if the Honeycomb yoke doesn’t do that, then any slight angle that the yoke is currently positioned at will feed the sim with inputs. It’s inputs like this makes it difficult to fly the airbus because there’s no absolutely no way that the human hand and brain could be absolutely certain that you positioned your hands and the yoke at the absolute neutral center. So you might need a huge deadzone to ignore those angle as valid inputs for the sim.

My yoke has a very strong centering system, but even a slight deviation from that centre was enough to disable the standard Airbus autopilot. As I use a button on the yoke, for ATC option 1, and even a slight press on the yoke was enough to override the autopilot. However I have just tried the A320NX version with modified FBW, and it seems on first impression to have resolved a lot of issues. Well done the Airbus NX team. The aircraft seems to handle more in the manner of an airliner, with changes of roll and pitch being smoother and more stable. VNAV seems to work smoothly and It has coped with significant in flight turbulence well, with no excursions from track or level. In addition when the autopilot is engaged my control yoke and rudder pedals are disengaged completely. This is not completely realistic as in the real aircraft I believe it is possible to break out from automatic control using the joystick, but it’s a vast improvement on the standard aircraft and perfectly acceptable for flight sim purposes. I’m still en route, so no landing trial yet, but on first acquaintance I am very impressed.

Yeah, this is why I always recommend the NX development with custom modified fbw version over the stable version or even the regular development version. Glad it works great for you. And yes, massive thank you to the FBW team for making it possible.