A320 pitch down after extend flaps

Hi there. As soon as I extend the flaps on a320, with A/P on, the aircraft become in a nose down attitude that is very strange and unusual, especially for a a320. That happens after the last update.

7 Likes

Same here. I tried some of the landing challenges with a320 and in these missions, plane starts with gear down flaps down. It goes down violently especially at lower speed. At 145 kts, it is impossible to keep plane flying

On approach with AP, set slats 1, then the AP will be strange, see pictures,
aircraft goes down, but the PFD shows climbing 2800f/m and is climbing.
I tried it three times, always the same,

any help?

2 Likes

Same here.

But I would say that it is not the autopilot, but the flight model iself. When flying manually, just extending flaps to 1 makes the aircraft climb like a space-shuttle. Even if I push the joystick all the way forward, I can not make the aircraft resume its descent. Aparently the autopilot does exactly the same thing.

2 Likes

If it were the flight model all aircraft would be affected. They aren’t.

I think he means the flight model for this aircraft. The settings and adjustments to the Aero Data etc.

A320. During AP, when speed drops to 180 and extend 1 flaps, the plane climb agressively, I found that it is becuase it changes to AP VS to over +5000ft/min when I extend the flaps, i quickly adjust the VS back to -.ve value to maintain the altitude
Causing me to land at 180-190kts everytime and nearly use up the entire runway

3 Likes

I’m having the same issue, when on approach, extend flaps 1, the plane goes into an aggressive climb (5000+ ft/min) and full throttle, like a go around or something. It’s annoying because I have to take the plane out of AP and nose dive at full throttle to not stall the plane. Throws the entire stabilized approach out the window.

3 Likes

Thanks, that was helpful.

Aparently, not many of us are experiencing this issue, since this thread did not have a lot of activity.

Lots of posts in here on this.
It seems to be in the way the flight model simulates the slat extension.
In a real airliner, there is no increased lift from slat extension, and little drag. The MSFS model does not allow for slat extension. With the A320 in this sim, when slats are extended, it is emulated by using the coding from the flaps, and, the results are as you have noted. Way too much lift on extension which causes the funky autopilot to overreact, diving down to catch it’s correct altitude, and way to much drag.

Its the same with me, get everything stabilized and then extend flaps to 1 and it goes into a nose down attitude and accelerates like Lewis Hamilton. lets hope Asobo do a bit of work and earn there money and fix this bug…one of many I add!!!

4 Likes

Zendesk told me, problem ist solved. So I hope for the next patch.

In some other thread (can´t find it to link it now, sorry), I read you can fix the problem by changing the aricraft model from classic to modern (Options / General / Flight Model).

It certainly worked for me, now I don´t get that violent climb when extending flaps, and it also fixed my speed not changing from mach to knots.

Much more enjoyable now.
Hope this helps.

The pitch down problem is still there with the modern flight model, but it’s much less pronounced.

1 Like

Hello to all!
Me to, on long final I disangage AP, flap 1 and then 320 start to Pitch down without any chance to controll it with sidestick…and finally crash…
Never happen before, After new patch.

Ps A320x mode installed

I have so many questions about this picture.

  1. Why is the airspeed arrow is blue colored? It looks like it’s on selected airspeed mode. You should be in managed airspeed mode (coloured purple).
  2. Why are you on Selected HDG mode? You already have a flight plan, use the managed heading mode in NAV.
  3. Why is your throttle set to AUTO at 48.4%? You should be at CL mode at 85-90%.

Your aircraft is misbehaving because you don’t have any active vertical mode. It’s just ALT in blue which is also a selected altitude. You should be in a managed altitude (purple) and the vertical active is either DES or OP DES in green when descending.

Also, it looks like you’re still in DES phase, you shouldn’t be extending flaps anyway. Wait until you’re in APPR phase, then you start extending the flaps. But only if you’re already on managed mode. I can tell it’s not on APPR phase because you don’t have NO DH shown in the FMA.

This one is better since you’re already on NAV and on APPR phase. That’s good. But everything else is still incorrect. Your airspeed is still in Selected mode, while your altitude is also in Selected mode. Keep everything in managed mode, and you won’t have this issue. And I can’t see how you set up your thrust lever mode. But I’m assuming, there’s a problem there too.

In the end, please check your flight model settings. You should be in Modern flight model, not legacy.

1 Like

I found that problem is solved if I change back the flight model setting from “Legacy” to “Modern”

FYI, the unrecoverable pitch up and subsequent stall can be solved by switching to the MODERN flight model.

The severe pitch down when extending the first stage of flaps (which is acually 1+F) with the MODERN flight model is still way off.

2 Likes

Same here, nose down as on your pic but the plane was holding its selected altitude. It`s so weird. It makes no difference whether you are in managed mode or not.

solution…as said in others posts, simply put in General > Flight Model > “Modern” (instead of “Legacy”), and it will work…RESOLVED!!!