A320 v2 ILS G/S and LOC are not catched up

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Which aircraft are you using that experiences this issue?


Brief description of the issue:

ILS G/S LOC are not catched up during approach with all data setup

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Do a simbrief flight from EDDH to EKCH with ILS approach setup

PC specs and peripheral set up:


Are you using DX11 or DX12?


Are you using DLSS?


:loudspeaker: For anyone who wants to contribute to this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Are you using DX11 or DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:

You appear to be doing the ILS 04L at EKCH? The NAV receiver is incorrectly tuned. It shows a frequency of 111.5 and an identifier of “IHHW”.

That is the frequency and identifier for the ILS 23 approach at your departure airport EDDH. It should not show a DME distance at all, since you are far away from EDDH and very close to EKCH.

This indeed appears to be a bug in the aircraft

The ILS 04L approach at EKCH is frequency 110.5 and the identifier is “CH”, or perhaps “ICH”.

1 Like

Yeah ILS 04L approach at EKCH.

I did not change any data, so the MCDU is receiving a wrong frequency.

That could be the issue. But how to fix this?

Hm, I had no issue with it auto tuning into 04L yesterday. Odd.

There is a way to change ils manually? Tried everything and got several error messages

I had no issues capturing the G/S in any of my flights. Try to tune in manually by just inputing the 3 letters of the ILS beacon and it will find the frequency automatically

There is still a bug evident in the OP’s original photo. EDDH-EKCH is a relatively short flight, but in that shot, not only is the NAV radio “stuck” on the departure airport ILS frequency, but it is showing the EDDH identifier and DME distance is 12.8 nm which is impossible, because the aircraft is close to EKCH - probably at least 130 miles away from EDDH by that point. Even if the NAV is just tuned to the wrong frequency, it should not be showing a DME reading from a distant ILS.


This plane needs MAJOR work. The ILS doesn’t capture… I was on KDCA ILS rwy 01, when I even re-enter the ILS, 109.9, it won’t change in the FMC – stays at 108.9. Then I tried changing ILS’s and the entire MCDU crashed.

This needs to go back into the oven.

Put in the letter code not the frequency number.

The ILS can auto select, I’ve only had to manually type in the ILS two times out of the 6 or so flights I’ve done so far. So there is some sort of bug in that system that only effects some airports.

It is still in alpha according to the Info page on the FMC. Apprently the version in this Beta patch is several builds behind.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Not exactly

Provide extra information to complete the original description of the issue:

ILS never autotunes for me. Either on departure or on approach. I have to manually enter the 3-letter identifier for the ILS to get it to work and even then, LOC capture is very wobbly. By default, when hitting LS button on Approach, ILS freq 108.1 will be displayed, even when there is no freq populated in the RAD NAV page.

Are you using DX11 or DX12?


Are you using DLSS?


If relevant, provide additional screenshots/video:


I’ve done three flights and the ILS has never auto-tuned. It’s always set to 108.1 when I hit the LS button, but going ot RAD NAV and there’s nothing there. Today I tried the 3-letter code for the ILS and that worked but the plane chased it all over the place.

If this is as alpha as I think it is, I’ll be the next patch we get will be night/day difference.