A32NX cockpit freezing

This has happened a number of times with mutiple different versions of the dev but every few flights the cockpit buttons and engine animation will freeze for up to 20 mins, and then return. Not sure why.


If you get unresponsive buttons like this, go to your top menu, open something like the ATC window, then do multiple clicks on the title bar of the ATC window to bring it to a rapid action of minimise then maximise, then minimise and maximise. Once that’s done, usually the cockpit becomes responsive again.

I don’t think it’s the A32NX itself, but more like the sim issue considering that you’re like out of focus from the sim, as if you’re opening a different window on the desktop, so it stops being responsive until you’re back to have the sim as the active window in focus.

1 Like

yeah the weird thing is the screens are responsive to the buttons but the buttons don’t actually move. I tried this once and it worked but now it’s not. I dont know but thanks for the tip!

Ahh, is this happened during long haul flights? Yeah, I had that too whenever I fly for more than 8 hours of flight on the A32NX. There’s really nothing we can do about it, as long as it’s responding well even if the buttons are not animated, it should be okay. And it does go back to normal when you start your approach.

Thanks. I’m flying from Kathamndu to Hong Kong so just about 4 hours. The buttons stopped working several times for about 30 mins each. I also can’t descend because it won’t recognize that I want to change the altitude. I don’t know but I’ll keep updating my A32NX.

I’ve heard that one reason may be that the ATC window keeps ALL of the conversations that you hear throughout the flight. On a long haul that may get to be a very large number and kill the memory. So someone came up with a mod to limit how many conversations it keeps in the window. Maybe that will help your problem. I believe it’s called ATC Stuttering Fix.


I resurrect this old topic as this is happeneing to me too in 0.7.1, dev version.

It only happens in the A320, not always but annoyingly often. Currently I’m sitting on the ground in Seattle, no traffic at all, so no ATC history. The “flight” is barely 30 minutes old and I have lost all cockpit animations while the functions are still there. For example clicking the anti skid switch turns it off but the switch won’t move. The advice above doesn’t help here either.

Has there been any solution in the meantime?