A32NX FBW Still Not Following FP

After the sim update on Tuesday, I tried a flight with the FBW A320 and it wouldn’t follow the FP. When I set the AP, it banked hard right and just kept flying off course. I deleted it, decided to wait two days and reinstalled what I assume to be the latest dev. Version (I always use the dev version). Well, unfortunately it’s the same story today on the same route, it just flies off course to the right.

Before anyone asks, I made sure once again that my dead zones are all set to 15%, so that shouldn’t be an issue. Is anyone else having the same issue with the mod right now?

I had this issue before the sime update 3. Now I cannot fly at all because the last stable version (0.5.3) has black screens after the update, with FWB current development version the APU does not start, and custom version causes MSFS to CTD. Now reninstalling MSFS.

1 Like

After the new update A32NX dev version do not follow FP, enginge failure after icing conditions, and the stable version with black screens.
When is Asobo able to work with FBW?

At some point during the flight it will always make a sharp bank to the right for no reason. Now it seems the the flight directors are also way off at least on climb out and in other news my frame rat e went from the 60’s to single digits. Awesome.

1 Like

I haven’t experienced the engine failure, but maybe that’s because I always have my anti-ice engaged just to be safe.

But I’m glad I’m not the only one experiencing issues with the mod still. Looks like I won’t be flying anytime soon…

Guys it has been posted multiple places that you can’t use the Stable version of the FBW mod with the current update. Have you guys updated all mods that you have installed? Sim updates almost always break mods until they can be updated by the developer.

1 Like

The one thing I learned from Easyjet (Check out youtube) is fly the plane manually and turn it towards the FP, then once you complete the turn then turn on AutoPilot. If you have tried this please disregard the tip. :slight_smile:

I’ve been trying different things today and trying flights with different routes and using different airports.

What I have found and noticed is that when I go to engage the AP, the aircraft just wants to fly straight north. It immediately begins a bank and then flies straight and level to the north and completely disregards the FP. This is so strange and it seems like nobody else is having this issue. Again, I installed the latest dev version of the mod.

Try increasing deadzones on all connected controllers. That was the problem for me. My game pad was causing the random banking.

1 Like

I did a flight tonight from EGCC to LFPG using a SimBrief flight plan with no issues.
I use the Custom mod via the installer and the flight was smooth with no problems.

I install the Custom mod because it gets updated almost daily, and I also have the Thrustmaster side stick and throttle quadrant.

Here’s to make sure you don’t have any issues.

  1. Delete your A32NX mod folder. Whatever version you have.
  2. Install a fresh version of the Development or Experimental Custom version A32NX mod. If you’re using the older installer where you only have a choice between stable or development. You’re on the outdated installer version. They already updated this installer months ago, so you need to grab the latest installer before you install the latest development or custom FBW version.
  3. If you’re on Navigraph subscription, chances are you’re in the outdated AIRAC revision version. This causes blank ND and your flight plan will not be loaded. Use the Navigraph beta client to remove the current version completely from your PC, and reinstall it.

These bugs are most likely user-configuration issues. Doing a few housekeeping tasks like this will get you up and running again in no time. I done this the first thing I got the sim update 3 patch. And I never came across any issues that you mentioned.

Never expect that once a patch goes through, that everything works the way it was before. They never do. So always make a habit of reviewing all your mods, go to their original pages and make updates as necessary.

If you’re on A32NX development or custom FBW version mod, you should be making a habit already to always download and install a new version every time before you start the sim.

2 Likes

Like I said, mine are all set at 15%. I don’t think that is what’s causing this though, because it’s not going into a spiral or continuing to bank. For some reason, it just wants to fly straight north. It’s like there is some imaginary waypoint that is causing it to fly a heading of 360 degrees. Once it reaches that heading, it stops turning and flies straight and level.

So earlier I went into my community folder and deleted everything from it except my custom livery I have installed (I only have one custom livery). I deleted the FBW mod from before and even the installer, even though I had been using the updated installer with the three options, stable, dev, or custom/experimental. I assume the new installer it the full screen page with the three options. If so, that’s what I’ve been using even before the update Tuesday.

I then went back onto Github and installed the new installer again and then proceeded to install the dev. version from it again (which I assume is the latest version). At this point, all I have in my community folder is the one custom livery and now the FBW mod (dev. version). I don’t have Navigraph.

Basically, everything should be up to date and the latest version. I’ve repeated these steps multiple times today and the aircraft flies correctly except for always wanting to fly a 360 heading when the AP is engaged and completely ignoring the FP I created. And as I’ll say again, my dead zones are all set at 15% and I’ve checked this everytime.

I’ve never experienced any issues like this after any of the previous world or sim updates.

Remove the Dev version and install the Custom version and see if that works.

I’ll try this and see. What’s weird is that before the sim update Tuesday, I had this similar issue with the custom so I switched to the dev. version and never turned back. Guess I’ll try the opposite then…

To be honest I never use the stable or dev versions, always the custom.
As soon as an FS update gets put out, i just wait a day and keep an eye on the FBW github page, and as soon as I see they have done an update, I then deleted the a320nx folder and run the installer and reinstall the Custom version. Works every time for me.

To the OP, when the aircraft starts to deviate off course, check the next waypoint displayed in the MCDU. I have found that sometimes (most often during approach) the MCDU will direct the AP to a waypoint behind you. When this happens, I disengage AP, fly heading mode then set direct to next waypoint in MCDU.

1 Like

Well… just tried another flight using the custom version and I had the same issue. After takeoff, I engage the AP and it immediately enters a bank until it reaches a heading of 360 degrees and then it levels off and just flies straight. So it appears that’s not my issue.

This sucks. I have no idea why this is happening to me…

As [Maxeuronate77] said above, have you checked your flight plan in the MCDU?

Yes I checked that as well. It was following the waypoints/fixes in order. Again, I feel like if this was the issue, it would make a u-turn and fly back to that waypoint. Again, its not doing that, just flying straight north.