About to give FS2020 up. Whats going on? Stutter, stutter... =(

My system:

Asus B450-F motherboard, latest Bios
AMD Ryzen 5 1600 OC’d to 3.8Ghz
RTX 2070 Super, 8Gb Vram
2 x 8Gb Ballistics Sport AT 3000Mhz (via DOCP in Bios)
Be quiet! Pure rock CPU cooler.
2 X SDD (Game, content and rolling cache installed on second, non-system D: SSD)
Full HD Dell U2414H 60Hz monitor.

100 / 100 Ethernet connection.

The game stutters in both the menus and in gameplay. Stutter or lag, not sure whats going on. All other games works just fine (especially when I went from my GTX 1070 to my RTX 2070 Super).

It does NOT matter if I lower the gfx, it does not seem to have to do with that. Also tried to OC the GPU. No difference really.

I tried to record a movie with OBS to see if the problem seem to occur before the screen shows the image, and yes, the stuttering or lag (?) is clearly visible in the recorded video too.

I have tried everything. Could it be the screen? I have seen really fluid videos of others playing in full hd in 60fps. Does the low 60hz mess things up? How to tell if there is soemthing else wrong? Is the 3.8Ghz R1600 to weak performer (once again i have seen others playing with about same setup).

Please help! As it is now, its not very fun to fly any plane really.

Well - but SUDDENLY, and only for short moments - everyting seems fluid, then next time I should play…same old stutter again. Also, it can start fine and then stutter. But stuttering is what se most of.

Stutters are def back to some degree with the latest patch. 1.8 seemed to be the best performance-wise for me. I’ve had full on 10 second long pauses for god knows why.

You could try locking your frames at 30fps with Riva Tuner (comes wth Afterburner) and turning off VSYNC in MSFS. That works real nice for me.

I think you’re CPU bound trying to feed the GPU (you can go into dev mode inside MSFS to see), but I found that fps locking works nice. :small_airplane: :smiley_cat:

2 Likes

Try turning off all AI/real time traffic, and disable multiplayer. See if that helps, might help troubleshooting.

Do you always have this, or mostly around area’s with photogrammetry scenery. The photogrammetry stuff takes quite a big toll on the CPU, and your R5 1600 might not be up to the task anymore.

Just turn stuff off and on systematically, so you can see where it’s working and where it’s not.

bonus for you is your motherboard should be able to support the R5 3600, and those are pretty cheap. Might even become more cheap with the Zen 3 processor lineup being announced this month, might even be able to use one of those (depending on BIOS updates from ASUS). Don’t buy now though, just wait for 2 weeks.

2 Likes

Ive got 2070 super 8gb vram overclocked , same cooler and similarSSd’s - My monitor is 1440p

but im using Intel I5 over clocked - Well its was 3.8ghz turbo boost to 4.3ghz - But I originally overclocked it to 4.6ghz (no turbo boost) BUT I have same reason as you getting STUTTERS and LAG especially at busy moments near ground, at runway threshold , short final etc. I took away some of the overclock so LOWERED IT to 4.4ghz and I noticed an improvement - average frame rate dropped about 2fps but there was less stutter

I used the developer mode and watched it whilst doing a take off from london city airport at midday no weather. basically i was getting 72 fps average with Cessna 152 and 40fps average with A320(dipping down to 28fps over runway threshold), sounds good but STUTTER was there and the developer mode showed LIMITED BY MAIN THREAD in RED. so i reduced the overclock and it wasnt going red so much just yellow now and then. (now its limited by main thread in GREEN)

I think the best way of testing MSFS is by landing the A320 normally and when your over that runway threshold pay attention to stutter and lag. Put developer mode on and see whats going on. I have fiddled about with the graphics settings to try and take away the burden on the CPU main thread as much as possible.

I don’t know for sure about this as i’m still experimenting but I think i’m seeing a difference between landing with the lowest amounts of aircraft systems turned on the a320 as possible ie NO autothrottle, NO ILS, NO Flight Director, no autopilot etc COMPARED to landing with Autothrottle, ILS etc all turned on . The difference i mean at the moment you come over the runway threshold (runway number) when lag and stutter are at their worst. I also put glass cockpit refresh rate to LOW and not noticed too much of a disadvantage whilst flying.

I am not an expert but have definitely improved my MSFS20 performance by fiddling around as above. I must be doing some of the things correctly at least. Its not fun or desirable but I am very hopeful that a future patch or patchES will make things easier for us . perhaps after the next patch I will have to do this all over again LOL

I also have the RTX 2070 Super.

Previously I was locking the frames at 30 through Nvidia control panel because Vsync appeared to be broken in MSFS with the original release version. I was turning off Vsync in MSFS. This worked really well but I was still getting some micro stuttering occasionally.

Last night I discovered that MS may have fixed Vsync issue. Determined to rid myself of microstutters, I set Nvidia CP to defaults except for preferring High Performance. I removed the frame rate cap. I then I re-enabled Vsync in MSFS and set it to 30 fps in MSFS.

It is so smooth now. I don’t see any stutters. This worked amazingly for me.

1 Like

Thanks I will try it …

Thank you for all your replies. But - to be honest, I have no idea whats going on here, but since the problems occurs ONLY in FS2020, this have to be badly programmed! I tried to use my Ryzen 1600 at stock speed, also removed my GPU OC.

Not much of a difference really.

Tried to set gfx to lowest in game settings (the preset). Well, a bit more fluid but the devs fps counter and diagram is still telling Im limited by Mainthread and with CoherentGTdraw going up and down with a lot of red parts in it (less after going in low gfx).

Then i turned down the sim to 30fps. Then i suddenly only got about 20fps. Now I get then info that its pending between gpu and limitations by mainthread.

I also find that my mouse (wireless) is laggy when moving it in game (but also outside game at some occation).

I get a feeling thats something really off here. :frowning: I have never been able to play this game as it should be played, and then im not talking about performanc…its not even performing smooth on LOW settings - and that even when OCd gpu and cpu.

1 Like

so in nvidia control panel i had it set to preference QUALITY - I changed it to BALANCED . went back in MSFS and in the A320 landing getting average frame rate gone up by 12 fps. lags going but now i see those microstutters more.

So im trying to see if i can limit it to 30 fps like you , cant see where to do it yet .

I have gysnc 1440p monitor

thanks for the tip is helpful

In MSFS options, graphics. Enable VSYNC, there is a slider underneath to force to 30fps, if your machine is older you can try forcing to 20.

1 Like

All stutters I’ve ever experienced were a result of my CPU struggling with generating traffic. This was evident with the frame rate display in Dev Mode. Also, I recently upgrade my GPU to an RTX 3080 and while my framerates have improved, I still get the occasional stutter if I have too much traffic going on (AI or Multiplayer).

I followed this guide to a “t” and have seen major improvements. I have a 3700X… so a 3700X with an RTX 3080 and it still has issues. The 3700X is an excellent CPU, so not sure if I can do much better without spending $500 on a new CPU.

2 Likes

you know ive experimented with everything now and ive ended up right back where i started. I tried it at 30 fps solid and wasn’t too happy with it there. I think its as good as it will get on my PC.

Ill just have to accept the settings as they are
for now and hope that a future updates gives some further improvement/optimisation.

yeah and i know about the traffic. Ive got it all turned off , I dont use weather and many things in the hope it might improve CPU perfomance

I think your (MortThe2nd) idea about possible CPU bottle neck could be close to the real root cause.
I have old i7-4790K which is 4 real core 8 virtual running on 4.0Ghz with turbo up to 4.3Ghz.
With pure 1070 card (waiting be 3080 available before make CPU and GPU update). Have 32GB of RAM and SSD.
Those are perform without stutters. Of course A320neo landing over load the system after approach start lagging strongly. But Balkan/USA bush trip working fine with smaller propeller planes
I forget to mention I still have 1.8.3.0 due reported upgrade issue.

So If my system able to handle without issues that could be a Ghz limit per core on R5. Think about that this is 3.2Ghz basic speed CPU just Turbo 3.6Ghz as in stock.
I know BoxiesAbyss920 OC’d but that is not helps over jump the physical limits of Ryzen 5 1600 limitations

2 Likes

I run on a R5 3600 myself (all core on 4200MHz), and it’s pretty smooth. The R5 1600 is 2 generations old already, and the 4th generation (Zen3) will be announced this week.

1 Like

Ryzen 1600 is too weak of a CPU for MSFS.
All flight simulators demand fast cores, as much IPS as possible to drive all those things in there.
MSFS actually works the best, I have never seen such well optimized simulator that is able to at least decently run an airliner on CPU’s such as Ryzen 1600.

Later generations of Ryzen 1.5 (R2xxx) and 2 (R3xxx) are dramatically better, having the AMD improved the memory controller latency between the CCX’s within the CPU, increasing the instructions per clock - alas not sufficiently to reach the single-core speeds of Intel Skylake and later generations.
Finally, the revolutionary improvement with the AMD processors just came out, with the Ryzen 3 (R5xxx) having all cores now being on unified CCX close around the memory controller, without the latency introduced by the infinity fabric that used to connect the cores and the memory controllers across the CCX’s.
Ryzen 3 cores are now all within a single CCX, with the improved power efficiency of the 7nm litography silicon die, reducing latency - completely beating Intel to the ground in all benchmarks.

Cya in the virtual skies ! :wave:t2: :tophat:

1 Like

Turn off AI Traffic, Multiplayer, Rolling Cache (!) Vsync set to 30 fps. Photogrammetry off, Bing Graphics on. Texture and Object lod set to 100.

are you guys serious 30fps this is not ps4 omg…anthing less than 60fps on any gaming pc you are doing yourselves a disservice.

1 Like

I understand it must be frustrating. Have you tested your internet speed? Maybe somebody is downloading while you are in the sim. Bring up your task manager while u are in the game and see what your network speed is.

Sometimes it is best to start with the simplest stuff…

Just a few thoughts on what to try

  • Turn OFF all overclocking
    ^ Use another XMP profile or manual clocks (if used)
  • Repair the game via App Settings
  • Disable all mods
  • Disable Windows Game Mode
  • Disable vSync and FPS limit when using Freesync/Gsync
  • Set Windows Power Settings to Balanced
  • Monitor system temps for possible throttling
  • Test drive read/write speeds and health
  • Reseat PC components (if it is an issue across all applications)

Good luck