Adding objects to scenery ---- Failed!

Hi everyone, I wonder can one of you scenery experts tell me where I’m going wrong?
I’ve been trying to add some more buildings to a small airport following the guides and various videos on YouTube.
That in itself seems okay, (apart from the slight differences in the SDK since the last update, where some of the options are now in different dialogues) and when I build the package it compiles with no errors at all. I transferred the package to the community folder (the one inside the finished Package Folder) yet when I reload the sim the building is not there.
If there were errors in the build process I would be looking to see what I did wrong but the Console shows I object added no errors.
I did not make an exclusion polygon, I simply dropped one of the default hangers into the scenery.
Any thoughts or suggestions would be gratefully received!

I have moved this to the SDK Category since you are more likely to get an answer here

Many thanks John :wink:

After putting the package in the community folder and rebooting the sim did you open your scenery project, open the scenery editor and the add the building in the objects panel?

Check out the videos by BenneyBoy444, Flying Theston or mustang60348.

1 Like

Hi thanks for the reply, but I’m not sure I understand what you mean.

The object was a default hanger, so was part of the FS installation, it wasn’t a custom building. I thought once the project was built and the BLG created it only needed moving to the community folder, because the building is in the list of objects already.
is that not the case…?

I have looked at all these videos :wink: but because they all seem to adopt a slightly different approach, they can be even more confusing. In addition they all have loads of errors in their build, I didn’t get any; which made it even more puzzling. :frowning_face:

I do appreciate your reply, perhaps I’m not understanding something.

Sorry, I thought you were adding a custom object.

Without being able to look over your shoulder, it’s hard to know what went wrong but, yeah, if you created the project, opened the project, added the default object, cleanly compiled it, and moved/copied the package to the community folder, it should show.

After you added it to the community folder, did you restart the Sim? Sometimes things will show if you close the project and then reopen it. But a lot of times a reboot is needed to bring the package in.

You also said you didn’t do any exclusions. Did you add it in an open area?

Since I wrote originally I’ve installed the latest SDK, and tried with an airport not just a single object. I used a polygon to exclude everything under it, following the steps by BenneyBoy444, I had no errors and after a reset it still doesn’t show.
And as you asked earlier, yes I have been doing a reboot after each attempt, which is a pain because it takes quite a while to run up the sim each time. In answer to you other point, the first attempt was at an existing airfield, just a small one which I though would benefit from a couple of buildings etc.

I’m getting close to thinking there’s either something wrong with my installation of MSFS2020, or I’m missing something so obvious it’s driving me nuts… :persevere: :tired_face:

Thanks again for your help! :wink:

1 Like

Thank you for the ideas, I will try them out in the morning.
Incidentally I have always pushed the save button for both the scenery object and the project before building the package.
However when trying to add a building I did not add the ICAO name in the project, I will try that also.


Hi Everyone who replied to my post.

The latest hot-fix has fixed whatever was wrong with my system, becasue I tried once again after installing the hot-fix and it worked. I used exactly the same naming conventions and folder structure, so essentially exactly as before.
Which means Asobo owes me the last 24 hours of my life. :wink:

What hot fix did you apply and where did you find it. This Scenery thing seemed so easy in 2007 and I cant even remember how I pulled all of that off though, I know I have the notes in a box around here somewhere, I cant tell if I’m developing Alzheimer’s or its just that difficult lol… Im hoping that it will become more intuitive.

I didn’t apply a hotfix myself, it was the update that followed a few days after the World update 3.
In fact there’s a whole section in the forum dedicated to it.

Of course I agreed to the update, I meant I didn’t go off to find it and apply it myself. If an update is offered naturally I accept it, why wouldn’t I. Otherwise, I could still be running the Beta.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.