Aerolite 103 no throttle control?

Unsure if it is just me with this Aircraft? The throttle control is not responding? All other controls are responding on this Aeroilite 103. No other control problems on any other aircraft that have tried so far. Use Saitek X52, but the throttle control does not respond with the keyboard as a control either?

Is your throttle bound to Throttle Axis, or Throttle Axis 1?
If just axis, change to Axis 1

No idea? I have gone into FS Control Options, Saitek X52, Throttle Axis, box says ‘Joystick L -Axis Z’. The horizontal indicator bar moves across as I move the throttle. The small box ‘Reverse Axis’ is ticked. I can not see any reference to Axis or Axis 1 options?

You have to search for ‘Throttle axis 1’ in the search box and bind your throttle to that. Best make a specific profile for it, as when you fly multiple engine planes, your throttle will only control the left engine.

This problem is also with a few other add-on aircraft. It fixed it for me.

Yes it will still move on the indicator.
Some 3rd party addons need to use the Throttle Axis 1 command rather than just Throttle Axis.
Make sure the filter on the left of the controls screen reads “all” not “assigned”
You should see a command for “throttle 1 axis” in there then.

Thanks. I have been through the ‘left hand box’ in Control Options. There is NO command/selection to change to Axis 1? I am looking at a screenshot of the menu on my iPhone (left box). Top to bottom. SENSITIVITY (BLUE)/ SEARCH/ in ‘Search by Name’ Box I input ‘THROTTLE AXIS 1’. Then nothing? Then ‘Search by Input’ which lists the Saitek X52 controls (axis’s, buttons) the throttle is on ‘Axis Z’. Then FILTER/ set to < Assigned > other settings < All , et > I have changed to < ALL >. THERE IS NO SETTINGS CHANGING FROM ‘AXIS’ to ‘AXIS 1’ ? Still no throttle for Aerolite 103? This is driving me mad?

Hopefully this will help:

The reason why I could not find the selection was it is ‘THROTTLE 1 AXIS’ not ‘THROTTLE AXIS 1’. Simple mistake. I have disabled ‘THROTTLE’ assignments. Set to ‘THROTTLE 1’ on Saitek Axis Z, not ‘THROTTLE 1 0-100%’ (what is the difference) ? Tested the Aerolite 103, but the throttle is now erratic, jumping from low to high, and the engine power indicator (external view) is flickering all over the place? Still not able to control throttle properly? Have not tested other aircraft yet, have to go out soon. But it seems there is something very wrong with the controls? Thanks for all the help.

1 Like

That sounds like a calibration issue

Thanks I will check the calibrations. I remember that I can check the calibration on Windows, but can not find the Windows joystick settings? Although I will look in the calibration settings in FS2020. What is the difference between ‘THROTTLE 1’ and ‘THROTTLE 1 0 -100%’ ?

That I can’t answer.
I have mine on just Throttle 1.
I haven’t tried the other!

Thank you very much for all your advice and help. You have been very patient with me. The erratic throttle is now stable. After a reset, and re-start of FS2020 it is now fine. It may have been the recent major update, followed by a small update a few days later. I have known these updates upsetting the settings. No more CTDs and all working fine. All the best, Ian.

1 Like

No trouble at all.
Good flights!!

Why change it to Throttle Axis 1. All other aircraft default and third party works with Throttle Axis!

Before Sim update 9 something went wrong use to work fine with Throttle Axis.

Is there an update that will fix this. I did try changing to Throttle Axis 1 with no luck?

I wish I had some additional info for you!
If I remember correctly, the change was made to accommodate some third party aircraft which needed that configuration (apparently there are addons that do not work correctly with only the just Throttle Axis command), and I haven’t heard of any MSFS plan to revert it back.

As noted above, the actual terminology is THROTTLE 1 AXIS, make sure you bind to that.

If you are having issues, I would recommend you contact Nemeth Designs.

Throttle 1 Axis did not work either. I guess if I want to fly a Ultralite I will have to by a Third Party plane. Any good ones out there?

I’m rather fond of the Top Rudder 103 Solo.

I’ve had no troubles with the Aerolite though.

What about the Drifter 582?

Before spending money on another aircraft, you might want to do a little more troubleshooting. MSFS keybindings can be difficult at times.

The keyboard can help find problems. The default keyboard uses F1-F4 to control the throttle:
F1 - Throttle cutoff
F2 - Reduce throttle one setting
F3 - Increase throttle one setting
F4 - Maximum throttle

Unplug any joysticks or any other controllers first to prevent any conflicts. These should work for all aircraft although some multi-engine aircraft might use something different.

If these work, then the problem is with the joystick keybindings or conflicts with the keybindings.

The 103 is a fun aircraft! Don’t let bad keybindings steer you away.

1 Like

As I mentioned earlier the joystick binding works for all other aircraft even third party aircraft. I did try unplugging my joystick with no luck? I also tried un-installing and re-installing thinking that there may be a corrupt file somewhere. Still no luck.