Aerolite 103 no throttle control?

That sounds like a calibration issue

Thanks I will check the calibrations. I remember that I can check the calibration on Windows, but can not find the Windows joystick settings? Although I will look in the calibration settings in FS2020. What is the difference between ‘THROTTLE 1’ and ‘THROTTLE 1 0 -100%’ ?

That I can’t answer.
I have mine on just Throttle 1.
I haven’t tried the other!

Thank you very much for all your advice and help. You have been very patient with me. The erratic throttle is now stable. After a reset, and re-start of FS2020 it is now fine. It may have been the recent major update, followed by a small update a few days later. I have known these updates upsetting the settings. No more CTDs and all working fine. All the best, Ian.

1 Like

No trouble at all.
Good flights!!

Why change it to Throttle Axis 1. All other aircraft default and third party works with Throttle Axis!

Before Sim update 9 something went wrong use to work fine with Throttle Axis.

Is there an update that will fix this. I did try changing to Throttle Axis 1 with no luck?

I wish I had some additional info for you!
If I remember correctly, the change was made to accommodate some third party aircraft which needed that configuration (apparently there are addons that do not work correctly with only the just Throttle Axis command), and I haven’t heard of any MSFS plan to revert it back.

As noted above, the actual terminology is THROTTLE 1 AXIS, make sure you bind to that.

If you are having issues, I would recommend you contact Nemeth Designs.

Throttle 1 Axis did not work either. I guess if I want to fly a Ultralite I will have to by a Third Party plane. Any good ones out there?

I’m rather fond of the Top Rudder 103 Solo.

I’ve had no troubles with the Aerolite though.

What about the Drifter 582?

Before spending money on another aircraft, you might want to do a little more troubleshooting. MSFS keybindings can be difficult at times.

The keyboard can help find problems. The default keyboard uses F1-F4 to control the throttle:
F1 - Throttle cutoff
F2 - Reduce throttle one setting
F3 - Increase throttle one setting
F4 - Maximum throttle

Unplug any joysticks or any other controllers first to prevent any conflicts. These should work for all aircraft although some multi-engine aircraft might use something different.

If these work, then the problem is with the joystick keybindings or conflicts with the keybindings.

The 103 is a fun aircraft! Don’t let bad keybindings steer you away.

1 Like

As I mentioned earlier the joystick binding works for all other aircraft even third party aircraft. I did try unplugging my joystick with no luck? I also tried un-installing and re-installing thinking that there may be a corrupt file somewhere. Still no luck.

What type of throttle are you using?

VKB Gladiator MK11

Slider build in

What happens if you assign some other axis on the Gladiator to the sim throttle control, like Y axis just to try what happens?

What happens if you go to the Gladiator II on VKBDevCfg and reset it to default settings (red labled button under tools tab)? You could also flash it to new firmware (you’ll need to put the Bootloader app to same directory as well) and then default and recalibrate it.

If the software allows it for Gladiator II (it probably does) you could also try setting the throttle lever to different HID axis and see what happens.

I went through the re-flash with the new firmware and recalibration process with the Gladiator some time ago just to make sure it was calibrated correctly and updated.

Not sure why this could be a problem with the Gladiator when it works perfectly fine with every other
plane i have in my Hanger.

I can click on the Throttle lever and drag in the cockpit and get the plane to advance, but
make no since to do it that way.

Anyhow, thank you for your input and suggestions.

My next step is to buy the Drifter 103 now in the marketplace and see
wat happens.

Did you try assigning the joystick Y axis (or any other axis other than the throttle) to throttle to see if that works? The significance of that idea is that you could check if accepts throttle axis input from the device in general, since you can switch the HID axes around with VKB software (e.g. if your throttle is say Y Rotation by default, you could change it to Slider or Dial or whatever). That being said, I’m not at home and won’t be for some time and hence can’t access the full interface due to lack of device and can’t walk you through that process right now.

Also check if the throttle 1 axis 0-100% works, if throttle axis and throttle 1 axis don’t.

Another option:

Download and install vJoy, I use this version with Win 11: GitHub - jshafer817/vJoy: Virtual Joystick
Download and unzip Joystick Gremlin somewhere: GitHub - WhiteMagic/JoystickGremlin: A tool for configuring and managing joystick devices.

Run the Joystick Gremlin. Assign your Gladiator’s throttle axis to any axis on the vJoy device (should be automatically created) via the rebind function you can find when you select the throttle axis. Save and activate profile, then go to MSFS controls options and assign the axis you used on the vJoy device to the throttle 1 axis.

Not sure what happened today but all of a sudden the throttle started working again with my Gladiator
flight stick slider. Flying the 103 again!!

1 Like

I,m Done with Aerolite 103!!!

Last week it all of a sudden it started working again! But this
morning broken again WOW! what is up with this plane!

No more 103. Switching to Drifter 582 to see if this ultralight works.