After playing a few hours, FPS drops from 40 to 5FPS

we see us :wink:

1 Like

so you mean you run after 12 hours into low fps ?.. or was your focus on the location ?

did you use Azure-ATC or Offline-Speach ? I use only Offline-Text2-Speach , may be there is a impact ?

Not in this Game :smiley: Totally hyped for x plane 12. For me it was the last try with msfs 8 hours in installing for 20 min oh no not again :joy:. Maybe in two years when it’s finished :joy:. Just ridiculous!


last questions then:
does it allways happens and in which airplane ?
I try to find a case where community can ensured reproduce this loose of fps. I also assume that your airplane not need “some hours” to 25000ft alt :wink: And of course we need a case with a not-moded airplane, etc.

The a32nx it’s the gtui draw and the mainthread. Plus heavy stutters now caused by the gtuidraw. And every other plane it’s the mainthread. Standart planes and mod planes. Clean install without mods and with mods. Scenery packeges installed or deinstalled it doesn’t matter. I put now 100 hours plus in installing a clean copy over and over again and tried every time an other solution written above. Starting on ground with 17-20 and after reaching the “25000” feet after some minutes it goes up to 35 sometimes more. I tried every workaround written here. Nothing helps.

If you guys have more questions don’t bother to ask :slight_smile:

okay… the a32nx mod I can’t retry.

For low fps on ground there is a different topic ( Poor performance on the ground ) and solution for now is to lower the LOD setting, in special in big airports ( example fps compare high density vs low densisty airport on ground )

And why is then the “increasment” to 35 fps an issue ? :relaxed: … I mean I play with a VSync limit to 37.5fps ( just 75fps monitor ), so that is my “normal”.

I meant the mainthread in ms wich is in the fps window the first line.
On ground it’s perfect I found the perfect solution for me. Ground is round about in the a32nx 40 to 50 in big cities. And the crj for example is at 60 to 70 fps.
BUT when I hit the magicall 25000 feet the fps goes down wich was before going up. distance to the ground etc. The fps were before this bug 70-90 up in the skies
Oh and sorry I meant 39 or more ms delay.
Its unplayable at this height the fps drops down and stutters how I said :confused:

Ah… the times, not fps… :slight_smile: But then sounds the issue different as these topic is about.

We have also topics for stutters , and I remember a similar topic somewhere with low fps in high Alt. , but can’t find at the moment ( remember e.g. virt. memory setting, cache size, … ). Usually the reports are about lower fps near ground. All fps > 30fps is playable, but stutters are of course not nice.

1 Like

The stutters is only in the a32nx. I don’t care there. The other planes have the fps problem. It starts slowly and gets worse and worse.
Many people in this thread mentioned my problems iam reading this post since the beginning:D.
I think some people get the issue later and some at the beginning like me. :thinking:


During the flight with A32NX the manipulators get slower and slower.

To fix it during the flight i have to toggle photogrammetry and that fixes it for a while before it gets worse again.

1 Like

DA20: got 75 fps and limited by gpu for 2 hours
A20X FBW: starting with 70 fps down to 30 (stable camera) 15 fps (turning the camera left and right slowly) 5 fps (turning the camera left and right fast).



Exactly my experience as well. I Mostly do 1-3 hours legs in the FBW. Find that FPS is steady at 37 (locked half refresh rate of monitor) in the beginning, then goes down to 20-25 when approaching the destination. If I then go to main menu after landing, and load back in to the destination airport, FPS are again fine…

Did try a bunch of things, including the server start for the FBW… Nothing helps…

Also tried loading the FBW on an airport, and just leaved it at gate for 3 hours… same thing happens… FPS is slowly going down…

This issue is really a PITA!!



Switching off Data usage in MSFS seems to work for me. Just did a 6:30h flight from KJFK to EGLL. As FPS drops to 5FPS, i just switched of Data usage, saved & applied. After 10min I switched it back on and FPS began to raise again to 40FPS like normal.


Interesting. What do you mean by switching off data usage? Live traffic and weather?

Same here. After Flight from Heatrow to New York with the new Concorde i got a Frame Drop to 2 in Appoach.


None of the Tips helped.


Its not Addon Related, its a Sim Bug.

my GPU is at 5% at Approach.

3080 RTX
32 GB 3200 Mhz

Asobo fix that PLEASE!

1 Like

Looking through this thread it seems abundantly clear this is an issue that seems to affect airliners primarily. I think there was one TBM outlier though.

The longest flights I have had have been around 6 hours. I always hand fly so no putting on the AP, and going to bed as I don’t really see them point in that myself, other than testing sim stability. But I understand some users experience this issue on much shorter flights, around 2 hours or so if memory serves.

I only fly GA which may be why I have never seen this.

1 Like

Testing for over 100H, same route KDFW to PANC, same time, clear preset weather and AI traffic off. With windows 10 pro, with/without Mods and finally switched to Windows 11 Pro. Fresh OS installation plus drivers and MSFS 2020 only. No Add-On at all, nothing. In the beginning of each flight on the ground +60 FPS, after take off for the first 0-3H t frame rate is +80FPS, then starts stuttering and frame rate drops. It’s very interesting, in the beginning the MainThread is about 10MS and GPU load is 99%, after 6H flight the MainThread is increased to 35MS or more and the GPU load drops up to 30%. This is dedicated system for Flight Simulator, I can give remote access to Asobo or MS support team to start testing on my system. This is not random issue, I flew the route more than 15 times, tried all possible fixes that are mentioned above or I knew from past. My system configuration is:
CPU: 12900K “Water cooled”
GPU: evga 3080TI “Water Cooled”
RAM: 32GM DDR5 6000 “At the moment works at 4800”
HDD: NVMe® M.2 SSD 1TB Samsung Pro

I attached some pictures from the start to the end, I hope this information help the team to eliminate this problem so we can all enjoy this beautiful Sim.

Pictures Description:
01 - After Take Off
02 - At Cruise Alt
03 - After 3H
04 - After 4H
05 - After 5H
06 - After 5:35H at ToD
07 - After 5:40H Descent is started


Lenovo ThinkPad P15, i9-10885H, 32GB RAM, RTX 2080 Super, running Win 10 Pro. No issues running on this machine for the past year+. However, after WU8, suddenly I’m dropping to sub-10 FPS. First, it started during a multi-hour flight. Now, it happens minutes after take-off. I did update my NVidia driver at the same time as the update, but have since rolled it back to 496.76. The issue persists. Plane doesn’t seem to matter. I’ve flown the DA62, the Grand Caravan, and the A320neo - all standard planes, same issue. No add-ons at all installed. Graphic settings on Medium.
After a clean reboot the sim runs as expected in the menus and the first few minutes of flight. If I shut the sim down and then re-launch it, the issue is present in the menus before the flight even starts. The performance stats do not seem to be indicative of an issue - meaning the FPS drops even though stats are unchanged. I can be running at 99% GPU and still get 63 FPS, then suddenly I’m running at 91% GPU and 6 FPS.
Running fine: image
Barely playable: image
I feel like there was a shift to running more of the sim in GPU and less on CPU. Tried shutting off all online features, dropped the graphics settings to Low - only gained 3-4 FPS.
This is my work laptop. On my home computer, an Alienware Aurora R13, i9 12900KF, 64GB RAM, RTX 3080 running Windows 11, I have not noticed any issues.
I can’t see how this is not a bug somewhere - obviously not impacting all hardware configurations.


Have you tried to turn of photogrammetry data ?.


For me the solution was really to uninstall the Ambitiouspilot toolbar pushback. Did a 2 hour flight today with the FBW and the FPS were okay.

1 Like