After playing a few hours, FPS drops from 40 to 5FPS

TBM - Airliner?

As I said, only some of this is caused by that. Have you tried toggling AI traffic off/on just to see if that helps?

I have not flown airliners, only GA aircraft. Have experienced this in the Cessna 208B and the TBM. Traffic on/off, weather live/preset, all players on/off, with or without mods. For me, the time varies but usually > 5 hrs before the FPS drops and audio stuttering. Some of these flights are with Unlimited Fuel. All are while on Auto Pilot under NAV guidance.
Unable to find a common factor locally, unless it’s between the yoke and the seat.

happens to me regularly.

I fly the bell 47 (helicopter) over London and go from a “normal” framerate to a stutterfest after 20 or so mins.

reloading at EGLC "resets"it.

doesn’t always happen.

250 rolling cache on ssd and mp/live traffic on. (140mbs average dl speed)

Maybe stupid, maybe not, but do you guys have “fast boot” turned on in windows? This is in fact a kind of “hibernate” state of windows without apps open but with services and drivers “hibernating”. As waking these drivers and services up, it could lead to undesired behaviour (leaks etc…).

It adds maybe a second of 1 - 3 for ones on SSD.

But, you will know for sure you’re pc does a… “cold start”.

Just my two cents.

A related thread that might offer some help?

Just I was searching this post.

I’m now flying from Tenerife to Berlin… It was “great” at the biggining (45/50fps) but I’m flying now over France and the degradation is noticable(15-23fps). I’m afraid for my landing…
I don’t know if this is related but I’ve “crackling” sound too.

I flight with IA traffic off but multiplayer on (I tried off but I don’t have any difference).
I’ve a 3080 ti
32 gb RAM
FS is installed on M.2
Ryzen 7 3700x

I hate SU5 so much…

1 Like

:wink: I didn’t spot your post about the TBM. The planes I fly either have no glass cockpit at all, or the 530/750/G1000 NXi, and I’ve never seen this issue. I was wondering whether it was avionics related.

I try to fly with live weather on, and live traffic, not AI.

I flew today from Belize to Cancun
, about an hour and as I was on approach, the whole system started to slow down. I noticed it first in the keyboard. Keys and mouse were slow to respond.

Surprisingly, I hit some heavy weather and that was fine. About 45 minutes into the flight.

Seems like cache or buffering issue somewhere.

Currently flying from RJTT-KLAX and 6 hours into a flight the FPS drops to constant 10FPS and I’ve tried to disable online function as well as playing around with affinity with no luck. Hope SU6 fix this ongoing issue.

1 Like

I’ll bet you anything you like that there is something in that aircrafts systems doing that.

It’s really frustrating. If we knew what is the cause, we would might be able to have a workaround.
But right now for me it is complet random. It ruins more or less the whole Experience.

Does someone know what exactly “limited by manipulators” mean?

I wasn’t 100% sure myself so I did some searches. According to the following posting:

These manipulators are basically click regions that change datarefs, or they can be used to UV map panels onto the objects.

So it’s an interactable region of the cockpit, apparently. Perhaps this is one of these cases where the more complex the aircraft is, the more chance of this bug happening.

I don’t fly the TBM much, but I fly the Caravan a lot, most of the weekend in fact, and some of my flights were around 2.5 hours long. I never saw this then. TBM, and C208 seem to be the only non-airliner aircraft mentioned.

So
When it deals with data refs, I maybe try msfs without stream deck and without axis and oh

I have a Streamdeck XL, but I use SPAD instead.

I don’t think it’s external hardware that’s the issue, but It could be something in the virtual cockpit.

What do you use Axis and Ohs to control?

1 Like

Yes, i do
But it’s hard to tell if i have it used everytime i had the drop

The Apps outside MS i had running everytime i had the drop are Stream Deck and Neo Fly

2 Likes

Someone mentioned he was using PACX when the issue occured whereas he did not get the issue without PACX. I have been using Self Loading Cargo (quite similar to PACX) whenever the issue occured. I just made a 3.5 h flight without Self Loading Cargo and the framerates were fine until the end.
PACX, Self Loading Cargo and Neofly at least have in common that they constantly monitor certain flight parameters.

I wonder if that might cause or contribute to the issue.
The fact that my framerates almost always went back up to normal right after touchdown fit into this assumption. Because at that moment there are no flight parameters anymore to monitor.

Might still be coincidence but should be worth more testing.

2 Likes

I will also test in regards to Neo Fly. It sounds kind of logical. But it is not the first time i have that thought

I am currently flying the 747-8 from Sydney to Chicago with the Salty mod. 13 hours into the flight I found that my FPS dropped from a pretty steady 60, which I usually have, down to 20. My GPU usage is usually close to 98- 99%, but over time it seems the GPU is used by only 50 - 60%. Temps and VRAM are fine. This is the RX6900XT.
No other apps are running. No idea what is causing this.

1 Like

There goes my theory. Another flight without Self Loading Cargo and frames dropping after 100 minutes into the flight.

I wonder if this is a cumulative effect of several factors. So sometimes it’s enough to take away one of these factors (like AI traffic or an external app), sometimes not.

Well, with a little luck this will be solved anyway with today’s update.

1 Like