After playing a few hours, FPS drops from 40 to 5FPS

I had no problems either but after SU9 my sim started doing this..

1 Like

I didn’t get it with Sim Update 9, just with the patch today. The sim updates and patches are so troublesome, everyone has pretty much made the sim worse. It’s been downhill for me since release really.

4 Likes

Have experienced the very same issue here. Select a long flight and engage auto-pilot, say if doing a flight from Orlando (USA) to OR Tambo in South Africa, flying Boeing 747-8. (About a 15hr flight, using default plane) Fps eventually drops after a few hours from 60Fps down to about 14Fps… GPU usage drops to around 18% +/-… I have checked all power saving options in Windows, and turned off whatever power saving options there are, but this does not help…
Windows 11 Pro - 21H2 - 22000.675
Intel i9-11900k
RTX3080 - nVidia Driver Version 30.0.15.1259
64Gb RAM
2Tb 980 Pro (Samsung)
Regards Mark

YEAP same approach that took place with GT7 in PS5 and then devs were forced to deal with it ASAP !!!

1 Like

Hey guys, I had the same problem with random FPS drops after one hour of flying. When I restarted the game I was able to play fluently on high graphic settings but after one hour, even when I remained at the same position FPS dropped to single digits.

My Solution:
I don’t know wether it was fixed by the update yesterday or it was me because I deleted everything in my Community folder but the PMDG 737.

Hope this helps some of you.

I had the same thing today when flying from KMIA to EGKK.

The fps and GPU usage gradually decreased as time went on. GPU and CPU temps were all well within normal range at ~50C. The fps was around 5 and GPU usage peaked at 40% but dropped to 0% frequently at mid point of test. Frame time was between 90ms and 200ms. RAM usage increased from 6GB to 14GB and audio started crackling during test.

Interestingly when my monitor resumed from sleep during the test the aircraft and environment audio from MSFS failed to work and RAM dropped to 3GB before slowly increasing again despite no audio except menu clicks working in the sim.

Test was stopped before making landfall in the UK as fps was hovering between 0 and 5 fps. Frame time was between 150ms and 400ms at this point. Sim was very unstable and clearly not working well enough to even bother attempting a landing.

The dev mode fps counter was flipping between limited by CoherentGTDraw and CoherentGTUIThread.

I do have Toolbar Pushback installed. No pop out windows were open at time of checking fps.

Mods in use during test:

Salty 747-8i with BA livery
Toolbar Pushback

PC Specs:

CPU: AMD Ryzen 7 5800X
GPU: AMD RX6800 XT
RAM: 32GB

Related Zendesk Ticket: #158684

hey welcome, I can confirm that the hotfix improved sth. Even with add-ons in my Community Folder.
In my case after the hotfix, I was flying one of my EDDB to EDDB traffic patterns in Asobo A320. 25L. Pilot view.

Take-Off = 58-61 fps. (92-93% GPU Core)
Cruise (6000-8000ft) @ 64-72 fps (99-100% GPU Core for 20 min)
Landing @ 44-48 fps (72-78% GPU Core)
Taxi back to 25L and Line up Runway @ 56-57 fps (91-93% GPU Core).
But with 2 planes in front of me. Runway far away and another to the right taxiing.

So I assume this little degradation is because of AI Traffic. I didn’t try taxi to the gates. But even fps will drop @ gates… it’s an improvement. Hope they don’t break this improvement again.

cheers

Hello all,

i want only share basic infos, i have my hw no rocket this time. Did stress to sim everytime with 3-rd party addon sitting at APN many hours, test fps, stability. Never noticed any fps own degradation by sim/system. Also don’t have many addons because somehow feel that with add more addons inside community all starts doing bad things. Test sim with clear community folder and without any tweaks, better with same graphical settings for longer time as possible. Use of bad antivirus solution can be also problem.

I still think it may have something to do with the planned route waypoints in MSFS.

PMDG is the first airplane i use that doesn’t use the MSFS route system at all and for the first time i am able to do long haul flights without performance loss. The FBW also has it’s own waypoint system but it still puts a route in MSFS.

After a 10 hour flight in the 737 i still have the same performance.

1 Like

Same deduction here, I have successfully repeated the experiment multiple times now.
Same departure, same destination, JFK to Heathrow, 6h flight :
-First flight crashed after crossing the Atlantic even before getting over Ireland.
-Second flight, SID + STAR + APP, no enroute waypoints, crashed 10 minutes before landing at Heathrow (really…)
-Third flight, set departure + destination only, manually fly the procedures, no drop in FPS

Interestingly the CoherentGTDraw clogs up for some reason, and it is way worse in cockpit (glass instrument always showing the VFR map ?)
External view while showing the VFR map :


mere seconds later after closing the VFR map :

(edit) start of flight, Vsynced 60hz :
image
(edit2) return flight over 6h completed, of 7hours, no waypoints, origin and destination only for the gps to work :
image

1 Like

I disable Steam, VGA and Xbox Game bar overlay and my game is stopping lagging and audio crackling. FPS returned to normal. Big hug guys, i hope to helped!

When this happens (Stuttering audio and bad FPS) i just save the flight and reload the sim. Saving works great now.

Hopefully they will fix these performance issues anytime soon.

My experience, as previously posted, has been slightly different in that FSP would crash sometimes only minutes into a flight. After the Update 9 patch yesterday, I did a flight with abysmal results. So feeling disheartened, I installed the latest nVidia drivers, rebooted, and viola!, no more drops. I’m 8 hours into a 9 hour transatlantic flight with no drops. Fingers crossed this keeps up.

1 Like

Sorry, We had an Update 9 patch yesterday?

For me it’s the VFR map.

I’m currently flying the FBW A320 and after 2 hours the FPS dropped from 30fps to 5-6. I closed the VFR map and the fps immediately jumped back to 30fps.

I don’t know when the performance issues started. I flew the TBM with the WT mod for 5-6 hours straight a month ago and the fps was okay. Though I suppose the WT mod uses a custom map. I flew the A320 for the first time in 6 months just yesterday. I haven’t really flown with the VFR map on for a long time in a year. So I guess that the issue was introduced in the last year.

Im right now in my second flight in a row without leaving the Cockpit. FBW
So far no drop at all

1 Like

Pc is still on and MSFS still running. Airbus parked at the Gate. Guess i will make a third flight shortly. All in all the Sim is running at least for 8 hours. No degradation at all.
Didn’t make a Flightplan,only departure for the first flight. The sync from the FBW MCDU seems to work flawlesly. Also ingame ATC was spot on for the 2 flights

After almost 2 years of this simulator we still have the same problem. incredible.

I am finishinig a flight with 7 fps.

can i say shame? can i?

10 Likes

Made my 1st PMDG 737 Flight.
I had to save and restart the sim Mid-Flight

Then the Perf degraded again when on Final

Asobo, Fix Your Sim!!!

3 Likes

Dear, I managed to solve it by following step by step what this page indicates. The only thing I omitted is the bandwidth and the settings inside the simulator. I just finished a 3 hour flight and the fps never dropped

1 Like