After playing a few hours, FPS drops from 40 to 5FPS

In this case I let the copilot manage the calls. Currently 40 minutes before landing at 10 fps.

But if you found Something and you now tune into an unused freq, the fps should rise again. If they don’t, your other case was no solution, only conicidence.

I think i read in this thread that someone said he didn’t has the drops when he uses pilot2atc. That would confirm your findings

Just tried, after switching to another freq, I am still locked at 10fps. Switched back 3 minutes later to get my approach now.

Can confirm, anything over a 1 hour flight ends up in a slow death of FPS by the destination airport! Come on,

Go from 50-60 FPS at takeoff to 20 - 15FPS at landing.

I’m not seeing that, and my flights are often over two hours. In fact I’ve never seen the degradation of performance that some describe, pre or post-SU5.

2 Likes

while zendesk usually process my tickets quite fast, regarding this one is still open after 21 days

did you buy from Microsoft store or Steam?

Microsoft Store.

Announcement. I finally said f*** it and did a clean MSFS reinstall (deleted all the directories and mods and model matching etc etc)

And it actually fixed the progressive performance degradation. I could actually do a full 2:30 flight from dfw to Atlanta in the crj and land with smooth fps. Audio crackling/stuttering gone.

If anyone else is having this issue, just do a clean reinstall and accept that we need to wait for more polished mods to come out before putting them in our simulator.

If it was a mod doing it, then a reinstall was unnecessary. Just remove the mods for a test flight or two.

1 Like

You only proved that a stock MSFS with stock settings and without Addons maybe didn’t have he bug.
There are to many variables to see it as a fix

2 Likes

Greetings.

Sooo, after i did a longer flight yesterday with the DC-6 from Venice to Hamburg i too had a huge framedrop. Landing was quiet difficult. After that i read multiple Threads here in the Forum about this issue.
So i came up with the idea to do a testflight today with the A32NX exp. build from Berlin to Funchal.
I also streamed that flight and have it on my twitchchannel with OSD enabled to look at CPU/GPU/RAM usage and Temps.

So here are the results in a nutshell. I have my frames capped at 35 and i´m playing the sim on 1440p settings are High/Ultra. With that the Usage of the CPU is around 30-40% and GPU is around 40-60%.

I can already say that throughout the flight this does not really change at all. Usage/Frequencies and Temps are all normal and the Ramusage is arounnd ~14Gig of 32. so around 18Gig were always avaiable, not compressed. So no memoryleak.
After around 2 hours frames were down to around 20-25 frames. i continued the flight without changes.
After around 3,5 hours frames were down to 10-15. when swiffeling the cam around in the cockpit they went down a bit to around 10 (this is a known issue from SU5 and is supposed to be solved with WU6 i think).
at that moment it was already hard/annoying to set things up in the cockpit. so i started testing things out and do some things that were mentioned here and other threads about this issue.

  • Turned off all overlay icons from the Toolbar = no changes in fps
  • Turned of live weather for 10 minutes = no difference (turned it back on)
  • Set task priority in the taskmanager to high and after that to low = no difference
  • Turned off live traffic.

Now here is the thing. After i turned it off no changes in fps and i was about to skip to the next part. BUT. slowly my frames went back up from ~15 to ~20 in about 2-3 minutes. so i waited.
10 minutes later frames were back at 30-35.

Now i dont know if this will work for everyone but for me it did.
I cant imagine how live traffic can “steal” so many frames but this was def. the issue.

Maybe this will help some of you.

Cheers

EDIT: My Rig

MSFS on a 1 TB nvme ssd. 32gb of 3600- 16Clock ram, Ryzen 3700X, RTX 3060TI.

That does not work for me unfortunately. I get the issue even if I don’t use any AI traffic at all.
I experienced several times though that the FPS - after having dropped to below 20 on a longer flight - recovered back to my normal locked 30 for no apparent reason, sometimes just to drop again after a few minutes, sometimes they stay at 30 again for the rest of the flight. I haven’t found any pattern so far. It seems to be totally random.
So maybe you were just lucky and your FPS went up again just coincidentally after you turned off your AI traffic. That happened to me before as well.

Could be. Will test this on my next long hauls. :thinking:

1 Like

So the other day i was doing a long haul flight from Copenhagen to Singapore in the salty 747. When i took off from copenhagen i had a cool 60+FPS and a few hours later that had dropped to 25 FPS. Another two hours and FPS was down to 15 and i aborted the flight.

I tried all the the usual tips, disabling traffic, reneabling, switching off ATC, VFR nav map but nothing worked. I dont use AI traffic or live.

I am curious to know if a slight loss in FPS happens on all flights but are just more noticeable on long hauls. I was hoping this issue was dealt with but it seems to be happening still.

That said, i have done long haul flights before in the salty 747 with only about a 10 FPS drop after 8 hours, but i sitill wish there was no drop after flying for a while…

Please consider voting so asobo can deal with this issue.

1 Like

Currently flying from CYYZ to VHHH. 4fps for me 8 hours in. Using the 787 heavy mod. Does this ever go away?

1 Like

No, not from my experience…

may be ask the mod developer :wink:

For me again after not using the performance tab in EFB my frames stay steady for a 2 hour plus flight
However yesterday I did a flight in the FBW A32nx with PACX enabled after 30 minutes into flight and interacting with the passengers my FPS tanked and that was a flight less than two hours
So I did another flight over two hours same plane, livery etc except without the PACX add on
So I deduce if you are using other programs or the EFB performance tab your FPS will drop
All other tabs like navigraph work ok in FBW A32nx, so I’m not sure why this is the case
Something to experiment with especially if you own and use PACX regularly , although it’s the first time I’ve used that program for a long time

1 Like

I have used several external applications including PACX with the FBW A32NX dev version. On my flights that were about 2 hours long, I did not yet experience this issue.
So maybe I did not fly long enough, or it may be something else causing the issue. E.g. I disabled all ai aircraft, but let Vatsim inject them and disabled ATC completely.

1 Like