After playing a few hours, FPS drops from 40 to 5FPS

before SU8 i had 35 - 50 FPS Here

1 Like

The same on my setup, i hope it will be better with su9

and i live RL in the near of the Airport so i want to have it in good qualaty
i am in SU9 Beta

I can completely understand it, its the same for me with edds

Takeoff with 6 Frames inside and dosnt go over 11 FPS inside view so it dosnt get better its even worse but 30 FPS in outside View

And airborne?

dosnt go over 16 FPS inside view and the bug where i cant get over 11GB in ram appears so i will get degradation very soon 11.124MB Max ram usage according to DEv mode and task manager

Mmmhhh, have you Done a simulator restart before you load the plane again?

and the sim freezes for a few seconds are back like SU6 when i remember correctly

Sim Restart ( i come from Xplane 11 i am used to this procedure) but a Pc Restart i havt tried

I would try it

Quick flight update. Currently at 34.000FT cruising and I am still at 45 FPS like it was when I started doing these flights months ago.


For the record, I have turned off the VSync option from graphics, but it should not matter.

Unfortunately, since I have removed and changed many things from the sim I can not provide an exact reason for what could potentially cause this. I have:

  • Disabled Windows AntiVirus (by adding an exception) for FSUIPC.exe MSFS.bat and the folder it self for FSUIPC.
  • Removed 3 addons (YourControls, HPG Airbus H145 and one addon it has) and removed IVAO PilotCore and PilotUI.
  • Changed Ndu from 2 to 4 as this post suggests.

Going to continue my flight, keep you posted!

1 Like

Ohhh, perfekt!!!

Dont have FSUipc installed anymore will try Turn of Defender Now With 2 exeptions (FBW320x And Salty747) No addons installed also no liveries and still Having performance degredation

Do you Set photogrammetry off?

I Had but Dosnt look good :slight_smile:

Have you tried the NDU fix? I have linked it on my post.

tried no effect

So i tried something something diferent first thing Run MSFS as Admin and turn of the Anti manipulation Feature of Defender Off and my frames are back to normal 35 FPS in EDDF at ultra lets habe a look

ok degraded to 13 FPS After 5 min