After playing a few hours, FPS drops from 40 to 5FPS

Interesting, however I did not disable anything so that might be a reason , without testing I wouldn’t know

Yesterday made a flight from GB to EDHL. About 2 hours, no drop in Performance.
Today flew from EDHL to GB. Frame drop after an hour or so. Just before landing, when i changed view, the Audio begun to stutter.

In both cases the same Aircraft (TBM), Live weather and Ai Traffic, no live Traffic.
Also in both cases i used Volanta, AAO, Addon Linker and neo fly besides MSFS.

For me that states that all those things doesn’t cause the fps los.

I still think it’s complet random or on the server side.

1 Like

It’s a known problem relating to real-time traffic - at least that is one cause of this issue. Disbabling and enabling real-time traffic may solve this issue (may not - it looks like there may be more than one issue causing this).

1 Like

I’ve not had this once, and I wonder if it only happens to those flying airliners.

Wasn’t there a bug ages back regarding the status of the stabiliser fuel tank? Like a value that for probed incessantly.

I didn’t used Real time live Traffic on both flights. Only AI offline Traffic

TBM - Airliner?

As I said, only some of this is caused by that. Have you tried toggling AI traffic off/on just to see if that helps?

I have not flown airliners, only GA aircraft. Have experienced this in the Cessna 208B and the TBM. Traffic on/off, weather live/preset, all players on/off, with or without mods. For me, the time varies but usually > 5 hrs before the FPS drops and audio stuttering. Some of these flights are with Unlimited Fuel. All are while on Auto Pilot under NAV guidance.
Unable to find a common factor locally, unless it’s between the yoke and the seat.

happens to me regularly.

I fly the bell 47 (helicopter) over London and go from a “normal” framerate to a stutterfest after 20 or so mins.

reloading at EGLC "resets"it.

doesn’t always happen.

250 rolling cache on ssd and mp/live traffic on. (140mbs average dl speed)

Maybe stupid, maybe not, but do you guys have “fast boot” turned on in windows? This is in fact a kind of “hibernate” state of windows without apps open but with services and drivers “hibernating”. As waking these drivers and services up, it could lead to undesired behaviour (leaks etc…).

It adds maybe a second of 1 - 3 for ones on SSD.

But, you will know for sure you’re pc does a… “cold start”.

Just my two cents.

A related thread that might offer some help?

Just I was searching this post.

I’m now flying from Tenerife to Berlin… It was “great” at the biggining (45/50fps) but I’m flying now over France and the degradation is noticable(15-23fps). I’m afraid for my landing…
I don’t know if this is related but I’ve “crackling” sound too.

I flight with IA traffic off but multiplayer on (I tried off but I don’t have any difference).
I’ve a 3080 ti
32 gb RAM
FS is installed on M.2
Ryzen 7 3700x

I hate SU5 so much…

1 Like

:wink: I didn’t spot your post about the TBM. The planes I fly either have no glass cockpit at all, or the 530/750/G1000 NXi, and I’ve never seen this issue. I was wondering whether it was avionics related.

I try to fly with live weather on, and live traffic, not AI.

I flew today from Belize to Cancun
, about an hour and as I was on approach, the whole system started to slow down. I noticed it first in the keyboard. Keys and mouse were slow to respond.

Surprisingly, I hit some heavy weather and that was fine. About 45 minutes into the flight.

Seems like cache or buffering issue somewhere.

Currently flying from RJTT-KLAX and 6 hours into a flight the FPS drops to constant 10FPS and I’ve tried to disable online function as well as playing around with affinity with no luck. Hope SU6 fix this ongoing issue.

1 Like

I’ll bet you anything you like that there is something in that aircrafts systems doing that.

It’s really frustrating. If we knew what is the cause, we would might be able to have a workaround.
But right now for me it is complet random. It ruins more or less the whole Experience.

Does someone know what exactly “limited by manipulators” mean?

I wasn’t 100% sure myself so I did some searches. According to the following posting:

These manipulators are basically click regions that change datarefs, or they can be used to UV map panels onto the objects.

So it’s an interactable region of the cockpit, apparently. Perhaps this is one of these cases where the more complex the aircraft is, the more chance of this bug happening.

I don’t fly the TBM much, but I fly the Caravan a lot, most of the weekend in fact, and some of my flights were around 2.5 hours long. I never saw this then. TBM, and C208 seem to be the only non-airliner aircraft mentioned.

So
When it deals with data refs, I maybe try msfs without stream deck and without axis and oh

I have a Streamdeck XL, but I use SPAD instead.

I don’t think it’s external hardware that’s the issue, but It could be something in the virtual cockpit.

What do you use Axis and Ohs to control?

1 Like