After playing a few hours, FPS drops from 40 to 5FPS

Hi all,

My first time here, not sure how to make a post… but i found a reply button to this thread which is very apt.

I hope to be able to help many others that experience an issue, i experienced today (13/5/22).

This is related to Windows 11 update [May 10, 2022—KB5013943 (OS Build 22000.675)
This update totally broke MSFS in that it cause my gpu to power spike every 3 seconds causing massive lockups even in the menu.

I rolled back this update (instructions can be found how to do this when you search for the above update).

Please if this is a repeat post or in wrong place, then point me in correct direction, i just wanted to share a problem i eventually figured out,

Fly Safe!

2 Likes

I had massive performance loss in the pmdg after a 6hr flight. I didn’t have that in the default 747 after I applied the fix that is mentioned earlier in this thread.

I also did a 5hr flight today in the pmdg and that went alright

After many months, I went back to fs2020 to try pmdg’s 737, I ran into the same performance drop issue, so I’ll go back to my xplane 11, and wait for 12, I already gave this game many chances, however Asobo keeps putting unnecessary world updates for different countries, without fixing the existing problems in this game, the sim was supposed to have a great future, but with Asobo’s decisions it will die slowly and be forgotten

I still don’t know why Microsoft trusted Asobo, a company whose experience is questionable, for such an important project. Asobo has never produced anything which is worth playing, at least according to me. They should have entrusted this project to a real and reliable AAA game producer.

4 Likes

My guess is that it went like everything nowadays, looking for the cheapest ?

What fix is that?

Try turning ipv6 protocol off in your adapter settings for internet. Not sure why at all but when I have that on I get drops in performance and weather stops after awhile. Never did a scientific study of issue but I know I don’t get any drops after shutting it off. Worth a try?
Capture

Asobo is a contractor managed by Microsoft.

Check here: Increase performances immediatly! AMAZING! Tested and aprouved!

try removing the pushback toolbar plugin

Playing with the registry, related to MSFS, is playing with fire. Unless this modification is aproved by Asobo/Microsoft I will never go for it.

2 Likes

and additional we discussed these NDU placebo already within this topic here and within the other one :slight_smile:

If your’re too afraid to do that, fine. To each their own

1 Like

Same issue here. After SU9 and its patch; before & after 5/12/22 Nvidia driver update. Unplayable framerates where before SU9 I was on high/ultra with consistently smooth frames (except for the occasional lag in long-haul flights in the default jets). I have no add-ons whatsoever - everything is stock.

Since the last hotfix I have also been experiencing this performance degradation, I’ve removed all my addons (except PMDG 737, Leonardo MD80), reinstalled the sim completely, nothing has made any difference, I have read through this whole thread, tried all the fixes, am at a total loss. I get like 30 minutes into a flight and then my GPU usage drops to 40%, and the framerate of the sim goes from 50 to 30 and degrades from there. I don’t know what changed, a few weeks ago I had no problems doing 3-4 hour long flights.

PC Specs: Ryzen 5 3600
RTX2070S
32GB DDR4 3600MHz
NVME SSD (Game installation drive)

4 Likes

This happened to me today for the first time. A simple 300 NM flight with the TBM,which I had completed successfully a number of times over the last few days, suddenly turned into a horrible 5 fps slideshow. I noticed it when my GSync-screen started to flicker about 40 minutes into the flight. Just a minute later the frames where down from 60 to maybe 5. GPU usage was down to almost nothing and even CPU usage was not out of the ordniary.

I then disabled the real-time traffic but nothing changed immediately. Then I tried changing some graphics settings off and on again (TAA, terrain caching). And after about 3-5 minutes the sim had recovered and was back at 60 fps again.

I don’t think they have something like a garbage collector running in the sim, so the spontaneous recovery sounds more like some kind of time-out effect. I’m a software engineer but of course I have no idea how MSFS really works. But this sure looks like some kind of streaming thread pool filling up with tons of timing out jobs - maybe due to Asobo server issues or due to ISP issues. New jobs for essential data are then waiting to get their turn but there is not enough available slots in the thread pool for all required data jobs to complete and so you’re down to a latency of ~300 ms for fetching some essential data much, much slower than usual to continue your flight at >300 kts.

I would assume that this problem, when it occurs, rarely is noticed unless you fly very high and very fast. If you remain in the same area, not a lot of streaming is required. If you fly high and fast, the sim needs to stream constantly. If some of the required batch jobs start failing but have some kind of timeout attached, you’ll run into major problems. I guess fooling around in the menus and changing some graphics settings and stuff made some threads finally run into their time-out limit. This, together with turning of the real-time traffic, might have opened enough slots in the job thread pool to allow the new data to come in again and then at some point everything had finally caught up again.

Anyway, that’s my armchair analysis. Could be completely wrong but I’m 90% sure that his is related to the sim getting out of sync with some data it needs to stream from the internet so that in the end the fps are tied to the rate of the incoming data packets.

2 Likes

Last 3 or 4 days start out at 20 fps, by the time Im at the end of the runway, its down to 16, and by the time I hit Euclid im running at 5 or 6 fps. Doesnt matter time of day etc.

Last week it was fine, move around airport 18-20 get airborne and fly 18-24.

Consistently bad…IMHO

WORKAROUND -
Switch on Developer Mode-
SPAWN the SAME Aircraft from the Aircraft Selector - (Wherever you are)
Frames go Back to FASTEST

1 Like

Nope doesnt work here. Something else is at foot. After the WU this morning it started running just fine again … Fps back to 20+ flew for 2 hours in the f18 no problems. We’ll see…

1 Like

Definitely something up here. Even less than an hour in I realised I had lost 10 or so fps, 45 to 30 is very noticeable. Turned off Online Functionality in the menu, back to sim, back to menu, and turned it back on, back to 45 fps.

Something is not right here.

2 Likes