After playing a few hours, FPS drops from 40 to 5FPS

So I’ve done some testing (7 flights LIRF-EDDM, PMDG 737) with the dev mode performance counter open, each time changing different things ranging from BIOS settings (virtualization, hyperthreading) to which programs were open in the background (Simtoolkitpro) Each time from 10 minutes into the flight the mainthread frame time would slowly start increasing, and the framerate would decrease along with it. Just did another flight, with the online functionality turned off entirely, absolutely no problems at all, no loss of performance. I will continue to test, possibly trying a VPN or swapping out my routers, will continue to update.

I should also mention that in the past I have tried turning off online functionality in flight, turning back on, leaving off etc. to no success after the flight had begun.

Hello,

I did a flight from Olbia to Trosmo today, as expected the performances degraded approaching from Tromso, I disabled live weather, enabled it again twice and the performance were almost back to normal.

So there is definitively a problem with the weather system.

The daily postings where someone thinks he has the solution are getting tiring after 2500 posts.
Because all is repeating

1 Like

But I have also these frames problems with REX as my weather tool

I really wish there was a definitive, official solution. But 1 year since the original bug was reported there isn’t, so going round and round in circles is all we have.

6 Likes

I’m having the same issue even without any addons.
I’ll post my specs just in case it might help the developers

Intel i7 10700k (stock)
Corsair Dominator Platinum 3200Mhz (just simple XMP turned on)
Nvidia RTX 3080Ti FE (stock with latest drivers)
Windows 11 21H2 22000.675

Game mode turned off
HAGS turned off
Variable refresh rate is on as I am using Gsync.
Running the sim at 4K Ultra all settings maxed out except motion blur and lens flare turned off.
Multiplayer and live traffic is turned OFF
Traffic settings is all zero at airport
boats and road traffic all at 50
Fauna at 100
(Not using rolling cache)

Hope it helps a little bit.

EXACTLY…!!! I have been following this thread since April 2021 when I first started playing MSFS…thus far there was only one confirmed workaround (Set As Destination in AI Pilot Menu) but that is reportedly no longer effective. All the “solutions” that people came up with are just repetitions of earlier posts that no one bothered to read anymore…

At this point I feel pretty confident in saying that there is no workaround (probably won’t be one ever). Until we hear something official from Asobo that the cause of this issue has been found and is being worked on, I don’t think we need to waste this much time searching for the magic solution. However, we do still need to vote this up!

Just my 2 cents.

8 Likes

It is definitely something with the planes themselves. I don’t presume to know what or how or why… I tried multiple variations of 3+hours flights to find a common source and for a long while I made long flights work with just setting the departure and destination airports. In the end, even flying with simple airport to airport GPS failed me today. So, I went on a quest to find new solutions… until I had found a post about reloading flights or planes :

!! Workaround !!
Reload the PLANE mid-flight using Dev mode. Magically, FPS are back the moment the plane reloads.
This leads me to believe something in the plane’s systems gets stuck or is badly managed.

Warning ! It is super stupid, and you have to use active pause AFTER reloading because you are going to start up your plane from dark to cruise at altitude while the systems run but the plane is not moving. Try to match everything like before reloading, you have a brand new plane now.

HD is still processing at this time. Sound didn’t record for some reason and ultrawide does not make for friendly recording, but you got proof right there that it works :
https://www.youtube.com/watch?v=EZWZynhdXLk

Flight started fine, recorded from just after setting cruise and let it do it’s thing…
2h later, it’s not fine anymore… Something processes for too long in main, rdr or coherentui
I suspect coherentUI because the external view renders faster. It is still affected but less than cockpit view.

At this point the flight is garbage 3h-in anyways, might as well try something different.
I had read somewhere to save and reload flight, I did try that before with another flight : it crashed.
Then someone suggested to use devmode to reload the plane; I tried to find that post again. Whoever you were, you are my hero.

(edit) To be clear, I did fly without pushback toolbar, or navigraph or whatever mods everybody seems to be pointing their fingers at, performance still degraded regardless. My conclusion is very simple now, I’ll add back all my mods, put all features I want on, and when the flight starts going to ----, I’ll just reload the plane from now on.

For me it is allready clear that part of the problem is on the server side. Because “workarounds” that seem to work one day, doesn’t work the next flight.
It also seems to appear on all kinds of planes.
For me i had it with TBM, FBW, DC6.
But for the last 1 1 /2 month it wasn’t an issue.
In that time i made one 7 hour flight, and on a different occasion i made 3 flights, without leaving the Cockpit. That lasted for about 8 hours. Also no drop in frames.

I still do not get how this is not fixed already. This has been reported long time ago, perfectly described and there’s no progress from Asobo at all.

People are posting this issue on every forum, every facebook group on daily basis. Still no progress.

Do you remember how Asobo wanted to implemented “more detailed FPS meter”? This has already been 2 months ago and nothing was implemented.

I guess adding new World Updates is more important that fixing not working product.

Just to add I still believe it has something to do with overall performance. When you are starting from big city, or crossing over big cities, performance will degradate and won’t come back. But flying over ocean seems fine to me.

5 Likes

Installed some type of FS2020 updates last night, 600MB worth I believe. Started a flight last night from PHNL to YSSY in the Headwind 330-900neo (I’ve noticed the FPS problem FBW n32x and 787 as well). 3 hours in was still running at 40 FPS. Went to bed hoping to wake up and get ready to land. Walked in and the sim was running stuck at 2.0 FPS and the sim was unresponsive doing some type of downward flat spin. Not sure how many hours in this started but I posted the map below. This was the first time I ever seen the FPS ticker completely stuck. Also seems like 500.00 ms right below it was maxed out as well because that was not moving. I posted 3 screenshots of the FPS display because the RED was fluctuating every second or so between MainThread, CoherentGTDraw, and CoherentGTUIThread. I have no idea what this means but took note of it hoping a developer or someone that is trying to figure this out would see it. Really disappointed this is not fixed. It was going to be my first time to Sydney and now I feel like Tom Hanks from Cast Away with no volleyball. The rest of my PC was running perfectly fine.


FPS3
FPS4
FPS5

4 Likes

Coherent GT is the software Asobo use to create the interface. It seems to be a common issue.

https://coherent-labs.com/Documentation/cpp-gt/

I looked recently, and they are a few versions behind what is currently on offer.

1 Like

Same for me … (starting flight 55-60 fps > 20 fps after 5-6 hours )

Intel i9-12900k
Nvidia RTX 3090 FE
DDR5 32 gb

2500+ _ post about this and this has been going on for over 1 year now !!

Really Asobo, it is about time this was fixed, rather than spending time & resource adding more “Extra FREE STUFF” on top of a broken Simulator.

Yes, while adding new stuff is FUN and EASY, sometimes one just has to buckle down and tackle the not so fun, boring, frustrating, but NECESSARY “Work” .,

(and DOCUMENTATION !!)

20 Likes

AMEN to that!

1 Like

has Asobo responded to these issues at all?

It’s really unflyable at the end, boring and ridiculous. Everytime I see an aircraft in real life landing, I see stuttering aircraft, because my eyes are used to see stuttering landing aircraft!
But as I promised before more than two weeks and maybe before 200 comments or more and gonna repeat it:
You have time till the end of may, if nothing will be worked on or at least announced that this issue will be solved, then the following will happen:

  • rating msfs2020 everywhere with 1 star or less
  • recommanding no one to buy msfs2020 in the future
  • no support for developing issues anymore from my side!

I hope you read this!
Best wishes!

5 Likes

It’s pretty cool that the hundreds of dollars I have dropped into this sim sits idle. I can’t fly at all. Frame rates make even attempting to control the plane impossible. This just happened within the last 3 weeks. I have tried every fix imaginable and had to give up.

4 Likes

For me the performance issues began with SU8. The spinning circle, the need to fly in developer mode, and the need to delete photogrammetry cities half a world away to enable performance on the ground. And since SU9 an additional manifestation of degradation.

It used to be that I could set up a flight immediately before putting on a coffee. I would be able to return with my coffee knowing that everything was as I left it. No longer. Leaving the sim running on its own for ten minutes results in a drop from locked 30 FPS down to sub 20 FPS. No live weather, no traffic… in fact, the aircraft is sitting on the ground cold and dark.

And, try going back to the main menu from this condition and it takes about ten minutes to get to it.

The sim is broken. It has nothing to do with my computer, my addons, or my Internet connection. There are fundamental flaws in the design architecture of this product which appear to be not sufficiently addressed. And perhaps this will only be taken seriously when enough people are noticing it and experiencing it with some future update. It is a very frustrating and disappointing experience. Unfortunately, I have yet to see a glimmer of hope which suggests they are getting a handle on this.

9 Likes

Same. My computer ran everything fine up until SU9. I had very occasional CTDs but that seemed due to the add ons. Everything set to ultra with photogrammetry on. Now it is like looking at a slideshow if I have PG on. Even with it off I start getting stutters after an hour, from 50 fps down to 20’s with stutters.