After playing a few hours, FPS drops from 40 to 5FPS

Sometimes you dont have to wait hours for ■■■■■■ FPS. Just tried to fly 6:00 est, best the sim would produce is 11 fps. This is getting old real fast I tell ya what.

I am pretty certain this bug has something to do with live weather. When this bug happens to me there are no clouds anywhere. When i exit the sim and reload the flight after saving; my FPS is back but cloud coverage is also back. There is no certain amount of time when this happens, but when it happens: weather injection seems tot be gone. Unfortunatly resetting live weather during flight does not work, i have to restart the sim.

Live weather has been bugging this sim several times so maybe the solution of this bug lies here as well…

The registry change in the following topic seems to have helped some folks who experience performance degradation the longer they fly::
(NDU registry change) Increase performances immediatly! AMAZING! Tested and aprouved!

Maybe worth a try, but YMMV…

Hi, simply try to fly without lights -
… ALL LIGHTS OFF from Departure Airport until Arrival and see if there is difference…

yes … but one test just to see ?

just test that i did and see the result…

This really worked for me. I have been struggling to get rid of these performance drops for months and your little trick finally helped. Thank you so much. I suggest everyone to give it a try!

I will try it when i have the problem the next time

@TenthBump40

Thank you so much for this, will test this evening. Do you know if internal lights have the same effect?

Hi, internal i didn’t try… only all externals… You can use the lights but after one hour /hour and half you must fo this procedure and switch on the light again… and so on…

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes and No, Only put DevMode on to see FPS/Performance

Brief description of the issue:

When I load into the world, about 80% into the loading bar, the performance plummets from around 150-300 FPS while loading, to 2 FPS with the Coherent GTUI Thread completely collapsing and altering with the Main Thread of being the limiting factor in the FPS display. Once in the world, I have 1 frame every 2 seconds, but showing as 2 FPS and again the Coherent GTUI Thread still collapsed. No matter where I spawn. With most planes everything works as intended. Just the Darkstar and the Volocopter create this problem.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Loading into the world with either the Darkstar or the Volocopter.

PC specs and/or peripheral set up if relevant:

Intel Core i7-7700K
NVIDIA GeForce GTX 1080
16GB DDR3 Ram
ASRock Z170 Pro4/D3
XBOX Controller to fly.

Build Version # when you first started experiencing this issue:

With 1.25.9.0 I got the Darkstar problem, but the Volocopter hasn’t even loaded in previous builds and now has the same problem accuring in the loading sequence as the darkstar has in loading and in the world.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

It happens almost every flight. I hope Asobo is going to fix this issue

1 Like

Thanks, does it matter the order you turn them off and on, or can you just turn them all off and then on in any order?

Flight is between SPHA and VDSR. For whatever reason this bug seems to have to do with distance and not flight time. Atleast that’s the current situation for me. I had another somewhat unrelated bug where under the AI pilot the only destination that would show up is the departure airport. Out of curiosity on how far away I flew from LOWI with the Darkstar as I was somewhere over eastern Asia, I noticed that as soon as I set the destination the very same thing would happen as in the video. When unselecting it’s back to normal. Sadly I don’t have a recording of this but somewhat tried to reproduce in this video without having the destination bug. What’s a constant though in both cases is that when a route was calculated the stuttering appears when there is enough distance between the DEPARTURE airport. I hope this helps in finally resolving this annoying issue.

Maybe as a sidenote on how it was previously. I did have this terrible gpu usage often even right after the game loaded. Also the issue with the camera stuttering when turning. I have 32 GB of ram, 8 GB of vram and it just doesn’t get used at all. If I did a 360 rotation it used to extremely stutter always even when on the ground and not moving. It’s not like the stuff stays loaded in (or whatever causes this) as it stutters the same when you look around even when you turned the camera around multiple times and didn’t move an inch. Atleast this issue is much better now, even if not completly resolved. I hope one day they decouple the loading in from the fps. I’d rather have unloaded textures for a few seconds rather than the game literally freezing to load in stuff.

1 Like

I switch off all except Strobe , no matter the order but must remain on only the strobe and after you can do the procedure

OK, so turn off all except the strobe. Then turn off the strobe, and then you can put them back on?

1 Like

Sorry, but you didn’t see my video?

Yes I watched, just checking, and trying to work out how to do it with different aircraft.

Ah… ok… this is very interesting… let me know if this trick works also with other type of aircraft…
Thanks

It’s not based on distance travelled. My FPS already degradated in past even when I was standing at gate