After playing a few hours, FPS drops from 40 to 5FPS

I try this trick with the PMDG 737 for me it doesn’t work, only way I can get down the manipulators is to go to menu turn on online functionality, then back to the sim, then fly for afew seconds, then go to menu and turn back on online functionality, then back to the sim, then my manipulators go back to normal.

I switched from 3900X to 5800X3D CPU and since then I don’t have the issues with FPS drop after 1-2 hours of flight. I mostly fly the Fenix A320 now and don’t have any degradation anymore even in very cloudy conditions.

The cache in the CPU seems to help

I had to deal with fps drops, especially with drops when moving the camera on 1-2 hour flights around and today I found a solution.

Example of bad performance: click here

  • empty your community folder, only your aircraft
  • make sure YourControls is removed
  • in case of AMD CPU follow this procedure (click here).

This solved pretty much the problem. Hope this helps!

2 Likes

Yesterday my game was crashing at main menu after telling me it couldn’t connect to stream or something like that. Over and over again so I figured I would just re-install the game. Before I did, I grabbed a spare 500GB SSD, formatted it and threw it in my computer. Re-installed FS2020 and only FS2020 onto the new drive. I made a backup of my community folder so after I installed, I put all my stuff back. Other than having to reset my custom views, everything was back to normal. I usually get the FPS drop around the 4 hour mark of flights and I just completed a 5 hour flight from KSFO to KEWR without the FPS acting up at all. I do not think it dropped below 30 fps. Not sure if others have tried this already and it’s only one flight but re-installing the game on a SSD and dedicating FS2020 to that drive possibly worked for me? Not going to hold my breathe though.

You didn’t need to do all that. The error message indicated a network connection problem that was most likely transitory. There’s good evidence that some of the performance issues are caused by network issues. But I don’t think Microsoft has ever acknowledged that.

for all having AMD CPUs, updating the bios to the latest version with AGESA V2 PI 1.2.0.7 made my fps performance much better and there were no stuttering and I have got much higher FPS on landing than before. I will try more flights and let you know about the results.

1 Like

That sounds possibly too punitive … I think that we should, as a group, continue to try and express our needs and desires, and clarify more whether they’re understanding us and can better speak to the core questions … as detailed in some of the other comments on here, thanks. :nerd_face:

I only removed YourControl (also I am an Intel user) after I read your comment, I’ve been able to complet 2 flights with PMDG737 and made a quick tour with the Fenix A320 and its flyable, I guess YourControl caused my Perf Degradation issue, Thank you for pointing out YourControl <3

1 Like

Well since re-installing FS2020 onto a dedicated SSD… I just completed my second flight which was the reverse flight of my original post. I flew KEWR to KSFO… 6 hours and 19 minutes… the FPS averaged 40 FPS the entire flight. I think while I was taxiing to the gate at SFO it had some drops down the high 20s but never dropped below 25 FPS. This is absolutely huge for me because last time I flew this route the FPS dropped to 2-6 FPS over Utah with the sim being unplayable and the plane eventually rolling over and crashing. This time I completed the flight with an average FPS of 40. I’m starting to think the clean install onto a dedicated SSD did it for me. Still not going to hold my breath but I’m super juiced about this.

40

Also approving that reloading an aircraft by enabling developer mode → choosing a different livery, does the trick for me , every time. From 30 or 20 FPS back to 45-50 for me.
Anyways, this proves the point of a leak somewhere in the sim code.
Of course others can suffer from the same symptoms due to a totally different reasons, but if reloading fixes your FPS, that’s the proof.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

On roughly every 5 out of 15 long haul flights I get a ridiculous amount of performance degradation. I’m talking perfect near 60 FPS down to a slideshow of 5 FPS for no reason. My temps arent high I have more than enough ram at 64GB. I’m not getting any bottle necks. I’ve tried vanilla and addons and both seem to get this issue.
I’m a long haul guy I like flying the big boys over long distances. So to me with nearly 33% of my flights having to end because of this I’ve stopped using MSFS much.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Nothing much to detail other than starting an ultra long haul and wait.

PC specs and/or peripheral set up if relevant:

Core I7 10700k (recently I set its target clock speed to 4.5 GHZ which it consistently achieves with no difficulty) 64GB ram. RTX 3050

Build Version # when you first started experiencing this issue:

latest version


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Let me add to this by saying I have experienced this bug for a couple of weeks now. It is very notable since SU9 and I cannot recall an event like this before.

I happen to have just bought a new computer (bar the GPU) so everything is freshly installed.

A few symptoms I observed:
It seems that the GPU degradation happens quicker with Fenix than PMDG or FBW. With PMDG/FBW often good after 3 hours, but with Fenix, degradation happens after 2-3 hours.
If I continue to let the flight run to 6 hours, it can get to 1FPS at the lowest rendering scaling.

Also a note, since this has been happening. I have followed every optimisation instructions, including but not limited to, clearing caches, vanilla state, delete all mods, deleting controller presets, disable/enable overclock, disable/enable autotuning-level, disable/enable TDR level, disable/enable game mode, disable/enable hardware GPU scheduling, disable/enable Ndu, disable/enable windows update speed limit. Some of which improves load time or frame rate, but NONE stops the performance degradation over long flights.
Edit: I don’t have Your Controls or Toolbar Pushback installed. The bug happened for me unpredictably, but both in circumstances at vanilla state as well as current state with World Updates and mods installed.

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

Technical symptoms: WITHOUT CPU bottlenecking, GPU usage will slowly decrease through time from 100% to minimal, causing framerate to drop to minimal.
Also, reserved memory usage for MSFS goes up to 20GB, through time.
Quiting the flight and going to main menu restores normal FPS and GPU usage but game is still laggy and slow in responding to clicks in menus.
Loading into another flight is impossible due to high memory usage and will be stuck in loading.

Provide Screenshot(s)/video(s) of the issue encountered:

6 hours into first flight (Fenix). Note there is not CPU bottleneck, but GPU at very low percentage. The spike was from Alt-Tab to screen capture.


When in general options menu, it seems GPU usage gets bumped up a little thus better frame rate, but not in other places of the menus.

When loaded back in menu by quiting the flight, the game stutters and the plane continues to move out of the hangar and takes off. But there is some GPU usage restored and “normal” frame rate.

Loading another flight, the game hangs and there is 18GB reserved memory, and the process is halted (suspended). My speculation: most likely due to leakage in sim.

Therefore there are actually 2 symptoms here: GPU performance degradation and System Memory Leakage.

Detailed steps to reproduce the issue encountered:

Nothing much to detail other than starting an ultra long haul and wait.

PC specs and/or peripheral set up if relevant:

Freshly bought PC, 2 weeks old. Latest Win11 and Nvidia Drivers. 12700F, Strix B660-G, 32GB 6000Mhz DDR5, NVMe Gen4 SSD 1TB (MSFS is installed on this drive), old GTX1070FE.

Build Version # when you first started experiencing this issue:

SU9

2 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

after fling ifr with the TBM 930 FPS drops from 60 to 4. If I shut down the aircraft fps reset to 60 for a vew seconds than decrease to 4 again. turning on and of the battery resets fps to 60 and than it decrease again.

If relevant, provide additional screenshots/video:

If I don’t watch out I will let it drive me crazy. Any flight longer than three hours results in fps dropping from around 40 to 5. I landed at Menara today in a slight show. Help! This so spoiles the fun…

Next test report:

I7-10700, RTX3080, VR, 32 GB RAM.
Before it I had mostly degradation to 15fps after 4h flight or/and CTDs.

What have I done?
Change to max fps 30 via Nvidia Control, Increase Pagefile to min 16MB and max 10GB, remove Pushback toolbar (left only vatsim and pdf ingame) also Volanta and Google Maps (returned to default. I updated RTX, FSUIPC.

Thats all and I have not troble after now 6h floght by PMDG B737. In my opinion unfortunataly I might be victom of radomly degradaction and CTDs effects and it not demand on my configuration, but MSFS vibe, server (weather and photo) avaibility.

I hope off course Im wrong and I have never again degradaction and CTDs…

Keep the fingers crossed.

1 Like

I think you mean degrading, but I love that word, and now feel compelled to find a use for it.

I’m thinking of leaked reports that become less, and less redacted. :slight_smile: :+1:

1 Like

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

After a couple hours flying my fps dropped to like 10 and the scenery wasn’t loading properly, resulting in a blurry scenery

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

Fly for more than 10hr

PC specs and/or peripheral set up if relevant:

Xbox: Xbox controller, mouse and keyboard

Build Version # when you first started experiencing this issue:

1.25.12.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hi @DegxI,
Was this noticed after SU9 or was it present before this?

It has been before the SU9, it also happened sometimes when i continue my flight without leaving to the main menu, the scenery looks blurry, bad performance and CTD.

Todays experience, start at 20, take off and in a matter of 20 min down to 5. Tried it in both win11 and win 10. no difference…even tried the ndu fix, nothing…