After playing a few hours, FPS drops from 40 to 5FPS

This is not man-made decision. Their system automatically marks all reported issue as solved. Thanks for reporting it, maybe one day it will be fixed.

I assumed so. I wonder why that is.
I hope this issue is fixed sooner rather than later.

2 Likes

“Solved” doesn’t mean that. It means it was accepted as a bug, and has been logged on their internal bug tracker.

1 Like

Huh. That’s interesting. Thanks for letting me know.

1 Like

We get to wait 1.5 months for SU7 - what a freaking joke

2 Likes

Can confirm. Long haul plans are definitely affected. The dev mode shows main thread and “manipjlators” are loaded. I don’t know what “manipulators” are, but that’s probably whats making the main thread load up. Also, pausing with the esc key make the fps recover, but on my machine, my GPU fans start to ramp up speed heavily. Something is loading up the sim real hard, and that’s whats doing this. Screen:


4 Likes

Its the length of the flight plan. I loaded up the F/A-18E and filed a plan from SFO>OMDB. I know it won’t make that, but the point was to establish the length of plan. That seems to be related. The short trips don’t seem to be affected as badly. So, I wonder if it’s really weather doing this. Somewhere I was reading that someone thought this was weather related, but that doesn’t seem to be the case. I started with a weather preset, and still with that plan in an aircraft I hadn’t experienced this in, it’s still doing it, and only when I file a long haul plan. So, what is the sim doing when it’s anticipating a long flight? Is it not downloading and storing scenery along the route into the cache? Because if it’s storing it in RAM, then I would expect to see that showing up on the game bar. But, the total GPU RAM available doesn’t, either. Not related, I know, but just to establish that there are other problems with the game bar.

So on my machine, it most definitely is directly associated to the length of the flight plan. Longer haul, worse performance, and the degradation is more rapid. If I file a plan with short hops, it doesn’t result like this.

That’s very interesting. Thank you for sharing your findings!

1 Like

Indeed. I may not be the most thorough, but certainly can troubleshoot.
So what has happened? A few of us should probably test a couple of scenarios as well to confirm our findings. I just want to fly, so I get it, but this makes that impossible. Nobody could land a 74 at 8-12 fps. That’s lame.

Yea. I find it challenging landing the 320 at 10 fps. Ground steering is even harder for some reason.
I fly on the VATSIM network pretty much exclusively so this stuff is very important to me.
Sure for the average simmer it’s fine. Just a VFR flight to see some attractions. Nothing wrong with that.
But, if they want to keep me and many other simmers around when X-plane 12 comes out, they’ve got to improve drastically on stuff like this.

1 Like

Well now this is weird, but suddenly, in the 18 @FL350, same weather preset, suddenly it just snapped to 30 fps. No explanation. All bars on the dev mode tool show green. I wonder what just happened. Well, not the GPU graph, but all the others. DX11. Only using almost 3gb gpu ram now of 7.12, but still doesn’t use the whole other card with another 8 gb on it. That’s something I wish they would develop is multi gpu support. But, maybe they had best leave it alone…

Amen - competition is good

This might help. The people who say they don’t have this issue are either

  1. Radeon users with cards such as the RX6800
  2. or people who have set vsync and locked their FPS to 30 which tells me they are focused on mostly being GPU bound as opposed to CPU.

The Radeon users not having this issue is a bit surprising, but actually makes sense. Nvidia cards have a higher GPU driver overhead than AMD cards according to hardware unbox and that could cause some issues especially considering MSFS uses a lot of CPU.

3 Likes

Report it of course. But also try to make a big fuss about it publicly on the internet. In a good spirited way.

Because 90% of the time you’ll be laughed at or you won’t get any reply when reporting at ZenDesk. No matter how much time you sink into perfecting the report details. At least that’s my experience so far. If it’s a positive feedback, you’ll get quick “Aww, thanks”, if it’s a detailed report, you’ll get no reply or “We don’t support your configuration” because of some irrelevant detail in your report. Like some hw device, or controller, etc, you just listed for completeness.

I’m on RX 6900XT, 4K 60hz, vsync, high-end preset and haven’t had this issue anymore (4 flights done in low to medium density areas). My guess would be that it still would affect everyone then but just wouldn’t be obvious or noticeable to all users.

I’m a Radeon user. 2 vega 64s, and locked at 30 fps. Really, I built this machine during the alpha testing phase to put the best stuff available and attainable at the time from AMD to work on this thing. All of that went south after the last update.
Gradually, the performance begins to decrease more and more, where one is barely able to keep 10 FPS. That said, it seems not always. I’ve found that the length of the planned route seems to be the biggest contributor to this issue.
As of today, I have seen consistently that the length of the flight plan is creating some other issue, and I can’t be sure, but it may be trying to work on something you’ll either see or find along the route. Either way, in dev mode, it’s loading up the main thread and the “manipulators” listing. And as I’m en route KSFO>OMDB in the F18, it suddenly snapped to 30 fps, and is holding it just fine. I have no clue what happened, it just did it.

Nvidia 3090 locked at 60fps if that helps, and I only fly GA.

Unlock your FPS and do the steps.

  1. Taking a shot of the Dev mode FPS counter after your 1 hour flight when landed at an airport,
  2. then exiting to main menu and spawning back into that same location and taking another screenshot to compare.
  3. Bonus if you restart MSFS and do the same thing
1 Like

That reads like that old adage “Doctor, it hurts when I lift my arm in the air.”

The issue is marked as “Under Investigation” in the recent dev update:

2 Likes