After SU10, FPS still drops during flights

That’s a fair point. Should have probably said it is a “workaround” for now. I agree this isn’t normal and needs to be analyzed and corrected. But, until then, at least I know that when I experience it (on maybe 20% of my flights) I can toggle a setting and at least complete the flight. All virtual passengers are now assured a safe arrival. :wink: Thanks for your comments.

1 Like

I have been having this problem recently also. I just can’t get my head around why this happens. I can fly from the UK to Europe, then on the return around half way back, FPS drops from around a stable 80 to struggling to reach 40fps. Once I start the descent and get closer to the ground, the fps will shoot back. I have tried a complete re-install of the game but it still does it. Like you, if I turn Photogrammetry off, it is absolutely fine again.

Do you think maybe a full re-install of windows may help? Or do you think this is an Asobo issue which they will need to rectify in an update?

Hey Alex. First of all, welcome to the MSFS community. There is a treasure trove of helpful information here, so glad you have taken the plunge.

No, I don’t think reinstalling Windows is the answer. I am on a new, homebuilt PC (specs in profile) and I am having this issue. So I am fairly confident that will not help at all.

I really can’t say exactly what the issue is. You can see that discussion about this issue involves a whole host of considerations. But I do believe (IMHO) it has to do with streaming, and especially when related to caching.

Frankly, I’ve been away from simming for the past month or so attending to other responsibilities, so no recent troubleshooting. That said, I soon plan to disable caching completely and see what effect that might have. I’ll update to this thread what I discover.

1 Like

Hey @AlexSkeff95. As promised, I did disable caching completely and then did a flight that had previously shown significant stuttering on takeoff and especially on approach and landing. This specific flight was buttery smooth.

I am not claiming this is the ultimate answer for my setup, but this preliminary test flight is encouraging. I will do more flight in the days to come to see if this was a fluke or a real workaround. Stay tuned…

Hey there @Sartanius

Thanks for coming back to me as promised - it is greatly appreciated.

Interesting find. Did you just disable the caching in the settings within MSFS, or is there further steps you need to complete to disable it?

Since our last posts, I have found that even with photogrammetry turned off at the very beginning, after around 5+ hours the fps nearly halve. Then when I turn the photogrammetry ON, the fps go back to normal. Such a strange thing to happen - so this is exactly the same as starting with photogrammetry on and then turning it off to get the fps back.

Software isn’t my strong point either which doesn’t help. But there’s something causing a dramatic FPS drop after a certain time frame which never affects landing because by the time you get halfway through the descent the FPS resumes. It’s just during the cruise.

1 Like

Yes. Simply turn off the Rolling Cache and delete the existing Rolling Cache file. I highlighted the two setting in red boxes below.

1 Like

I am having this issue even on relatively short fligths of around an hour… On approach last night, FPS was tanking down to sub 1 FPS (yes, SUB 1 FPS) after starting off buttery smooth at 60-80 FPS.

I have not tried turning photogramic scenery or the rolling cache off yet.

2 Likes

There is not a fix for this problem from Asobo?

1 Like

have the same issue. after an hour ish the fps drops to half.

but if asobo cant even fix their own programmed white dot on the screen I dont have much hope for any of these more complex issues.

6 Likes

Maximum frame rate is now on off in Nvidia settings and this help me. Try this out guys.

That makes sense in my case too - it was flickering when I posted a while back but then took a long break from it. When I returned there was the usual big sim update and then it advised me to update my video drivers too.

I installed the latest Nvidia set and did it as a clean install as usual but this time I have not touched any settings in the NVCP at all, I believe max framerate is off by default and I have a feeling I had it on before. Its working now so I’m leaving the NVCP alone completely

Hi, to those following. After a couple more rather long (>4 hour) flights with zero stutters, I can confirm that, for my system, flying with rolling cache completely disabled (and deleting the rolling cache file) has done the trick. This has nothing to do with photogrammetry or Bing data they remain enabled.

I don’t believe this is a surprise to many since it seems quite a few already knew this. In any event, I don’t experience any downsides at all with rolling cache disabled.

For me this is a simple workaround, and I am a happy camper. Give it a try.

3 Likes

I think that somehow the memory is full after a long flight. That’s why it stutters like hell after landing. But there are also players who don’t have this problem.

Today he do not load the airport EDDF after a long flight.

This problem had mostly gone away for me until this week. I am really hoping it is to do with server issues (probably overloaded due to all the updating).

Since updating to SU13 it is back with a vengence. I have a very good system (5800x3D 4090 etc). I load up my aircraft in VR and get 55fps. 20 minutes later by the time I have taxied out it is down to 45fps.

Half an hour into my flight it is down to 23fps.

On final approach I can barely manage 18fps.

After landing it is down to an excruciating 12fps.

Reloading a new flight with the same plane in the same location, back to 55fps.

Please, please, please, please, please fix this issue (as I said, it had recently improved with me do nothing to change my system or install).

After reading the SU13 notes and seeing this problem marked as fixed I had high hopes, but it is worse than ever!

6 Likes

This is just getting ridiculous now. Can not complete a flight more than 2 hours and 40 minutes without these giant pauses/stutters which usually occur on the decent. Temps are fine … system specs are good … rolling cache deleted and off. I am out of ideas.

Found an interesting thing on my side.
After an hour or so of flying my FPS are going down a lot.

When it happens, it appears that my GPU is charged at 99%…

I just go to the graphic menu, and turn antialiasing to DLSS and go back to the flight for a few seconds.

Then i go back to the menu and come back to TAA.

No more FPS drops, and i can still play with a very good frame rate…

Tell me if it works for you !

You don’t hear anything from Asobo about this memory problem. They don’t seem to be interested

That’s not true. This is one of the topics that was covered in the last dev livestream.

Scroll down to “Stability and Memory Improvements” in the transcript for more info…

1 Like

They say that things have improved in their exam, but nothing has improved here with us