After update no custom models anymore

Hello.

Updated the Sim and SDK. Maybe i oversee something, this is the first update i did. I had a project going on, pretty far already, with around 5 buildings, a tower and clutter.

Now i tried to open and rebuild it but all my models seem to be gone. They are visible but named as “unkown” and if i search for them in Scenery-objects, they are not in there. Yes, ive reloaded the project after build. Various times.

Since this is first SDK update (maybe second, at least i cant remember problems), are there steps to be done after an update? Cant find anything about that. I mean, im aware of issues like CTD after updated but this one i didnt encounter yet…

Btw, it compiles without errors.

Would appreciate some thoughts. Thanks!

Placed custom objects are “unkown”

Nothing there if i filter.

unknown.png

Everything is still in place, like yesterday…

No errors.

Just found this, what is the meaning of "shadowed, unmounted and “suspended”? Cant find that in the SDK…

I had the same problem. I needed to build all databases and restart the sim.

I also had to first rebuild the project and then restart the sim to see all my custom models.

Hmm, this is strange. Just tried as you mentioned to rebuild my scenery but still all my own objects are unknow even after a restart…

Hey guys, I am facing the same problem as described above, objects not recognized and listed as “unknown”. I will follow up here if someone gets any solution, in the meatime I will try myslef to see if there is any workaround and if I see any result I will let you know. Cheers!!

PS. Anyway, I was able to see some customized objects that I made for another scenery that is released and working but the ones in WIP are the ones that I cannot see. This is really odd.

Same problem here. Even after rebuild no custom objects. They are visible in sim mode but not dev mode, so not able to work on projects. The SDK is screwed up!
I put in a bug report to zendesk last night but no change so far.

OK last minute news, I just opened a brand new scenery project mostly with SDK defaults objects and I copy/paste a customized object that I used in another scenery and now is visible and usable, so now I need to figure it out how show the other ones that are still missing.

Maybe renaming the objects and reimporting them from Blender??? Not sure yet.
Regards.

1 Like

I’ve submitted a bug report on this too. I tried with just the SimpleScenery project (with all the incantations for moving things into the Community folder) but nothing worked for me. If that doesn’t work, it’s a bit bleak for all the other scenery projects that WERE working last night and not now after the update.

I opened a new thread on this as I had been searching for the BGL failed rather than object import problem

Tip now is go via Community… let it preload. Cite Jeppeson2001 on fsdevloper

[quote=" Jeppeson2001"]

OK, so after experimenting further I think I’ve found a workaround.
It is long winded compared to the previous workflow, however it’s better than scenery creation coming to a grinding halt.

1./ First of all copy your latest compiled package into your Community folder
2./ Create, or amend your custom objects and compile in the normal way in Blender, 3D max, etc
3./ Run the sim and once in the Main Menu open your project and ‘Build Package’ (no need to go to your airport in the sim at this stage to save time) DO NOT click Load In Editor at this stage.
4./ Once the package has been built, exit the sim.
5./ Go to your project folder, copy and replace the previous compiled version into your Community Folder.
6./ Run the sim and go to your airport/scenery area, then open your project, myscene and click ‘Load In Editor’, DO NOT click Build Package.
7./ Your new, or amended asset should now show in the Objects of the scenery editor

I hope this helps and works for you. Hopefully there will be a proper fix soon!

AWESOME!!!
It worked for me, many thanks.

Just one clarification, on Step “1./ First of all copy your latest compiled package into your Community folder”…

If you guys dont have any previous compiled folder (from “Package” folder), just go directly to Step 2 and follow the steps.

Sadly, there are 2 comments regarding this…

1.- We have to repeat all these steps everytime we add/modify a custom obejct…yes, over and over again (bummer)

2.- After the compiled files are moved into “Community” folder then the scenery objects are gonna be “glued”, so when you move them around the oldest one remain on its original location meanwhile you are moving the object to its final location…- so my suggestion here is… work first with the default SDKs (polygns, terraforming, runways, vegetation, exclusions, etc) and when you are done with that, you can add your customized objects at last, othewerise is gonna be a mess.

Best Regards

I’ll repeat what I’ve just said on FSDeveloper – for those whose issue is that they don’t see their models in the scenery list, and already-placed objects show as ‘unknown’, you can separate out your library to another package, so that your library isn’t disabled by opening the project. You only need to do this once, although I’ve set mine up so that I can combine them into one project when this is fixed.

Just for clarification for someone reading this now, this all not needed anymore.

Seems one of the last patches fixed it.

Hmmm I have this issue now. Customs objects not shown anymore in scenery list. Last week it worked flawlessly… what gives?

It can have other reasons too. But it’s not broken anymore on editor base. Probation something is wrong in your project.

I would look at fsdeveloper Forum, i think I’ve seen someone else with this there but no idea where it was.