After update Sim won't load (STEAM)

Can anyone help. This latest sim update installs then it goes back into loading sim gets halfway then CTD? Never had this problem before? TIA

Things to try are:

Ensure all your Windows updates are installed.
Ensure you have an open path through the Window’s firewall.
Make sure the time and zone in your PC settings are correct.

If you had the Google Maps Replacement Mod installed, reinstall it, then uninstall it using it’s uninstaller.

Reset the MSStore app on your PC.
Reset the xbox app on your PC.
Reset the Gaming Services app on your PC.

Sign into MSStore, install all updates in your Library

Reboot PC, then, with an empty Community folder, no 3rd party plugins running, try sim.

did all that already still the same problem.

Had the same problem yesterday. I logged out of xbox app on pc, logged out of microsoft store, rebooted pc, logged back in to both, then it worked.
My install is with Steam but the xbox app and store still greatly affect the sim.

1 Like

If you’ve done all that, and still no luck, in these cases, most times the only cure that seems to work is a window’s reset.
If you are going to go that route, uninstall the sim, delete all the remaining folders, go to steam and uncheck the cloud save option, reset windows and reinstall the sim.

Moved to #self-service:install-performance-graphics

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.