AIG Live Traffic and Traffic Controller -- CTDs Due to Legacy File Change in SU10!

CaptDRoch…Thank you so much this works for me…Now I have AIG Traffic back with no crash…

Interesting find. It works so far.

Thank you.

Put all but the 767’s back as well and have done 3 hours without any issue. Good job!

So, as many others have stated, I’ve had relatively good success with the AIG workaround… until recently. Now I am getting a CTD at least once every other flight, using AIG Live Traffic and on VATSIM.

I am getting a pile up of all the planes in one location (on top of each other) at any return airport which is strange and never had the issue before SU10. So when I return to an airport all airplanes are piled up in exactly one location. No issues when I start at a location! Always something new!

Well I have to correct myself… excluding the B767 models only, is not the solution. At least for me.

Arrrg…next workaround please :grinning:

1 Like

This appears to be the case. After my initial return of CTDs after the workaround, I reinstalled AIG and re-performed the workaround, but this time I haven’t gone on VATSIM once nor used AI Traffic. Hence, none of the models were loaded and I haven’t experienced a CTD since. But I suspect as soon as I connect to VATSIM and one of the FAIB models is called up, I’ll get a CTD.

1 Like

Seems like todays build will include AIG fix :smiley:

1 Like

Have now tested with the latest beta patch, and all seems to be working :partying_face:


Same here. Really missed it. Though already had my first AIG TC crash at KLAX.

One step forward though.

Great news all! Can others keep testing so we can update Asobo on this?


Can someone try AIG Traffic Controller to see if it works? What about updating your AI traffic with latest/greatest using AIM?

1 Like

just about doing that right now… Same test KBOS departing 22L every single time it crashed with AIG. lets see now…

Ok, using AIG Traffic controller v0.5.1.1 with 100% traffic and AIG AI Manager v1.1.0.108 with 90 airlines and all updated (plus VerifySetup ran) on today’s v1.27.11.0 update.

KSEA for last 15 minutes looking good so far, no CTDs for me. Traffic is moving. I had previously (before today’s latest update) cleared out my _CVT and cache folders.

1 Like

can comfirm it works now… was able to depart KBOS finally off the same runway using TC

1 Like

I tried it and It seems to work as it did in SU9. That said, TC still randomly crashes. AIG has claimed for months that their app crash is caused by some SimConnect issue Asobo needs to fix. Not sure I totally buy that BUT it seems to be “working” as it was prior to SU10 BETA.

Yes, that’s my experience as well (in re: to TC crashing all the time, which thankfully no longer crashes the sim)

Glad it is not just me… AIG claims this is a problem with the sim itself but I’m not sure I understand how that could be the case. I get the sim can be quirky but you’d think TC could trap for errors or other issues caused by the FS and at the very least restart itself.

has anybody tested it with vatsim yet?

Just completed a three hour flight Las Vegas - Indianapolis on vatsim with AIG, no CTD.