Airbus 320neo V.0.5.1

Is anyone else having issues with the aircraft not following waypoints on approach? I don’t know if it’s the payware KPDX scenery, but once I reach to a certain waypoint on the STAR arrival, it seems to skip everything else and goes directly to the airport in a steep left/right bank angle and stops following the rest of the arrival waypoints. I also had this problem today at CYVR. It’s pretty embarrassing happening on Vatsim all the time, I have to request vectors and bring her in on a visual approach.


I had pretty much that exact same thing happen last night. I was able to select DIRECT to one of the STAR waypoints though and it recovered the approach OK.

1 Like

I tried doing that but it didn’t work. Especially when you’re on approach, I don’t have to be selecting DIR to every waypoint when it should capture the ILS. Happened to me 3x today.

Not for one moment suggesting you should have to. Just trying to help with a workaround that I’ve been using.


Same here, but has been occuring with both the default A320 and the Flybywire version (I am still using the v4 Stable) which maybe suggests it’s a fault with the sim. It started for me just after the last MSFS uodate.

Sorry I never meant it in a bad way and I appreciate your help. It’s just frustrating if it’s going to keep doing that

1 Like

I’m glad I’m not the only one experiencing this. Is there anyway we can let FlybyWire know about this issue?

I don’t think it’s a Flyby wire issue as i removed all my Community folder (including the the A320NX) and flew the default Asobo A320, and the same issue is still there.

May be unrelated but … the same issue flying the Caravan on AP. Suddenly banked left and started to descend and strayed way off course before I could manually bring it back. Re engaged AP and it flew as required.

Yes, it happens almost every other approach, it’s very inconvenient. It’s been reported many times but FBW can’t seem to find a solution for this one. I hope they manage to fix it the same way the Working Title team is squashing A LOT of nasty MSFS bugs in the CJ4 autopilot and FMS.

The A32NX mod is awesome but I can’t wait until we hit that point where FSLabs can join the party.


must be a bug as i have completed 5 flights since FBW 4.0 and had to vector myself in as she seems to want to redirect herself with at least one or two STAR in the mcdu…
still a great MOD through and getting better all the time…

1 Like

Might have found a solution. Earlier i made a flight plan with SimBrief, downloaded it and installed it from Load in (MSFS FLight Planner) .

Bingo, whole flight and approach were spot on, no wandering or going off on a tour of it’s own.

So maybe the issue is with the Flight Planner in MSFS, as it’s this i have been using all the time. Off to make another flight plan in Sim Brief again and will report back .

I might as well try that out. I normally get the the flight plan off simbrief but I like to input it on MCDU manually to give it a more realistic feeling, but if that fixes the issue then I’ll go with that. How did the second flight go?

While I’ve seen that what is more typical is it loses the FP and starts to circle. Am I beyond tired of this error at the end of the flight yes. Not enough focus on AP problems in Airlines and Gamin 1000/3000. Should have been fixed by now

My simbrief flights have the same issue. I notice when this happens (circling and high angle of bank) that the next waypoint shows several thousand miles away and the FP path is dashed. If I do a direct to the waypoint it fixes the distance issue and the aircraft flies fine…until it happens again. It’s almost as if the sim thinks the plane is at 0 long/0 lat until the direct to “corrects” it.

I am not a developer… but I don’t think it’s an issue with the A320 mod nor a fix with Simbrief - I think it’s an Asobo bug.

1 Like

You’re right. In my case it barely started happening. Maybe the last patch messed something up.

I had no problem flying into San Jose yesterday but it gave me issues into PDX and CYVR. It seems to go on the STAR perfectly but once I’m closer to the airport it stops following it and wants to go directly to the airport.

You are likely right, first two flights using Simbrief flight plan worked fine, third one this evening went off on its own on approach, went to manual and got the landing in…

1 Like

I can’t access the approach phase on FMC. I will usually preload flight plan thru world map. I will then load approach data when ATC informs me close to airport. On the FBW version, it will not allow me to select the approach when I click on the airport code. On the default, I can.

Anyone know what I am doing wrong or is it a bug?