Aircraft control almost impossible especially rudder and elevator axes - CRITICAL BUG

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Since World Update IV things have changed dramatically. It is now almost impossible to fly as the controls, especially rudder and elevator, are completely erratic and the aircraft is like riding a wild bucking horse - this has never occurred before.

  • During taxi the ever so slightest rudder movement sends the aircraft violently left and right.

  • During takeoff what used to be a smooth gentle rotation now has become an instant upward and then downward wild ride.

  • During cruise the slightest movement of either rudder or elevator sends the aircraft out of control.

I have tried just about every adjustment in the Sensitivity controls to no avail.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs for those who want to assist (if not entered in your profile)

Did you submit this to Zendesk? If so, what is your ticket #?
YES - Request #102102

Not experiencing any of your problems.
Have you rechecked the axis bindings and sensitivity curves?

You may want to check which flight model you’re using. If you have an aircraft designed for Modern and it somehow got switched to Legacy, or vice versa, it’ll go haywire similar to what you’re describing here.

1 Like

Is there any add-on aircraft for MSFS which uses the Legacy flight model?

Not any that I’ve seen, though I’ve only bought stuff from the Marketplace and some of them I have yet to actually fly. But there may be some freeware and non-marketplace payware that use it. My guess is that those that do (if there are any) were previously published for FSX or P3D.

A similar problem I notice on my PC. The controller axis are not wright centered. This problem on my PC+MSFS appears sometime. It was even before that update.

But I can fix it very simple: MSFS is running. The controller (Thrustmaster hotas x) is disconnected, waiting some seconds, and connected again. Then it works.

Now, when the controller setting page (in MSFS) is checked, everything is fine.

1 Like

Thanks to all that have responded.
After a huge amount of effort over the past two days I have been able to somewhat control this beast, however it is not at all as good as it was before World Update IV.

What I have ended up doing is adjusting the Sensitivity controls way down for both the Rudder and the Elevator settings, as follows:
Rudder is now at - Sensitivity -50% and Reactivity 40%
Elevator is now at - Sensitivity -50% and Reactivity 20%

But the part that annoys me is that up until the morning of the update everything was running as smooth as silk. Immediately after the update, without changing or adding anything I ended up with a wild bucking horse to control. Obviously something(s) got changed. I do hope that MSFS/ASOBO will still look into this issue.

1 Like

Same and totally agreed with you. Airliners are very difficult to turn after the update. Before is better but still not ok since the launch of the game​:thinking::flushed:

Has your joystick been calibrated in Windows? If so, try recalibrating again in Windows.

Back in January when I got the Saitek Yoke it was calibrated, but I will calibrate it again just to be sure.

With my T16000M nothing has changed. Neither aircraft behavior nor sensitivity settings etc.