Aircraft customization (tail number etc) and other things not being saved

since SU5 i have the problem that my custom settings are not being saved (callsign, tailnumber, etc). also, the “airport history” does not save any new airports since the update.

is that a problem on my side or does everyone has this problem?

on a side note: it seems i cannot use my favorite callsign/tailnumber “foxtrott uniform charlie kilo” anymore. :frowning:

1 Like

My callsign and tail numbers are OK. But, I don;t have the airport history any longer.

Same problem. It won’t save the N-number from my old 172 IRL. I have to admit, it was not as good as yours, ReimRehkitz!

Same here, callsign / tail number disappears each time I change the aircraft.

I kind of have the opposite problem… a bit difficult to explain but it’s saving custom tail numbers from one aircraft to every aircraft in a way it didn’t before and then I have a heck of a time removing it from planes that have a tail code ‘baked’ into the livery. Not quite sure what happened.

And yes the airport history isn’t working right, this was noted in another thread… seems to be using a “snapshot” from a few weeks/months ago that doesn’t update.

3 Likes

Yup. Seeing ALL of the above.

But…my history is not entirely gone. I have 3 airports listed and I think they are the very first 3 airports that I visited the day I installed in December 2020!

Yeah that’s what I mean about it looking like it’s falling back to an old snapshot instead of updating the history… It’s stuck on airfields I was using a lot a couple months ago but the ones I’ve actually used most recently never get cycled in.

1 Like

I guess we all need to open tickets for this.

I probably will for the airport history. For the tail number I need to do a bit more testing to try to figure out what’s actually happening so I can give steps to reproduce the issue.

It’s really badly broken it seems lol … sometimes it wipes the tailnumber as soon as I type it in, somteims I get as far as the flight number, but it just wipes them.
Last night it gave me a callsign as the airport I left from and the flight number I put in, but that had been blanked. Weird.

It might be the mouse overlay.
If I move my mouse, it clears them.
If I click the mouse, it clears them
If I stay hands off and leave the mouse alone, it stayed for 20 seconds once, and around 30 the second time.

But if I turn off my mouse, it stays in there … but the sim/game is unresponsive as there is nothing you can press to leave the screen lmao … switch mouse back on, it carries on and wipes them again …

Last attempt was type them in, press ENTER for all three, then quickly press ESC. When I went back in, the values were there !!! But they wiped after 4 seconds lol :¬(

I guess if I do the typing and ENTER for all three, then hit ESC quickly and then go fly, they should work. I’ll try it and update in a few …


UPDATE — It worked !!

Tail number was correct at the gate, and once I put the flightplan in, ATC used the correct callsign and flight number … Yaay !!!

Oddly enough I saw the opposite problem to the OP. Loaded up my first SU5 flight, entered my tail number, left flight number and call sign blank (and they really were blank!) to make sure the sim would use my tail number rather than a call sign. Still got addressed by ATC as “PANAM 060”, which is a bit ambitious for my little C172… But it was the call sign that I used in my previous DC-6 flight, somehow the sim remembered it although the fields were blank.

2 Likes

LOL — was it also set to “heavy” lmao :¬)

after trying to get it to work, i ran into the same problem/glitch, where all of the textboxes would be empty, but all planes had the customization from my tests before.

thanks for your replies everyone, at least i know it’s not a problem on my side. :slight_smile:

Did anybody work out a fix for this? I’m still experiencing it :frowning:

Tail and flightnumber disappearing in the box. But when i start a new flight, the flightnumber is saved. Its the same as the last flight, but the box in the option is empty

just the workaround I was using, type in details, quickly press enter - repeat for all, then as soon as pressed enter on last one, hit ESC - for me that ensures they are in there when I go fly, and are in there for any aircraft changes until I retype them again.

Same problem here. NONE of my setting are being saved. It takes me 20 minutes to reconfigure everything (graphics, controls, stopping that annoying music that is playing in the background, etc.) each time I start the program. VERY annoying!! Googled it and still can’t find a working solution. Once it’s running, everything works great, but I don’t have time to change the settings each and every time I want to fly it. VERY close to getting a refund!

It is most likely related to where the settings are stored, as permissons might not be set up to allow it to save them. Do you know the install path?

And is it Steam or Microsoft store?

Take a look at this pic. It shows that although the file says it is on my C drive, it is not.
One issue with the saves is they are encrypted, and this might be causing an issue.
In my case, the program is installed on the D drive, but the program files directory stores the encrypted files. These then have to be within a system dir, and so it created a dir on my D drive and logically connected it to the C drive. THe dir on the C drive is the one in the pic, but that just redirects any queries into the “D:\WPSystem” dir, where the encrypted files are ACTUALLY stored. If anything was to change, for example if I moved the flight sim app, or changed a logical connecton, then it could cause the app to not be able to record settings changes. Similarly, if any permissons were changed, it could also interfere with saves into that system folder.
There are only two dirs within the D:\WPSystem dir, both of which are for the flight sim.

It might be that the system has changed, or a different login was used to install it etc.
Have you changed anything major such as a drive or major hardware since it was installed?

I have given up on the boxes redarding ATC.
My solution is pretty simple. I have cleared the text boxes (F4 I guess) and put the Callsign direct in the Aircraft.cfg. Works for me regarding atc. Also when I put the Callsign this way it is spelled right (icao alphabet) instead of being only read.

1 Like

Good info, thanks. I didn’t know there were encrypted files. It’s the MS Store version. The problem started right after I did the normal (default) installation. Haven’t changed paths or anything.

The other day I did a complete uninstall, then reinstalled it, including the Xbox app. Now everything seems to be working as advertised. All my settings are being saved as they are supposed to me. Must have been something that got corrupted during the initial install. Hopefully it stays this way!

1 Like