Aircraft stuck on the ground after breaking and when starting from a runway

After installing Version 17.3.0, the aircraft will move only when I leave from a gate. If I start from a runway, or if I break at any time once on the ground, the aircraft gets stuck and won’t move but a couple of inches, as if something is holding the aircraft in place, glued to the ground. I don’t have push-back engaged and the parking break is released. I re-calibrated my hardware but the issue persists with all aircraft.

Is there a solution? What is causing this issue? I already uninstalled and re-installed the sim 3 times after reinstalling Windows 10.

Thank you.

No, the parking break is not on… I wish it were that simple

what about your normal brake? Sometimes they’re engaged by default so you have to press whatever button you have your brake bound to “refresh” the brakes.

Same thing with parking brakes, you might need to engage then disengage just to properly release them.

Also which aircraft?

I deleted and remapped the rudder axis and breaks’ axes in the Controls field. When I break and release, I can hear the breaks engaging and disengaging and the aircraft responds accordingly, even though the forward movement is minimal. So, the breaks are definitely not stuck. This happens with every aircraft. I contacted the pedals’ manufacturer to see if they have any suggestion w/regard to the firmware that runs their hardware but doubt that is the issue. . . All my hardware has been fully operational for almost a year, until Microsoft came out with yet another crazy update on top of the many others that cause too many issues.

Best way to confirm this is to look at the in-sim pedals.

Sometimes it’s locked even when it looks like it’s not.

Did you try this:

  • Engage the parking brake
  • Release the parking brake

Yes, I tried that also. I have tried everything and now I will try to bind those inputs again and see if it unlocks some functionality that is recognizing the breaks as applied full on when they are not. The hardware I use must not be fully configured within the Microsoft software that runs the sim and this must be causing the issues I am having.

Yes, sounds like it.

I must also say, that parking-brake-bug seems to have been fixed. I had the issue quite a bit in the beginning of the sim. Brake during taxi and then the plane wouldn’t move anymore. Could only unlock it with that parking-brake trick. But lately not anymore (although I also avoid the Asobo airplanes… might play into it).

@ememPilot and @Neo4316 -

Through some miracle, I was able to get the ugly ‘glued-to-the-ground’ effect to disappear from standing starts (i.e., from a runway), although - once I am moving - once I break I need to quickly ‘tap’ the button assigned to the parking break twice to get the aircraft to move again (odd…). Is this something that you also are experiencing, or is it something that you experienced but resolved eventually? I can live with this work-around for now (better than being stuck on the asphalt) but was wondering if you had any input on how you cleared that. I use only Verpil hardware, which works well both in DCS and XPlane, so I know my hardware is not the issue. I also know that Microsoft has not even spent a fraction of a second to modify their almost 1 year-old software to acknowledge peripherals (natively) besides the most common hardware…and this could be an issue. But if you have any feedback on how you were able to resolve this last wrinkle let me know. Thanks.

I dunno… I never start from the runway, I always start on the gate because I need to do all the preflight checklist to make sure my flight is without issues.

From what I’m seeing, you might have a double binding somewhere with your brake. like something to do with your normal brake to also engage your parking brake. Which explains why you need to reengage and disengage the parking brake to disengage it.

Another thing to check is your Assists settings. I wonder if your assist setting is engaging the brake for you. Just to be safe, turn off all assists, or set them to Hard/True to Life.

I have never changed anything in my controls or bindings. But I stopped using the Asobo airplanes. I really thought this bug was fixed, but maybe not in the MS planes.

If it is a binding issue, I have no idea, cause in the FBW Airbus and the DC-6 this never happens.

However, I do seem to recall that at some point I thought it also might have something to do with the auto-brake system? If that button is switched on… like the auto-brake would start already when going really slow… but I don’t think you specified which aircraft this is happening in. Else have a look at those buttons (in the airplane).

1 Like

Ok, I will check as suggested. Thanks much!

Had similar issues a while back. First, realize that NumLock must be OFF for the parking brake control to operate.

Then try a different combination of brake config settings that are describe here.


I had this same issue last week and was able to resolve it (somehow) after re-calibrating the rudder pedals in the VPC Verpil software application. This is not happening in “X plane 11” by the way, but only in MSFS 2020, which makes me believe that this is purely a Microsoft issue. I don’t know if this current version of the software causes this problem, or what. It happens on a sudden. If I start from a gate and do not break, no problem, but if I start a flight from the runway or break at any time during taxing, the aircraft remains “glued” to the ground as if something is holding it in place even with throttle at full power. I don’t have an double-bindings causing this issue and no, I do not have the parking breaks engaged. Every plane in MSFS has this same problem, this is not limited to a specific aircraft model. I simply restarted a flight yesterday, made no changes to the controls’ configurations and here I am again.

Does anyone have the same issue? I have re-calibrated those rudder pedals a few times already, and everything looks ok. “X Plane 11” runs very smooth (it always does), does not throw these curveballs (ever !) and is much more stable. Why is this happening? Do I need to reinstall MSFS 2020 (this would be my 6th time in two weeks), hoping this goes away? I have run out of options. Any help is appreciated, thank you.

Hello @InFlight2020 .

I saw reports that others also had some issues using Virpil products.
In the following topic a user managed to resolve his issues by completely deleting the default binding profile and reassigned everything manually: Configuration Nightmare of my Own Purchasing!
Maybe this could also help in your case?
Otherwise, screenshots or (even better) a video may help us to troubleshoot.


I already did all of the steps below, multiple times. As I said in my original question, which was deleted, the planes do look like are tied to my pedals correctly, but for some reason they remain glued to the ground. I can see the yoke turning and I can see and can hear the breaks engaging. This is not a Verpil issue. I happened a week ago, went away and then came back. No Verpil configuration was changed. This is a Microsoft issue and we need someone from the community to see the issue and maybe provide advise on what worked for them. I can guarantee you that my pedals are configured well in the Verpil software and use the latest firmware from Virpil.

I have a similar issue that happens randomly but I have also seen a bit of unusual behaviour!.

Tonight I set up a flight at a gate. Requested and successfully pushed back. Set the parking brake then released it and on moving the throttle I did not move. However, in frustration at wasting all that time programming FMCs etc, I applied full power. Although I didn’t move, the ASI did (!) as if I was accelerating! Makes you wonder where the sim is taking it’s airspeed readings from, it certainly doesn’t require any forward movement!

Back to my point though, what is causing this stuck to the ground situation? It has been happening for months, randomly!

1 Like

Hi All,
Has anyone ever find a resolution to the sticking brakes problem? Reading through the comments I can confirm that it is not specific to virpil equipment. I have Mad catz ProFlight combat rudder pedals and have the same sticking brake issue… and the brake axis’s work fine in xplane and DCS.
They are unable to be calibrated in windows.
I realise its a year since the last post but even after the last update (40th Anniversary update) the issue is still as bad as ever.
I have tried removing all brake assignments from keyboard, mouse but the issue still exists. …and yes have removed and reinstalled all drivers etc.
I fly in VR and even with no brake assignments at all, the plane is stuck to the spot…madly tapping the parkbrake on and off with the vr controller and the plane inches forwards and stops (even at full power).
Very frustrating!!
I hope someone has had more luck than me!
Would love to hear its been solved!!


Yep me too, I have saitek rubber pedels and it happens randomly to me. I did see it first at Heathrow after installing iniScenes version but found a post which mentioned removing the Asobo version in content manager (as they can clash with each other) and I haven’t seen it happen since. Am using digtal designs salzburg and its happened twice with that addon airport but there is no version of that airport to uninstall from the sim!

Maybe the sim thinks the aircraft is airbourne when its still on the ground???

1 Like

Are you using VR by chance? I only fly with virtual reality and have noticed that when I am taxiing in VR with a VR controller in my hand the plane will stop as if the brake is on. If I put down the controller the plane will start rolling. Will have to work out how to assign controls away from VR controller.