Airports, Traffic, FPS Disappear - Simconnect Object Limit?

I had a feeling it wasn’t addressed yet; I suppose we need more votes.

I actually had this happen only using AIG and not GSX. I was trying to fly out of the freeware EGKK by mkvy in the Fenix A320, and the AI traffic injected for a moment, then disappeared. Instead of wasting my time, I exited the flight. There are so many objects at the airport, it must have reached the limit with only the traffic added. I didn’t run developer mode to check, but I recognized the problem starting.

Have now had 5 flights in a row where arrival airport does not load in. Have tried tweaking a bunch of settings with no luck. Anyone else?

Which airports were you departing from, and how dense were your GSX/AI Traffic settings?

I was able to complete a YVR-YEG flight with GSX and AIGTC setting greatly reduced, but they’re smaller airports. I’d really like to use these products to the best of their abilities.

Does anyone know how get this bug logged with the “bug logged” tag? Maybe I have missed a step along the way.

KSRQ by VerticalSim
KLAX by IniBuilds
KPNS by DominicDesign
KBWI by LatinVFR

My FSLTL settings are pretty much in the middle, not too high, not too low and I’ve disabled VFR aircraft as well.The temporarily workaround in the past was to completely quit the GSX app while in flight, then re-launch it once at my destination. That has seemed to stop working.

After stopping use of FSTL and using vatsim, the problem has seemed to have disappeared – which is a bummer because I really love that live traffic.

Just landed at Heathrow from Frankfurt. not the welcome party I expected.

Just experienced this last night on arrival into Justsim LTAI in the Fenix. It’s definitely weird since the default airport is completely suppressed indicating the addon is indeed active, but there’s just bare satellite imagery and PAPIs. ILS was also functional and fine.

Had AIG and GSX active. I hadn’t experienced this with bigger airports until now, but this was my first flight to a big airport in months that was over two hours. I wonder if the length of the flight factors in.

I actually had no fps loss or anything though. Very good and smooth all through approach and landing.

the combination of both can trigger some kind of “object limit” within the Sim. There are some options you have:

  1. Disable ground clutter in the GSX settings
  2. Reduce Density of AIGTC injected traffic
  3. Disable Services in the OCI settings of AIM, run a verify setup and enable Airport Services in the TC Airport Manager Settings.

Just landed at EGSS after flight from Copenhagen. Same welcome party at Stansted.

Same issue today at KPIT, using Fenix A320, GSX Pro, and FSLTL–no terminal building on arrival. I don’t ever recall this happening prior to SU 10, and it seems to have worsened after SU 11. As everyone else here has pointed out, likely due to the Sim object limit. Why would this be implemented now? What is the benefit besides causing issues like this? And importantly, why does this only seem to affect some users and not all?

My guess is those who fly online don’t have the vast amount of traffic objects loaded at any point in time as those who fly offline. Similarly, those who fly out of small airports don’t have this issue compared to those who fly out of large hubs. Unfortunately, the workaround right now is to either reduce settings, or fly with one program or the other. Meanwhile, please vote at the top of this bug report if you haven’t already and send anyone you know over here to vote as well. This needs to get logged.


had the same issue have we got fix or a walk round yet

even tried to load up first at my destnation but still have same issue

this should not be happing

Same issue here, FSimStudios CYVR and Verticalsim KBOI. Both flights included a departure from Inibuilds KLAX.

@karlmemphis87 No fix/workaround that I know of, aside from reducing settings or not using one or more of the addons.

@Regis902 Brave for starting both flights at KLAX. Did you notice that AI traffic wasn’t being injected while you were at LAX?

I had AI traffic @ LAX but my GSX ground vehicles were not visible which in retrospect makes sense now.

In my case i don’t use addons/mods and the ai aircraft disappear (buildings ok). I found that if i close the internet navigator (Mozilla Firefox) running in the background, the problem solves. Seems is related to a memory usage issue.

This happened again to me during last nights flight from KORD-KMIA. Left an add on airport used FSLT to one at another add on airport. No issues until final approach airport not loading and severe drop in FPS. This has happened 4-5 times now over the past month. While it never happened before. I will go in a vote for the Asobo bug request!

I7-1100/3060Ti/1T SSD / 32G RAM

Meanwhile, is the only solution not to use FSTL then due to object limitations? I have my FSTL settings on pretty low

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue: having the same exact issue fly from large addon airport and land at a large addon airport. I use GSX and FSTL

If relevant, provide additional screenshots/video:

I’m on my cell phone now but, my pictures look exactly like the one above.

Mine has def read “limit by main thread”.

Same. Except ini KLAX to Fly Tampa KLAS. Entire city is gone, Airport gone, and frames drop to 8 fps.

Folks - this feedback is logged, meaning the Dev Team needs a probable, repeatable, consistent scenario to show a potential SimConnect defect. In other words, reproducible scenario.

That’s a challenge, looking at this thread. There is a variety of software and setup/usage scenarios.

My recommendation is make a scenario that you can consistently have this disappearance occur, lock it down and have anyone try it. If you get a high percentage of independently verified validation using the exact same software, same settings, etc., please post it here.

Without it, repro, which is the key to turning this feedback into a validated bug, won’t likely happen.