Anyone find the fix to the rudder on ground issue?

Hello. Has anyone found the fix for why the rudder is having these erratic moves when on hitting the ground on landing? It’s clearly a bug in the game and I hope it gets enough attention for it to get fixed because of right now I have stopped playing. I am on Xbox series s by the way. Thanks.

Have you checked your assistance settings?

It is impossible to know what you’re talking about. But I’ve seen many complain about realistic handling in crosswinds.
Do you use your rudder correctly in crosswind landings?

1 Like

Something that really helped me out was to lower sensitivities on not only the rudder but also the ailerons, and elevator. People often compare ground handling to like being on ice, definitely feels a bit excessive with the low grip levels. There’s no real fix but things you can try to make it a little better.

@lolapaloka
It has been written multiple times, the rudder can’t move on its own.
Crosswind can’t move the rudder either.
It must be either your hardware or any assistance/AI setting which is responsible for this problem.

@RandyFlagg9653 lowering the sensitivity will not remove this problem, increasing the deadzone would help…if it’s a hardware problem.

for the last week i never started the sim in live weather, then you can change, or delete, the ground wind. For me that changed everything with takeoff and landing movement. Especially with small airplanes. With the jets, i didnt have the movement issue.

I only as TS have that problem on the runway. Loose from the ground and the wind problem was over most of the time

Check to see if you have psuedo keybinds applied. I have seen before where left or right brake have key binds set without actually showing them. The fix is to set them to different unused keys then clear them afterwards. You have to do this on each device used.

I’ve done this. Didn’t do anything.

All my AI assistants are off. Can you send me a screenshot of you’re settings for me.

Turn on rudder assistance, it make it less realistic, but more fun to fly until Asobo fix this issue.

A screenshot of which settings?

@Ixoye56 It’s not a sim issue.