Appear BSOD

I play MSFS of steam edition. Confirmed my PC spec meets the recommended spec,
but when playing MSFS, appears BSOD many times.
I tried to fix this situation, like re-install of all drivers, software,Microsoft visual c++ and of course Windows. but the situation has not been changed yet.
Kindly share the idea or tell me the way to settle this situation.

Looking forward to hearing from the comrades!

Do you happen to have any overclock, like dram/cpu or any

Looks to me (also due your info) as some HW problem, with drivers problem.

Never tried overclock.
Thank you for your comment.

Guess what you said is one of the causes.
If that’s the case, do you have any idea to settle this case?

Thank you for your comment!

Generally,

BIOS options (be careful if not experienced) can be good start but in case of BSOD that screen can also show some infos, some files are saved also due crash so check of Event viewer (globally for sure) is preffered, you can do now that steps. Hope you’ll find your problem.

On other side we don’t see your HW deep spec so if you want share that infos also… Simply I see due your info somehow your HW at range close to not meet :wink:

Alright.
Welcome to the forum Keiworld5545!

Is your pc home build or ready from the shop ?

Can you play other games without bsod

Hey, a BSOD shows always important information like Error Codes etc… It would begreat to provide this information, best is a Photo of the BSOD. Overall, I think your BSOD will be RAM or Kernel related. What RAM are you using and which speed it’s supposed to run at? What CPU are you using?

Thank you for your prompt reply.
My HW spec is as follows.

  • i5 9400F
    -Asrock z390 phantom gaming 9
  • MSI RX vega56 air boost 8GB OC edition
  • DDR4 3200 16GB
  • SSD 256GB PCIE
  • Win 10 Home
    Kindly confirm my PC Spec.

Thank you !

My PC is home build.
I can play any other games…

I suggest to check some BIOS settings. First make sure your Memory Speed is set to 3200MHz. You will find this setting at your RAM specifications settings.

Next make sure, that your CPU isn’t using any Auto Overclock (named: OC Tuner, Auto Boost f.e).

Also check your Virtual RAM usage. Just go to the settings following this Link and provide a screenshot for further troubleshooting.

Greetings

Thank you for your comment.
In my case, appear BSOD only a fraction of a second, then the screen black out
It’s difficult to take a shot of BSOD. I do not get a stop code…
My RAM is DDR4 3200 16GB average speed is 2133.
CPU is i5 9400F.

Try to set the speed im your BIOS settings to 3200 MHz. Possibly your RAM isn’t fast enough. Which games are you playing without any problems?

I can play the following games without problems.
The crew
The crew2
Forza Horizon 4
Cities skylines
Mine craft

Try to check my virtual RAM which you commented.
Keep in touch!

I dont believe low ram speed would cause bsod at least from my experience :grimacing:
But increasing over “auto” value will so idk if its good thing to mess with bios atm

Any more info on the B/S message? It usually hints into the right direction.

Once changed Virtual RAM from auto to 16,000 MB but situation has not been changed…

Virtual RAM is not a good idea for several reasons.

@PauL1eeeeeeeeee that’s true. But I would still give it a try.

@Keiworld5545 ok, then set the RAM pagefile back to auto management please.

Can you please check your Eventviewer? Do you know, how to use it?

1 Like

It can be really helpful for Troubleshooting. But it shouldn’t be a solution over a long time.