Approach flyback bug - Not fixed as stated in SU5

Keep voting folks, latest update didn’t seem to fix it.

1 Like

What I usually do is if I see there isn’t a waypoint assigned near enough to the airport, I go to filters and turn on waypoints and add a closer way point or add a small airport as a waypoint and once I get to the last waypoint I set, then it gives me approach transition without having to back track to a previous waypoint. That’s my temporary fix.

1 Like

Thanks for the your patch Jay, I brought this up for the MSFS team because they keep asking and are looking for bugs in MSFS. Their is a glitch in the programing of the MCDU and with ATC in that your arrival should be given to you much earlier than it is given, The in-flight planning phase of an
instrument approach can begin as far as 100 - 200 NM from the destination. - Especially in a A320… In MSFS I’m lucky to get my approach vectors within 20 - 13 NM which is way to late. Additionally, real-world I would have been on com with approach as soon as possible if I had not gotten the go ahead. BTW approach is typically foretold when you get your plan from operations and Approach has the prerogative to change the approach if they so choose to because of weather or traffic. THere have been many times when turned over to Approach when I am not even told what to expect.

3 Likes

Terrible bug, makes aircraft became crazy.

entering or changing flightplan causes major mayhem in route.
This is also the case when reloading / resuming a running flightplan. ATC gets thrown back in time and loses aircraftposition also. Lots of work to be done there!! Very very dissapointing and loss of pleasure

Made the feedback snapshot but in the backlog… well keep voting anyway. We’ll eventually get it fixed.

1 Like

As of today this is still happening.

Edit: it also happens in the 747.

Same Issue here, with all planes with Garmin.

Very often the ILS frequencies are not correct either. A real disaster … and a NOGO in an alleged “flight simulator”. Unless the goal from the beginning was to be a sports aircraft simulator, with a focus on visual flight, at least MSFS2020 currently makes the appearance for me.

I have been having issues with RNAV approaches using A320 FBW where APP NAV and FINAL stay blue ( not captured ) and hence does not go to FINAL APP. But the aircraft does follow slope and track to runway. Also do not get the runway data displayed. Some airports not capturing slope but track is always ok, but cannot trigger FINAL APP.

Tried to replicate with C208 ( as I have triggered FINAL APP in December ) and manually input the flight plan in the G1000 then departure, then approach, then arrival. Then when I loaded the flight plan the map disappeared and all the displays froze.

This reminded me of another RNAV approach in the A320 FBW where the FMC screens froze on approach when I used the CONSTR button, then unfroze when I turned CONSTR off ( a few weeks back )

I have latest AIRAC cycles, Navigrapgh BETA, WT G1000 MOD, FBW mod stable version.

Can all the mods be a problem or will I still have these issues if I clear them all out? I am reluctant to go back to vanilla as these are great mods especially if it’s MSFS causing the problems.

I love MSFS but flight planning is such an important element of my enjoyment and any kind of instrument approach seems problematic.

I have poured over the forums in Navigraph, FBW, my own VA and here but just feel like I am going round in circles not knowing where to start.

I am still wondering about one thing:
The problem (at least as I experience it) seems to be caused the moment ATC gives you an approach clearance. But why are ATC and the aircraft’s navigation system connected in the first place? Why does the autopilot/NAV guidance system react to an ATC message? I mean, that is what the pilot is there for, isn’t it?

ATC and the NAV system are not connected, but the pilot needs a clearance to execute the approach in a real world situation. The beginning step in any approach is for the pilot to go in the FMC and enter approach, via entry, and execute. This really is something that you would be expecting from a sophisticated FltSim. Especially if you are try to compare yourself to XPlane for example.

But that is exactly the point: in MSFS the ATC and NAV systems ARE somehow connected. How else can you explain that the second an approach clearance message comes in, the fms automatically reacts by changing the active waypoint, sending the autopilot into a bank somewhere off-course?
Here is what I would expect to happen: Of course you need a clearance to enter an approach via a defined waypoint, but it is the pilot’s responsibility to make sure that the route programmed into the FMS corresponds to what he is cleared for. The autopilot in turn only follows the FMS, and the FMS adheres to the route that has been programmed. If the expected approach has already been pre-programmed, then the FMS should just continue flying along its path regardless of when any ATC messages come in.
Or am I wrong?

1 Like

Hi Werner,
I afraid that I am not seeing that happen. But then again I am running the MSFS A320neo Improvement Mod available at: https://github.com/wpine215/msfs-a320neov. It is a vast improvement on MSFS team’s base 320N that comes with the package. Check it out, maybe that will help you with what you’re looking for.

Thanks for the suggestion. I am actually using the FlyByWire mod – as it seems after some further reading, the A320NX has its very special enhanced version of this bug, which has in fact become more prominent as of late. I still find it funny that it appears only when you’re flying with ATC (otherwise, the plane just navigates smoothly as it should). Anyway, I suppose it will be solved once and for all once they release their newly built FMS/AutoPilot.

Well let’s hope so…
All the best to you and happy flying…

This fix is very much needed :slight_smile:

Has anyone tested this in Sim Update 3?

Yesterday I was flying an arrival and an ILS approach into DFW. Shortly after starting the approach, the AP turned the aircraft 180° and started flying to,the IAF that the aircraft passed several minutes earlier. WTF? Is this the approach fly-back bug?

When the aircraft reached the IAF, the AP turned the aircraft 180° and started flying the approach (again).

After landing at DFW, I started examining the route flown by the AP. I admit that I don’t carefulled check the arrival and approach plates when I create an IFR flight plan. After all, shouldn’t the FMS take care of any flight plan issues?

I loaded the flight plan into an external flight plan creation app. The details in the flight plan showed two waypoints, the IAF and the one after it, listed twice. The notes for the first pair said these are arrival waypoints and the notes for the second pair said they were approach waypoints.

I looked at the arrival plate and the approach plate. Both waypoints were on both plates. I then deleted the first pair and the software removed the entire arrival. I restored the waypoints and deleted the second pair. The software removed the entire approach.

Apparently the AP flew the entire arrival past the IAF, then turned around and went back to the IAF to fly the approach. The AP flew exactly according to the flight plan.

I’m trying to figure out where the bug is. Is there a problem with the Garmin allowing supplication sets of waypoints? Is there a problem with the flight plan creation software having a flight plan with duplicate waypoints? Is there a problem with the FAA plates allowing overlapping waypoint for STARS and approaches?

It is stupid to have any aircraft fly back up an approach to the IAF. But what should be fixed? It seems like everything is working as designed but the design is awful.

Yes this is the bug. Extremely frustrating. Basically what happens is when you enter approach mode either manually or via auto systems, the sim inserts a “user” waypoint and then calculates what waypoint it should then sequence to rather than just moving to the next planned waypoint. In addition as you may have noticed they sim likes everything rounded evidently so it will create a big looping path to the waypoint sometimes.
I am not sure where exactly the bug is, it may be a combination of things but I think it is a simple matter of trying to be too “fancy” or “elegant” with it. Instead of simply calculating ok we are between waypoint A and B and approach mode is turned on fly to B then continue as normal. The sim does ok we are between A and B but approach starts at A so we need to create X and go there first so we can then fly to A.
It is just all around wonky, for lack of a better word.

I am in agreement with the two of you that this is extremely frustrating… Especially when you get no time to fix the issue when MSFS ATC Approach provides the approach when you are only 50 miles or less from the airport…

So there are two issues with this. 1)Short notice on approach and the second being what you’ve mentioned above.