Are others also still having issues with Saitek Multi Panel not working properly when starting cold & dark?

Hello there,

I’m running the latest update of MSFS 2020 Premium Deluxe from DVD (as of today, April 29th, 2021) plus Version 8.0.313.0 of the MSFS Plugin from Logitech and when I start on the Cessna Longitude from cold & dark, i.e., at any gate, my Saitek Flight Multi Panel display lits up and displays the text (for instance, “ALT” & “VS”) but the digits won’t show. Also, none of the Autopilot related buttons work nor light up.

However, if I start a flight either from the runway or in the air, the panel works fine.

I’ve seen an old topic from Sept. 2020 about this issue but there was no real solution for this problem there. There’s a mention to the USB enhanced power management issue, which I already applied some time ago. Nevertheless, as the panel actually lits up and works under the circumstances mentioned above, I’m pretty sure the power management issue is not the cause.

So, is there someone who still has the same issue as myself? Or, if there’s a new fix for it, can someone point me to it?


Do you have the plugin for MSFS installed?
If not, get it here:

However, sometimes MSFS gets confused after restarting the game and the plugin won’t work. Then simply open the task manager, stop the plugin and restart it.

Has been working fine for me.

One thing about the usb power saving fix, if you ever moved the panel to another USB port you have to run the fix again.

1 Like


thanks, but, as mentioned, I already have the plugin installed and working. Also, the panel works, mostly. The only thing is that the auto pilot controls, i.e., the dial and buttons do not affect the sim. Autothrottle, flaps and trim are fine. And, when I use the switch to the left, it also changes the display between “ALT/VS”, “IAS”, “HDG” or “CRS” accordingly. The only thing is, that it doesn’t show the numbers, neither 00000 nor the actual value in the sim.

And then, if instead of going from cold & dark I simply start from the runway or the air, where everything is already on, then the autopilot elements are all there and working.

I suppose it might have something to do with the initialisation of the peripherals.

1 Like

Do you also start your aircraft from “cold & dark”? I.e., have you also started your flight from a ramp/gate, instead of from the runway, or mid-air?

Yes, I noticed this as well. I then reapplied the fix, which works fine for maintaining the display active, but apparently has nothing to do with the non-working auto pilot controls.

To be sure are you going through the startup checklist when starting cold and dark at the ramp to ensure you have all avionics set right? Early on when I was being stupid I once couldn’t figure out why the TBM auto pilot would not turn on with my Saitek Multi panel even though I kept on pressing the button on the Garmin.

Figured out because the AP witch up top on the ceiling panels wasn’t on so the aircraft true world settings do affect the panels accordingly.

Yeah all ways of starting. I just done it now to make sure but as I think has already been said, you have to turn the avionics switches on for it to change from just ALT and VS being displayed. If I switch the avionics back off it goes back to displaying the ALT and VS on the screen.

1 Like

Interesting, I found out today that, if you start the engines via the Ctrl+Shift+E then the auto pilot works fine. Following the checklist procedures doesn’t. I assume that the automatic start includes something that activates the panel, while the procedure doesn’t.

Is there a key binding for turning just the avionics on?


Yeah i would have thought so i use the avionics switches on the Honeycomb yoke just search avionics in the control key bindings on the sim and should show you.
When cold and dark are you making sure to also switch the battery and alternator on?

1 Like

As a thought, perhaps check out this early vid of a Longtitude startup from cold and dark to see if you missed a step.

1 Like

On the Cessna Longitude there’s no avionics switch per se, only the Left and Righ battery switches, which, once turned on, activate the avionics of the plane, but unfortunately, not the Multi Panel AP switches…

That’s why my suspicion on the avionics switch.

By the way, the “official” starup procedure via Checklist from MSFS2020 also doesn’t work.

I also tried this startup procedure, same result.

However, I also tried a different thing: I bound the “Set Avionics Master” control to a key and while starting up, after the generators are on, I applied the Avionics key and then the Multi Panel AP controls activated.

So, for me it’s clear that somewhere Asobo bound the activation of the Autopilot controls to the avionics, at least for the Cessna Longitude (didn’t test other planes on this yet). As there’s no avionics switch per se for the Longi, this never gets activated.

I will try to open a bug report, but as apparently I’m the only one who seems to have the issue, I see barely a chance that it will be fixed in the near future (other issues which are much more common didn’t get fixed yet, either).

Thanks for the infos and have safe flights

Here you go you need to bind some controls to the ones shown in my screenshot.
Just tried it out for you i couldn’t find a switch in plane to turn the avionics on either.
Also using set avionics master doesn’t work as using a button press acts like a toggle it switches off straight away, so needs the on and off buttons binded.
I use the honeycomb which has avionics switches so no need to use the keyboard so ignore my keybinds I just done it quick.

1 Like

My multi panels completely dont show up in msfs control UI. i have them connected ive tested them, but they arent there as a preset. Anyone have the same problem?

its not needed as all the switches do there correct functions by defualt. I believe there is another app that allows customisation for use with the logitech panels can’t think of the name of it right now.


welcome to the Forum!

As mentioned by DORRAGER, the buttons and switches of the Logitech Panels are automatically preset to their normal functions. They also don’t show as periferals in the Controls section of MSFS 2020. For them to work properly though, you need the MSFS Plugin, which you can download from the Logitech Support site. Be careful to look for the right plugin, as there’s a different one for each simulator (FSX/P3D, MSFS2020, X-Plane, etc.).

The other app DORRAGER mentions is probably However, I don’t know how well it works, although it’s quite praised by some users. If I understood it correctly, it has some sort of trial period and then you have to pay for it.

Best luck

Interesting, I actually noticed this behaviour. So I really have to map the Set Avionics On control…

Did you notice if both avionics must be set on for the AP controls to work or does it suffice to activate one of them?

Yes if you don’t have Hardware with actual switches. The switches send a costant signal but if you use a keyboard key then it just toggles on and off.
You need to bind a keys to avionics on and off.
I think you need both as I think one powers up the seconds screen in the cockpit.