Arrival Airports, Traffic, and FPS Have Disappeared

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Issue caused by addons.

Brief description of the issue:

Recently, I have experienced disappearing arrival airports on three different flights of three different lengths, in three different parts of the world, with two different aircraft. On final approach, the FPS dropped very low, and the airport failed to load and left me with the base aerial imagery only. When the sim is restarted, the scenery loads in fine. I was using AIGTC with GSX at the time.

Provide Screenshot(s)/video(s) of the issue encountered:


This image was provided by @MDFlier in the Avsim forums, reposted by @F737NG.

ICAO or coordinates (DevMode > Options > Display position)

LPPD, OOMS, KOMA

Detailed steps to reproduce the issue encountered:

  1. Start Flight at large airport; 2. Run GSX; 3. Run AIGTC or FSLTL; 4. Fly to any airport.

PC specs and/or peripheral set up if relevant:

i7-12700k, 8GB 2070S, 32GB DDR5, nothing overclocked.

Build Version # when you first started experiencing this issue:

SU10


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hi Fellow Simmers,

I’m hoping you all can help.

Yesterday, I experienced disappearing airports on two different flights of two different lengths, in two different parts of the world, with two different aircraft. On final approach, the FPS tanked, and the airport failed to load. When the sim is restarted, the scenery loads in fine. I was using AIGTC with GSX at the time.

I have also posted this issue in the “Warning: Your graphics device has encountered a problem” thread as the second flight resulted in this CTD, but perhaps it should have its own thread. Having researched a bit, there seems to be an issue with multiple SimConnect programs and a maximum object limit possibility in the sim, but I’m curious who else has experience this, and if there are some workarounds beyond reducing the settings.

Thanks in advance!

Specs: i7-12700k, 8GB 2070S, 32GB DDR5, nothing overclocked.

2 Likes

This seems to be caused by a maximum object limit in SimConnect post-SU10.

@MSFSCommunityTeam , it would be good if this could be investigated and for this thread have votes enabled, please.

We should make this eligible for votes.

This needs to be a bug and we need the ability to vote.

I tried to collect several threads which are all about the same issue in my opinion.

Would be nice to have one major topic with a title covering all which could be find better. Currently we have a big clutter or, like on AVSIM, it is burried in 50+ pages monster threads.

“Vanishing/disappearing/invisible (AI) planes, airports, vehicles: FSLTL, GSX?”
something like that.

https://forums.flightsimulator.com/t/invisible-planes/546785

https://forums.flightsimulator.com/t/gsx-pro-and-aig/545885

https://forums.flightsimulator.com/t/scenery-not-loading/545646

https://forums.flightsimulator.com/t/scenery-and-airport-not-loading-at-arrival/540758

https://forums.flightsimulator.com/t/major-issues-confusing-things-happening/551519

https://forums.flightsimulator.com/t/fsdreamteam-gsx-for-msfs/287195/803?u=guenseli

https://forums.flightsimulator.com/t/airports-sometimes-doesnt-load-with-gsx-pro/546234

https://forums.flightsimulator.com/t/terminal-buildings-dissapearing-when-landing/519327

4 Likes

i can confirm it seems to be an object limit and ai planes seems to be the catalyst at least in my case… lowering ai seemed to cure the issue but its worth noting that each ai plane at a gate will have all its own service vehicles adding to the objects used.

2 Likes

I think it would be useful, if all of you are experiencing very bad fps when the airport disappear, to post a screenshot of the DevMode FPS counter, which shows what’s affecting the fps more.

In some tests I made, sometimes the culprit seems to be coherentGTdraw, so you’ll see the message “Limited by coherentGTdraw”, but in other cases I saw the Manipulators having an higher impact, so you’ll see “Limited by MainThread”.

Also, it might be useful to open the DevMode CONSOLE, look for error message and SORT the lines using occurrence column, which might help troubleshooting what objects/vehicles have issues, it’s possible even the logging process itself, when there are many errors, is affecting this.

I can try to gather this information over the next day or so. Thank you for the suggestions. Hopefully others having these issues can do the same.

Would be great to have the relevant ones combined, but I suppose that’s up to the moderators.

Hello all!
Is any of this being noticed in the “base” sim (no addons, no traffic injection addons)?

They need to know if this only happens in the “base” sim.

As far as I know, it does not. It’s being speculated that the problem is with simconnect and a maximum number of objects limit, which would be a base sim issue. It has shown up as a result of simmers using GSX, FSLTL, AIGTC, and so forth.

1 Like

I also do not think so as it seems that the sim runs into a kind of limit.
Whatever limit this is, I can’t say … animations? Objects? Polygons?

When it happens, it doesn’t help to dial down settings, invisible and/or distorted objects do not come back in that session. You have to restart the sim.
When it happens on my departure airport (vanished AI traffic and ground vehicle), then during the flight, AI is also invisible (despite I’m in high altitude and not much ressources are needed) and arrival airport (and others of course) are simply not there any more (or partially)

So I assume, there is a kind of limit that makes the sim stuck in its present state and it is not able to free any more ressources, despite the demands are lower during the flight or by settings for that session.

1 Like

I re-flew ORD-OMA tonight to stress-test the sim and recreate the problem, which was successful. Here are the steps I performed to do this:

  1. Loaded the Fenix A320 at Gate E6 at FSDT ORD with live weather.
  2. Started AIGTC and ran it at 90% traffic.
  3. Went in to GSX setup and chose Dense for passenger timing.
  4. Commenced boarding and fueling.
  5. Pushback and taxi to 9C for departure.
  6. Flew to OMA.

First image shows an empty ORD, even though AIGTC is showing a somewhat full house.

Second image shows an empty ORD after takeoff.

Third image shows the single-digit FPS on short final. The calculated approach speed was much lower than what is shown, and perhaps the Fenix was out-of-sorts as a result of the sim, but not sure on that part.

Fourth image shows that the scenery is just gone, photogrammetry and vegetation remain, and FPS is even lower than on short final.

Fifth image is of the Console view, and slightly better FPS. I forgot to sort by occurrence, so this is what was going on at the time of landing. It seems that the airport scenery was trying to load. I explored the console list in cruise and several errors happened to be related to the Fenix. Keep in mind, this sim issue has also happened to me with the PMDG 738.

Sixth image shows what happened when I exited to main menu. The sim froze while loading and had to CTRL+ALT+DEL to get out. Again, forgot to sort by occurrence, so this is by time. But hey, at least the FPS came back.

1 Like

The most puzzling screenshots are the first ones, because you have good fps, and nothing shows you have any problem with resources: all timings are green and show reasonable values, and you have some VRAM headroom ( 5.3GB used out of 7.0GB usable )

Which means there’s aren’t any reasons why you shouldn’t see AIs or other ground vehicles there.

There’s another path you can check in DevMode, and it’s the Options->Simobjects, it will open a list of all objects in the scene, grouped by category. Try to open those categories, and see if you have some either listed in Red, or with something that looks like a problem, like “invalid object” or “unknown”. This might help finding a problem with Simconnect object creation. It’s best you do this while you are in the “KORD” situation, that is all apparently normal, good fps, but an empty airport even if it was supposed to be full of AI.

The screenshots on arrival, with very bad fps, seems to be caused simply by being too close to VRAM exhaustion, because now your headroom is lower ( 6.1GB out of 6.9 available ) but the most serious thing is the RdrThread, which took only 7 milliseconds at KORD, but not it takes an insanely high value of 99 milliseconds, which added to the other threads, result in such a low fps.

Remember that, for a “perfect” 60 fps, the TOTAL frame time ( adding all threads ) should be under 16.67 milliseconds, and for a perfect 30 fps, it should be under 33.33 msecs so, clearly, if just the rendering thread is taking 1/10th of a seconds by itself, if you add all the other thread times, it’s clear why the fps is so bad.

Now, WHY this is happening, is a completely different issue, which I think only MSFS developers can answer.

I just took at a look at the simobjets list you suggested, and the following images show what I found. Since I’m not a developer, I’m not entirely sure what all of this means, but I enabled the labels for all ‘unknown’ objects. Not a single AI aircraft is showing up, even though AIGTC is showing otherwise, and FPS is lower than yesterday’s test. What’s interesting is the VRAM, right away it’s around 9GB which explains the lower performance.

I understand the reasoning behind the question but, in this case, if the problem at hand is an hard limit over the maximum number of Simobjects created through Simconnect, it’s impossible to replicate it in the base sim, since the base sim doesn’t use Simconnect to create objects.

Not being able to replicate it with the base sim, doesn’t make it any less worth of investigation, because Simconnect is an official part of the sim (regardless if the base sim use it or not), and there are no other published ways to add objects dynamically in the simulation so, if there’s an hard limit on the number of objects created that way it should be:

  • Documented officially in the SDK so, not only developers can have some idea how to adjust their default settings, for example for traffic generation, but users can also read and be aware of it, so if they use multiple add-ons at the same time, they can have some rough idea how to set their settings.

  • There should be a proper Simconnect exception when the limit is reached, so developers can adjust their code accordingly to trap it. Yes, there’s a “Too many objects” exception code, but it doesn’t seem it ever being triggered in this cases.

  • There should be a way for add-ons to know how many objects are already in the scene, which might also help to code some protective behavior against the issue.

  • If the simulator is intentionally removing or not creating new objects because lack of resources, the rules governing this strategy should be documented. As per SDK, is said that objects without LODs are being removed first but, maybe this shouldn’t be the only criteria. From an user point of view, it’s way worse having a whole airport terminal being removed because it doesn’t have LODs, while an AI far away and possibly not even visible, has been preserved just because it a full complement of LODs. I don’t know if the distance from the observer is taken into account when deciding to remove something, but maybe it should be.

  • It doesn’t seem a clear way of recovering from this issue exists, as if Simconnect got “stuck” into not accepting any new objects, and all of the new ones that add-on clients tried to add all returned “Unknown”, at least this is how they are being reported in the Simobjects list in DevMode.

So, please, if this is really a Simconnect issue, it should be investigated as such, that is using add-ons that inject Simobjects, possibly more than one at the same time, for the precise reason to put the simulator under stress intentionally to trigger the problem, and find ways to better help add-ons dealing
with it, like giving better error exceptions, document precisely how many objects can be created, provide ways to check if we are close to approach the limit.

Anything that can help developers write better code to deal with the problem, basically.

6 Likes

I have this issue as well.

I’m curious to know if SU11 addressed the simconnect issue we’re discussing here, as I didn’t see anything specific mentioned in the release notes. Any ideas yet?

Had the issue happen again in SU11, using FSLTL and GSX.