Arrival Airports, Traffic, and FPS Have Disappeared

I re-flew ORD-OMA tonight to stress-test the sim and recreate the problem, which was successful. Here are the steps I performed to do this:

  1. Loaded the Fenix A320 at Gate E6 at FSDT ORD with live weather.
  2. Started AIGTC and ran it at 90% traffic.
  3. Went in to GSX setup and chose Dense for passenger timing.
  4. Commenced boarding and fueling.
  5. Pushback and taxi to 9C for departure.
  6. Flew to OMA.

First image shows an empty ORD, even though AIGTC is showing a somewhat full house.

Second image shows an empty ORD after takeoff.

Third image shows the single-digit FPS on short final. The calculated approach speed was much lower than what is shown, and perhaps the Fenix was out-of-sorts as a result of the sim, but not sure on that part.

Fourth image shows that the scenery is just gone, photogrammetry and vegetation remain, and FPS is even lower than on short final.

Fifth image is of the Console view, and slightly better FPS. I forgot to sort by occurrence, so this is what was going on at the time of landing. It seems that the airport scenery was trying to load. I explored the console list in cruise and several errors happened to be related to the Fenix. Keep in mind, this sim issue has also happened to me with the PMDG 738.

Sixth image shows what happened when I exited to main menu. The sim froze while loading and had to CTRL+ALT+DEL to get out. Again, forgot to sort by occurrence, so this is by time. But hey, at least the FPS came back.

1 Like

The most puzzling screenshots are the first ones, because you have good fps, and nothing shows you have any problem with resources: all timings are green and show reasonable values, and you have some VRAM headroom ( 5.3GB used out of 7.0GB usable )

Which means there’s aren’t any reasons why you shouldn’t see AIs or other ground vehicles there.

There’s another path you can check in DevMode, and it’s the Options->Simobjects, it will open a list of all objects in the scene, grouped by category. Try to open those categories, and see if you have some either listed in Red, or with something that looks like a problem, like “invalid object” or “unknown”. This might help finding a problem with Simconnect object creation. It’s best you do this while you are in the “KORD” situation, that is all apparently normal, good fps, but an empty airport even if it was supposed to be full of AI.

The screenshots on arrival, with very bad fps, seems to be caused simply by being too close to VRAM exhaustion, because now your headroom is lower ( 6.1GB out of 6.9 available ) but the most serious thing is the RdrThread, which took only 7 milliseconds at KORD, but not it takes an insanely high value of 99 milliseconds, which added to the other threads, result in such a low fps.

Remember that, for a “perfect” 60 fps, the TOTAL frame time ( adding all threads ) should be under 16.67 milliseconds, and for a perfect 30 fps, it should be under 33.33 msecs so, clearly, if just the rendering thread is taking 1/10th of a seconds by itself, if you add all the other thread times, it’s clear why the fps is so bad.

Now, WHY this is happening, is a completely different issue, which I think only MSFS developers can answer.

I just took at a look at the simobjets list you suggested, and the following images show what I found. Since I’m not a developer, I’m not entirely sure what all of this means, but I enabled the labels for all ‘unknown’ objects. Not a single AI aircraft is showing up, even though AIGTC is showing otherwise, and FPS is lower than yesterday’s test. What’s interesting is the VRAM, right away it’s around 9GB which explains the lower performance.

I understand the reasoning behind the question but, in this case, if the problem at hand is an hard limit over the maximum number of Simobjects created through Simconnect, it’s impossible to replicate it in the base sim, since the base sim doesn’t use Simconnect to create objects.

Not being able to replicate it with the base sim, doesn’t make it any less worth of investigation, because Simconnect is an official part of the sim (regardless if the base sim use it or not), and there are no other published ways to add objects dynamically in the simulation so, if there’s an hard limit on the number of objects created that way it should be:

  • Documented officially in the SDK so, not only developers can have some idea how to adjust their default settings, for example for traffic generation, but users can also read and be aware of it, so if they use multiple add-ons at the same time, they can have some rough idea how to set their settings.

  • There should be a proper Simconnect exception when the limit is reached, so developers can adjust their code accordingly to trap it. Yes, there’s a “Too many objects” exception code, but it doesn’t seem it ever being triggered in this cases.

  • There should be a way for add-ons to know how many objects are already in the scene, which might also help to code some protective behavior against the issue.

  • If the simulator is intentionally removing or not creating new objects because lack of resources, the rules governing this strategy should be documented. As per SDK, is said that objects without LODs are being removed first but, maybe this shouldn’t be the only criteria. From an user point of view, it’s way worse having a whole airport terminal being removed because it doesn’t have LODs, while an AI far away and possibly not even visible, has been preserved just because it a full complement of LODs. I don’t know if the distance from the observer is taken into account when deciding to remove something, but maybe it should be.

  • It doesn’t seem a clear way of recovering from this issue exists, as if Simconnect got “stuck” into not accepting any new objects, and all of the new ones that add-on clients tried to add all returned “Unknown”, at least this is how they are being reported in the Simobjects list in DevMode.

So, please, if this is really a Simconnect issue, it should be investigated as such, that is using add-ons that inject Simobjects, possibly more than one at the same time, for the precise reason to put the simulator under stress intentionally to trigger the problem, and find ways to better help add-ons dealing
with it, like giving better error exceptions, document precisely how many objects can be created, provide ways to check if we are close to approach the limit.

Anything that can help developers write better code to deal with the problem, basically.

6 Likes

I have this issue as well.

I’m curious to know if SU11 addressed the simconnect issue we’re discussing here, as I didn’t see anything specific mentioned in the release notes. Any ideas yet?

Had the issue happen again in SU11, using FSLTL and GSX.

I had a feeling it wasn’t addressed yet; I suppose we need more votes.

I actually had this happen only using AIG and not GSX. I was trying to fly out of the freeware EGKK by mkvy in the Fenix A320, and the AI traffic injected for a moment, then disappeared. Instead of wasting my time, I exited the flight. There are so many objects at the airport, it must have reached the limit with only the traffic added. I didn’t run developer mode to check, but I recognized the problem starting.

Have now had 5 flights in a row where arrival airport does not load in. Have tried tweaking a bunch of settings with no luck. Anyone else?

Which airports were you departing from, and how dense were your GSX/AI Traffic settings?

I was able to complete a YVR-YEG flight with GSX and AIGTC setting greatly reduced, but they’re smaller airports. I’d really like to use these products to the best of their abilities.

Does anyone know how get this bug logged with the “bug logged” tag? Maybe I have missed a step along the way.

KSRQ by VerticalSim
KLAX by IniBuilds
KPNS by DominicDesign
KBWI by LatinVFR

My FSLTL settings are pretty much in the middle, not too high, not too low and I’ve disabled VFR aircraft as well.The temporarily workaround in the past was to completely quit the GSX app while in flight, then re-launch it once at my destination. That has seemed to stop working.

After stopping use of FSTL and using vatsim, the problem has seemed to have disappeared – which is a bummer because I really love that live traffic.

Just landed at Heathrow from Frankfurt. not the welcome party I expected.


Just experienced this last night on arrival into Justsim LTAI in the Fenix. It’s definitely weird since the default airport is completely suppressed indicating the addon is indeed active, but there’s just bare satellite imagery and PAPIs. ILS was also functional and fine.

Had AIG and GSX active. I hadn’t experienced this with bigger airports until now, but this was my first flight to a big airport in months that was over two hours. I wonder if the length of the flight factors in.

I actually had no fps loss or anything though. Very good and smooth all through approach and landing.

the combination of both can trigger some kind of “object limit” within the Sim. There are some options you have:

  1. Disable ground clutter in the GSX settings
  2. Reduce Density of AIGTC injected traffic
  3. Disable Services in the OCI settings of AIM, run a verify setup and enable Airport Services in the TC Airport Manager Settings.
3 Likes

Just landed at EGSS after flight from Copenhagen. Same welcome party at Stansted.

Same issue today at KPIT, using Fenix A320, GSX Pro, and FSLTL–no terminal building on arrival. I don’t ever recall this happening prior to SU 10, and it seems to have worsened after SU 11. As everyone else here has pointed out, likely due to the Sim object limit. Why would this be implemented now? What is the benefit besides causing issues like this? And importantly, why does this only seem to affect some users and not all?

My guess is those who fly online don’t have the vast amount of traffic objects loaded at any point in time as those who fly offline. Similarly, those who fly out of small airports don’t have this issue compared to those who fly out of large hubs. Unfortunately, the workaround right now is to either reduce settings, or fly with one program or the other. Meanwhile, please vote at the top of this bug report if you haven’t already and send anyone you know over here to vote as well. This needs to get logged.

had the same issue have we got fix or a walk round yet

even tried to load up first at my destnation but still have same issue

this should not be happing

Same issue here, FSimStudios CYVR and Verticalsim KBOI. Both flights included a departure from Inibuilds KLAX.

@karlmemphis87 No fix/workaround that I know of, aside from reducing settings or not using one or more of the addons.

@Regis902 Brave for starting both flights at KLAX. Did you notice that AI traffic wasn’t being injected while you were at LAX?