Asobo Add-Ons (Maverick Dune etc) have no options or FLY - Just a background

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No but same if DEV mode on

Brief description of the issue:

Maverick/Dune/Landing Challenges and Flight Training do not show any options or FLY. Only a background is displayed and the Go Back button

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

On every launch of the sim
1.37.2.0 STEAM version
Empty community folder

PC specs and peripheral set up:

Windows 11 Pro
AMD Ryzen 5 5600X
64GB Ram
NVIDIA RTX 3070

Saitek Pro Rudder Pedals / X56 Rhino Stick / X56 Rhino Throttle

Are you using DX11 or DX12?

Occurs using either DX11 or DX12

Are you using DLSS?

Occurs using NVIDIA DLSS or TAA


:loudspeaker: For anyone who wants to contribute to this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Are you using DX11 or DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:

First thing to double check is whether you went into the marketplace and purchased (free) and downloaded/installed. If you go into the marketplace and it doesn’t say you “own” the add-on, you’ll need to do that before it shows up as usable.
Regards

Hi
Yes all items are Owned, downloaded and installed.

1 Like

Quick question, since we got an update beta release yesterday, did that make any difference with the issue? If it didn’t help, I’ll look at the issue some more. Also, hopefully someone else may come in here with some other ideas. I haven’t seen anyone else this particular issue so far, but will keep looking for resolutions.
Regards

As a “P.S.” I noticed today that Dune had an “update available” in content manager. It looked on my system almost like a full install (although I had it completely in before!?!). You might check that too in case it’s trying to fix an issue today.
Regards
P.S.S. I restarted the sim, and it showed another Dune update in content manager. The second one was just a few Kb, so very small. Everything seems to be loading right on my end now, but I’ll see what happens after I’ve shut it down again and restarted the sim.

Hi,
Thanks for the info. Yes, today I received and update to 1.37.4.0 and there is now an update to Maverick and the Dune expansion says partially installed and has an update, both of which I am doing.

Will let you know if this resolves the issue.

1 Like

OK so after updating, still no Maverick/Dune or Flight Training. Dune still said partially installed. Have now uninstalled Maverick/Dune and restarted the sim. Still no Flight Training available. Will re-install both and see what happens. Might add that I have been using MSFS since it started and use DEV mode frequently. Cannot say that 1.37.x actually caused these issues - they may well have been around for some time. I know that I did use Flight Training some long time ago…

Re-installed Maverick and restarted - no change to Flight Training and Maverick - just a blank screen as before.
Re-installed Dune Expansion and Dune just loops to Content Manager and provides a tiny update ok 900KB. Restart sim and loops back to content manager

The others are just backgrounds with no options. Not sure of the next steps to follow

I got a small update to it yesterday, too. And it seems like every time I go out of Dune (because for some reason it still works for me…) I end up with another small update to Dune. Each of these little updates are just “Kb” sized, but never the same size.
I’m stumped at this point. Everything you’ve done should have resolved the issue. You might just want to go ahead to submit a help ticket and see if they have any better luck. I was really hoping someone else had this issue and got it resolved, and came in with some words of advice.
Hope it works out. If I happen to see/think of anything else, I’ll post back here.
Regards

I did log this with Zendesk but they directed me to post it here. Zendesk did not offer any resolution of any kind. A bit disappointing from that respect as I still have nothing working

1 Like

Well that’s not any kind of “answer”.
I tried to duplicate the problem a couple of different ways, but none of them caused the problem. I remember one of the forum mod’s posting another “help” link, but I didn’t bookmark it. If I remember, it was slightly different than straight “zendesk”. I’ll keep looking/working the issue.
Regards

Thanks. I did see something about deleting FS-Base and some other file but cannot remember exactly what or where. I have a complete backup so guess I could do that and keep testing. I also saw someone say delete C172 but that seems nonsensical. Clearly others have had this issue.
I wonder what XML governs the hooks into the options after selecting Dune etc…

1 Like

It’s a little (or more) frustrating. I’ve seen (as you have I’m sure) several threads about the control profiles, Dune wanting to update a small file every time it’s reflown, etc, but I just can’t find one with your problem specifically, where the screen showed up, but there was nothing behind it.
I know you must be frustrated too. I guess unless someone posts another thread with this or similar issue, we’ll just keep working.
Delete the 172…well that’s not one I have heard of for any issue, and wouldn’t have thought of! :rofl:
Regards
I just keep thinking it’s a folder that got write-protected somehow, or files that got corrupted…but which ones…

One difference I did notice between your screen and mine, other than I have the tutorials, etc is that yours is lacking the “activities” tab at the top of the screen. That’s another lead I’ll try to pursue.
Do you have any of the “activities” listed when you open that box on the opening screen when you start the program?

Regards

No nothing on any of the 3 screens mentioned. No Activities…
Dune now just loops to the Filter content and requests an update so that’s useless.

Hi @Ironpot4070,

Could you try to manually delete the package and to redownload it. If you need any help in where to go to delete this package please let us know.

Regards
The MSFS Team

Hi, I’m having the same issue : update is requested after each launch of the sim for Dune content. I have no access to the activities. I did delete Dune expansion with ingame content manager, redownload it, the bug remains.
I then deleted Dune’s folders directly in Official\OneStore folder and redownloaded it, restart the game : the bug remains.

In content manager, i see a 475.65KB update available, and 951.30KB free disk space required.
After clicking on download, i get a black screen for 1 or 2 sec.
Then the download starts and is only 306.17 KB…
See screenshots below


Thanks for the reply - I used the Content Manager to delete and re-install previously.
Please provide details on how to delete manually.
Also, I have this issue for Dune/Maverick and Flight Training so do we deal with each one separately? If so, I will need instructions to delete each manually.
Just reiterating that this is STEAM version

If you’d like to try deleting manually, you can do so by finding your “Official” folder, which will be in the same folder structure as your “Community” folder. You may have set a custom location for these when you installed the sim. Once you have found your Official folder you can then find any folders related to the Maverick (or other problem DLC) and delete those. Once deleted you can start your sim and attempt to download from the content manager.

We believe this may be due to some missing UI files, potentially if you’ve entered and exited betas multiple times. Nevertheless let us know if the above steps help to fix!

Regards
The MSFS Team

Thanks for the info. I just deleted the DUNE folders as you said and got hit with an update to 1.37.5.0… so presumably it will do that and put Dune back.
What are the folder names for Maverick and the Flight Training?

Deleting the folders for DUNE and the update to 1.37.5.0 did not change anything except that I no longer loop to update for DUNE. I have still only receive a background and no options or FLY on the 3 DLC. Can you suggest specific folders to delete or some other course of action?