ASW doesn't work with OpenXR (Rift S)

You can also use Oculus Debug tool or CLI.

BTW, reading your original post, does Steam VR load when you switch to VR? I ask because I originally opted for Steam VR beta and that caused Steam VR to be used. Probably switched the OpenXR setting in the registry or something. Anyway that results in a big loss in performance.

Probably already have it fixed but thought I’d point it out.

Just to confirm…

We currently have NO fix for the Rift or Rift S?

Yes… If you use the main window settings then it will apply the settings to all games. Same for the Oculus debug tool, it’s a general setting.

What thread are you referencing? I’ve yet to get my Rift S dialed in :confused:

I followed the instructions in this thread VR issues - Oculus Rift S - #95 by chadwpalm by @chadwpalm
and this thread My settings so far for Rift S - #2 by MouthyGrunt97 to a T!

1 Like

My App framerate drops from 90Hz to 30 Hz when it loads inside the cockpit using the oculus Link cable .That is unplayable for VR. I’ve tried changing settings in Oculus, windows, Nvidia and it doesn’t seem to solve the problem. I have even dropped the MSFS settings to the absolute pixelated minimum and it still doesn’t achieve more than 40 Hz. My PC meets the requirements and should easily be achieving 90 Hz, it has no problems playing the most demanding VR games. Something is not right and flying in VR on MFS202 is something I have looked forward to since it’s release.

30FPS is usable if you enable ASW30 which interpolates back up to 60FPS

These instructions may be of assistance. They’re for the CV1, but may be applicable to the Rift s.

Cheers.

How can for the rift S the asw mode in the profile be set to something lower like 27 fps, it only lists auto and 45?

I find better performance with just not even using the tray tool

Welcome to the world of VR flight sims, where none of them can achieve a stable 90fps except for AeroFly FS2. MSFS is a lot like X-Plane, in that the best you can hope for is to get your framerate slightly above 1/2 the display’s refresh rate, and then rely on ASW to interpolate back up to 90. (Or there are a lot of people who run at 45 without ASW, because they prefer the choppiness to the distortions ASW can introduce). Also, it’s a little bit worse than that, because something about the way both MSFS and X-Plane render their environments cause hitching/jerkiness with ASW, which isn’t there on any other games, so people spend endless hours tweaking and adjusting things when the bigger problem is how VR is being rendered by the app. All that said, you can still get a usable result out of them – but you have to accept that 90fps @ 90Hz refresh just isn’t going to happen.

1 Like

The Oculus runtime shortsightedly named the ASW states based on the 90Hz refresh of the original Rift CV1, but despite the names like 45Hz, 30Hz etc; what they really are is 0.5 * refresh, 0.25 * refresh, and so on, where refresh is the native refresh rate of the display (90Hz for Rift CV1, 80Hz for Rift S, and 72/80/90 Hz for Quest 2 which is user-selectable). That said, you’ll notice the Oculus debug tool only has gui dropdowns for 45Hz. If you want the other rates, you have to either enter them via command line, or if you install Oculus Tray Tool it has a dropdown menu for the other options.

Exact! You’ve said.
I use Rift S in ASW30 mode with OTT (27 fps original, ~80 interpolated; I don’t understand how some people prefer to fly without ASW…) and is quite good and smooth in a rectilineal flight almost all the time. Also moving your head. But if you you make a sudden movement of the plane, there will be jumps in the image.
For that same reason, flying with wind is very choppy.
But… in general terms and taking into account many variables, flying in VR in FS2020 is a joy!

1 Like

I tried to lock ASW @ 30fps using OculusDebugToolCli, and checked it was really active in game (it seems to be a hit or miss stuff) using a monitoring tool.

I simply can’t play at such low frequency, make me sick. I can barely support 45fps ASW ON even if Oculus make wonder here but 30fps is a no go. MSFS don’t even use our hardware fully if you monitor it (low CPU and GPU usage and low fps???), I sent a support ticket for that and wait an answer…

For now, even if I love MSFS on monitor, if I want to play in VR I gave up this one as I have all my other sims which run at 90fps supersampling 150%, max settings, without any issue and out of the box (Aerofly FS2, FSX+FlyInside, IL2-Sturmovik, Star War Squadrons, Automobilista 2, rFactor 2, etc.).

I hope Devs will improve our VR experience here, specifically with us Oculus users as it seems we meet more performance problem than other ones.

When I enable ASW, even if I stay perfectly still, there is a wobble effect on the image that is very annoying. Seems like wave ripples on the image or something to that effect. I’ve tried it several times, with several resolutions, but It’s unplayable for me, so distracting and in the long run probably will make me sick. There is much improvement to be done here for sure. My GPU (RTX 360 ti) has headroom, my CPU too, but the experience is suffering like when you lack hardware resources.

Today, after trying ASW30, for a C152 flight, I experienced exactly the same thing and remembered my earlier experiences with ASW.

I experienced this in my Rift, 3-4 years ago, in DCS, especially when looking forward through a spinning propeller at straight lines or lights, and it appears to just be an unwanted feature of ASW.

I therefore simply used the Oculus Tray tool to turn ASW off altogether and the issue was gone. It doesn’t appear to affect the performance or quality of the image, so maybe just try with ASW off.

ASW technology don’t affect performance or quality for sure. What it does is create fake intermediate image with a smart algorithm so your receive 90 fps in your headset in all case (90 for CV1 or 80 for Rift S). It add fluidity and you can see that by rotating around your plane in exterior view. If you can handle real 30fps so you may turn it off effectively.

if you can handle real 30fps so you may turn it off effectively.

You mean, you’re ok with 30fps as a person or if your computer can handle 30 fps?

Obviously your computer must be capable to reach 30fps :wink: Above what I mean is if you feel comfortable playing at 30fps in VR. Some can handle it in VR, I can’t. But I can play a fly sim at 30fps on monitor, it’s far enough to get something smooth. In VR it’s another story as you move your head, so not having, at least for me, 45fps and better with ASW ON (to get 90 fake images), is a no go, it make me sick.

Got it! Shouldn’t be 40 fps with the Rift S? Other question: does the Rift S renders at 1648*1776 per eye (so *2) ?