ATC doesn't say Air Canada correctly?

I want to fly Air Canada routes, so I set the ATC options to be AIRCANADA (it doesn’t allow a space). However, ATC says “cun-a-da” instead of “can-a-da”. So it’ll say Air Cunada 121 do XYZ.

Seems like a minor thing, but it’s been bugging me. When I set Lufhthansa it pronounces it correctly.

Anyone know of a fix?

Also, other Air Canada planes in the sky are correctly addressed. It seems to be related to the lack of a space… I can hear ATC talking to other planes and the text shows up as Air Canada instead of AIRCANADA.

In the screenshot below, Air Canada 1421 is correctly pronounced, but my flight (AIRCANADA 121) is not.

Needs to be logged at Zendesk as a bug, they don’t always see them if they are just posted here

Sure, but is this a bug or is it working as intended - as in, are we not supposed to put in the airline name in the callsign field?

I fixed it - instead of a space, I used a dash (Air-Canada) and it works now.


I have found it amusing in Australia to hear the the sim ATC say "Klink " for Qantas Link flights (Q Link) which are in real world pronounced as “Que Link”. :laughing:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.