ATC menu is grayed out

Help, i installed it twice. Everything is fine. However, I can’t assess the ATC panel from custom toolbar since it gray out. The keybind for ATC panel doesn’t allow to open it as well. Any suggestions? Is this is a bug? I use AI ATC but without the panel showing up.

Bump. Same issue for me. It worked fine when I played the first time, then it failed to work afterwards. The tips are bugging me to communicate with ATC, and I’d love to! Thanks!

Same problem after I changed profiles in the game.

Same here for me. It automatically signed me into a different profile, so I didnt have the Premium content. I had done a few flights no issues before realising, and then switched to my proper account. Premium stuff is there now, but no ATC at all. Regarldess of online/offline, flight plan made etc.

Issue has been posted elsewhere too. I had the same issue, ATC greyed out when I needed to switch xbox profiles. Solution for me was to reset controls to default.

Resetting controls didn’t resolve the issue for me, unfortunately.

Nope - didnt work for me either :frowning:

I’ve just fixed mine!!

I tried this last night but it didn’t work, but I’ve just read another post that helped…

Load up to the main menu, Options, assistance, change the preset to “All assists” - this is the mistake I made last night, I individually changed each setting to on. DONT DO THAT, change the preset at the top of the page!
Apply and save the changes. Close the sim. Restart the PC.
Load up to the main menu again, options, assistance, now change the preset to “True to life” - again making sure you do it via the main preset.
Apply and save, close the sim, restart the the pc again.

Then you should be good to go! Load the sim up, start a flight, and the ATC box should pop up!
Hope this helps you all out, I know how frustrated I’ve been about it, and I’d tried everything up to this point! Its a bit of a ballache with all the restarting, but hey ho, its sorted it for me :slight_smile:


Holy ■■■■ on a cracker, it worked! Woo! Thanks!

1 Like

Worked for me too thanks.

1 Like

This worked for me as well. Thank you so much!

1 Like

Problem fixed! Thanks Sillysimon4… this completely worked!

1 Like

This fix worked a treat!

note: I didn’t need to restart my PC at all, just the sim.

Thank you

Thankyou so much Sillysimon4 this has worked for me, at least till the next update lol

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.