ATC never shuts up

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
no
Are you using Developer Mode or made changes in it?
no
Brief description of the issue:
constant telling pilot plus myself to expedite to the next FL when I’ already there. very annoying
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs for those who want to assist (if not entered in your profile)

Build Version # when you first started experiencing this issue:

Are you on the Steam or Microsoft Store version?

Did you submit this to Zendesk? If so, what is your ticket #?

There’s an issue with how the altimeter is handling the air pressure. The workaround is to go out of the STD altimeter and into whatever they say you are.

For example, if ATC says you are 300 feet above the assigned altitude, change your altimeter so that you are currently 300 feet above your set altitude, then have your autopilot to descend back to it.

Similarly, If ATC says you are 400 feet below the assigned altitude, then change your altimeter again so that you are currently 400 feet below the set altitude, and have your autopilot climb to reach it again.

This should silence the ATC.

Another workaround is to fly with a weather preset on a static altimeter that you set the same the whole way.

ok so let me try to get this straight.

Lets say I’ve just reached my designated FL320 on autopilot. ATC says I’m either X feet above or below my designated FL. I turn off AP, either climb or descend to where ATC says I’m not supposed to be, and then activate back AP and let it take me back to my designated FL320 I was at?

No, that’s not it…

You change the Barometric Selector to make it “look like” you’re X feet above/below the assigned altitude in your PFD. Then you can engage and disenage the AP to let it climb/descent.

This is because the ATC is reading a different barometric selector than what it’s set in you aircraft. So by changing “your” barometric selector, you’re making yours the same as the ATCs, therefore silencing them.

1 Like

ok thanks I get it now. just adjust the barometric selector. I dont gotta touch AP or anything. and just let AP do its thing.

Yep this the workaround, thats great . But how does all this come to this, how does it all get so stuffed up???. Does anyone do any type of testing.? Its ridiculous that from now on everyone is going to cringe when they hear of a new wonderful update. Asobo falt out lied to us all about what they were doing to get incrreased fps.

There’s something wrong with the live weather and how it affects baro, so the altitude readings between your aircraft and ATC gets out of sync. There are other longer threads going into more specifics of what is wrong.

As to how you can workaround it, unfortunately you have to turn off live weather if you want to use ATC. You can kind of work around it by constantly tweaking the baro during flight, but I found this was very hit and miss. Sometimes the difference between your reading and ATC can be large, 2000ft+ above or below.

1 Like

Hello everyone,
We are closing this issue, as there are already two linked threads in the #bugs-and-issues category listing this problem:
Wrong temperatures
ATC telling me I am at the incorrect altitude

A hotfix is on it’s way for this bug. It should drop either Friday or Monday: Regarding Your Feedback + Upcoming Hotfix